Commit 1b50a984 authored by philm's avatar philm

update drivers to .37

parent 6c616cc2
......@@ -9,7 +9,7 @@ source ../_buildscripts/${current_repo}-${_arch}-cfg.conf
pkgname=ndiswrapper
pkgver=1.56
pkgrel=10
pkgrel=11
# Find the kernel name inside the chroot
_kernver=`pacman -Qf kernel26 | cut -c10-15 | sed 's/kernel26 //g'`-CHAKRA
......@@ -19,8 +19,8 @@ license=('GPL')
arch=(i686 x86_64)
url="http://ndiswrapper.sourceforge.net"
install="ndiswrapper.install"
depends=("ndiswrapper-utils=$pkgver" 'kernel26>=2.6.36' 'kernel26<2.6.37')
makedepends=('kernel26-headers>=2.6.36' 'kernel26-headers<2.6.37')
depends=("ndiswrapper-utils=$pkgver" 'kernel26')
makedepends=('kernel26-headers')
source=(http://downloads.sourceforge.net/sourceforge/ndiswrapper/ndiswrapper-$pkgver.tar.gz kernel-2.6.35.patch ndiswrapper-ioctl.patch)
md5sums=('1431f7ed5f8e92e752d330bbb3aed333'
'0a03d613b1fd545a75c5dd1a7c2aaec4'
......
......@@ -2,7 +2,7 @@
post_install()
{
ndiswrapper -m
KERNEL_VERSION='2.6.36-CHAKRA'
KERNEL_VERSION='2.6.37-CHAKRA'
depmod -ae $KERNEL_VERSION > /dev/null 2>&1
}
......@@ -11,13 +11,13 @@ post_install()
post_upgrade()
{
ndiswrapper -m
KERNEL_VERSION='2.6.36-CHAKRA'
KERNEL_VERSION='2.6.37-CHAKRA'
depmod -ae $KERNEL_VERSION > /dev/null 2>&1
}
# arg 1: the old package version
post_remove()
{
KERNEL_VERSION='2.6.36-CHAKRA'
KERNEL_VERSION='2.6.37-CHAKRA'
depmod -ae $KERNEL_VERSION > /dev/null 2>&1
}
......@@ -9,20 +9,20 @@ source ../_buildscripts/${current_repo}-${_arch}-cfg.conf
pkgname=tiacx
pkgver=20080210
pkgrel=22
pkgrel=23
pkgdesc="OpenSource module for Texas Instruments ACX100/ACX111 wireless chips. For stock chakra 2.6 kernel"
arch=(i686 x86_64)
url="http://acx100.sourceforge.net/"
license=('MPL')
depends=('wireless_tools' 'kernel26>=2.6.36' 'kernel26<2.6.37' 'tiacx-firmware')
makedepends=('kernel26-headers>=2.6.36' 'kernel26-headers<2.6.37')
depends=('wireless_tools' 'kernel26' 'tiacx-firmware')
makedepends=('kernel26-headers' 'kernel26-headers')
install=acx.install
source=(http://downloads.sourceforge.net/sourceforge/acx100/acx-$pkgver.tar.bz2
kernel-2.6.27.patch
kernel-2.6.30.patch
kernel-2.6.31.patch
kernel-2.6.33.patch)
_kernver=2.6.36-CHAKRA
_kernver=2.6.37-CHAKRA
build() {
cd $startdir/src/acx-$pkgver
......
# arg 1: the new package version
post_install() {
KERNEL_VERSION='2.6.36-CHAKRA'
KERNEL_VERSION='2.6.37-CHAKRA'
depmod $KERNEL_VERSION > /dev/null 2>&1
}
# arg 1: the new package version
# arg 2: the old package version
post_upgrade() {
KERNEL_VERSION='2.6.36-CHAKRA'
KERNEL_VERSION='2.6.37-CHAKRA'
depmod $KERNEL_VERSION > /dev/null 2>&1
}
# arg 1: the old package version
post_remove() {
KERNEL_VERSION='2.6.36-CHAKRA'
KERNEL_VERSION='2.6.37-CHAKRA'
depmod $KERNEL_VERSION > /dev/null 2>&1
}
......@@ -9,14 +9,14 @@ source ../_buildscripts/${current_repo}-${_arch}-cfg.conf
pkgname=vhba-module
pkgver=1.2.1
_kernver='2.6.36-CHAKRA'
pkgrel=15
_kernver='2.6.37-CHAKRA'
pkgrel=16
pkgdesc="Kernel26 module that emulates SCSI devices"
arch=('i686' 'x86_64')
url="http://cdemu.sourceforge.net/"
license=('GPL2')
depends=('kernel26>=2.6.36' 'kernel26<2.6.37')
makedepends=('kernel26-headers>=2.6.36')
depends=('kernel26')
makedepends=('kernel26-headers')
install=vhba-module.install
source=(http://downloads.sourceforge.net/cdemu/vhba-module-$pkgver.tar.bz2 vhba-kernel26-2.6.34.patch vhba-kernel26-2.6.36.patch)
md5sums=('a3b6ad798f2b72ef599df797ef79e5ec' 'de68d2e744885faade0b03baff52f4a8' '5960ac48a487ff5a4d767ed1f5eaf904')
......
post_install() {
echo ">> Place 'vhba' in MODULES= in /etc/rc.conf to enable vhba on system boot."
echo ">> This module needs to be recompiled for every kernel version upgrade."
KERNEL_VERSION='2.6.36-CHAKRA'
KERNEL_VERSION='2.6.37-CHAKRA'
depmod $KERNEL_VERSION > /dev/null 2>&1
}
......@@ -10,7 +10,7 @@ post_upgrade() {
}
post_remove() {
KERNEL_VERSION='2.6.36-CHAKRA'
KERNEL_VERSION='2.6.37-CHAKRA'
depmod $KERNEL_VERSION > /dev/null 2>&1
}
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment