Commit 48546f8b authored by Chaoting Liu's avatar Chaoting Liu

linux-lts: add config file, update to 4.4.17(2016-08-14 current LTS version),...

linux-lts: add config file, update to 4.4.17(2016-08-14 current LTS version), no build yet as per AlmAck request to study the compatibility furthur
parent e5a7fa76
# Maintainer: Neophytos Kolokotronis <tetris4 AT gmail DOT com>
_extramodules=extramodules-3.14-CHAKRA-LTS
_kver="$(cat /lib/modules/${_extramodules}/version)"
_kernelver=3.14.66
# Source global configuration
source ../linux-lts.conf
pkgname=acpi_call-lts
_pkgname=acpi_call
......
# Maintainer: Neophytos Kolokotronis <tetris4 AT gmail DOT com>
_extramodules=extramodules-3.14-CHAKRA-LTS
_kver="$(cat /lib/modules/${_extramodules}/version)"
_kernelver=3.14.66
# Source global configuration
source ../linux-lts.conf
pkgname=bbswitch-lts
_pkgname=bbswitch
......@@ -18,6 +17,7 @@ depends=("linux-lts=${_kernelver}")
makedepends=("linux-lts-headers=${_kernelver}")
source=("https://github.com/Bumblebee-Project/bbswitch/archive/v${pkgver}.tar.gz")
md5sums=('5b116b31ace3604ddf9d1fc1f4bc5807')
build() {
cd ${srcdir}/${_pkgname}-${pkgver}
make KDIR=/usr/lib/modules/${_kver}/build KVERSION=${_kver}
......
#
# Chakra Packages for Chakra, part of chakraos.org
#
_extramodules=extramodules-3.14-CHAKRA-LTS
_kver="$(cat /lib/modules/${_extramodules}/version)"
_kernelver=3.14.66
# Source global configuration
source ../linux-lts.conf
pkgname=broadcom-wl-lts
pkgver=6.30.223.271
pkgrel=2
pkgrel=3
pkgdesc='Broadcom 802.11abgn hybrid Linux networking device driver'
arch=('x86_64')
url='http://www.broadcom.com/support/802.11/linux_sta.php'
......
# Maintainer: Neophytos Kolokotronis <tetris4 AT gmail DOT com>
_extramodules=extramodules-3.14-CHAKRA-LTS
_kver="$(cat /lib/modules/${_extramodules}/version)"
_kernelver=3.14.66
# Source global configuration
source ../linux-lts.conf
url_ref="http://support.amd.com/en-us/download/desktop?os=Linux+x86"
DLAGENTS="http::/usr/bin/curl --referer ${url_ref} -o %o %u"
......
#
# Chakra GNU/Linux Buildscript Config file
#
# LTS Kernel group
#
# These are the "basic variables" appliable for the LTS kernal group
# Fetch from linux-lts/PKGBUILD
_kernelname="-CHAKRA-LTS"
_basekernel=4.4
_kernelver=4.4.17
# Fetch from vhba-modules-lts/PKGBUILD
_extramodules=extramodules-${_basekernel}${_kernelname}
_kver="$(cat /lib/modules/${_extramodules}/version)"
# Fetch from ndiswrapper-lts/PKGBUILD
_rootOfSourceTree=/usr/src/linux-${_kver}
......@@ -12,7 +12,7 @@
#
#core_packages
#linux-lts
linux-lts
vhba-module-lts
broadcom-wl-lts
acpi_call-lts
......
#
# Core Packages for Chakra, part of chakraos.org
#
# Source global configuration
source ../linux-lts.conf
pkgbase="linux-lts"
pkgname=('linux-lts' 'linux-lts-headers' 'linux-lts-docs')
_kernelname="-CHAKRA-LTS"
_basekernel=3.14
pkgver=3.14.66
pkgver=${_kernelver}
pkgrel=1
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc')
arch=('x86_64')
license=('GPL2')
url="http://www.kernel.org"
options=(!strip)
source=("https://www.kernel.org/pub/linux/kernel/v3.x/linux-$_basekernel.tar.xz"
"https://www.kernel.org/pub/linux/kernel/v3.x/patch-${pkgver}.xz"
source=("https://www.kernel.org/pub/linux/kernel/v4.x/linux-$_basekernel.tar.xz"
"https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
# the main kernel config files
'config.x86_64'
# standard config files for mkinitcpio ramdisk
'linux-lts.preset'
'change-default-console-loglevel.patch')
md5sums=('b621207b3f6ecbb67db18b13258f8ea8'
'0ee585c72b3ebfdfcd68a3e7ed291f19'
'9fd7a4e21d3f8f31fb5baa91c43937f7'
md5sums=('9a78fa2eb6c68ca5a40ed5af08142599'
'12acd9b991b2d369774f262d3bf319dc'
'3c2a6142e569256e1c1774098c745444'
'232b52576a62c7a333e9fe7a1e1ca359'
'98beb36f9b8cf16e58de2483ea9985e3')
'df7fceae6ee5d7e7be7b60ecd7f6bb35')
prepare() {
......@@ -36,6 +33,7 @@ prepare() {
# add latest fixes from stable queue, if needed
# http://git.kernel.org/?p=linux/kernel/git/stable/stable-queue.git
msg 'patch for console loglevel'
# set DEFAULT_CONSOLE_LOGLEVEL to 4 (same value as the 'quiet' kernel param)
# remove this when a Kconfig knob is made available by upstream
# (relevant patch sent upstream: https://lkml.org/lkml/2011/7/26/227)
......@@ -234,9 +232,9 @@ package_linux-lts-headers() {
"${pkgdir}/usr/lib/modules/${_kernver}/build/drivers/media/tuners/"
# add xfs and shmem for aufs building
mkdir -p "${pkgdir}/usr/src/linux-${_kernver}/fs/xfs"
#mkdir -p "${pkgdir}/usr/src/linux-${_kernver}/fs/xfs"
mkdir -p "${pkgdir}/usr/src/linux-${_kernver}/mm"
cp fs/xfs/xfs_sb.h "${pkgdir}/usr/src/linux-${_kernver}/fs/xfs/xfs_sb.h"
#cp fs/xfs/xfs_sb.h "${pkgdir}/usr/src/linux-${_kernver}/fs/xfs/xfs_sb.h"
# copy in Kconfig files
for i in `find . -name "Kconfig*"`; do
......
diff -upr linux-3.0.orig/kernel/printk.c linux-3.0/kernel/printk.c
--- linux-3.0.orig/kernel/printk/printk.c 2011-07-22 05:17:23.000000000 +0300
+++ linux-3.0/kernel/printk/printk.c 2011-07-27 14:43:07.000000000 +0300
@@ -58,7 +58,7 @@ void asmlinkage __attribute__((weak)) ea
/* We show everything that is MORE important than this.. */
#define MINIMUM_CONSOLE_LOGLEVEL 1 /* Minimum loglevel we let people use */
-#define DEFAULT_CONSOLE_LOGLEVEL 7 /* anything MORE serious than KERN_DEBUG */
+#define DEFAULT_CONSOLE_LOGLEVEL 4 /* anything MORE serious than KERN_WARNING */
DECLARE_WAIT_QUEUE_HEAD(log_wait);
--- linux-3.16/include/linux/printk.h.old 2014-08-04 18:48:30.686043266 +0200
+++ linux-3.16/include/linux/printk.h 2014-08-04 18:48:47.706218528 +0200
@@ -37,7 +37,7 @@
#define CONSOLE_LOGLEVEL_SILENT 0 /* Mum's the word */
#define CONSOLE_LOGLEVEL_MIN 1 /* Minimum loglevel we let people use */
#define CONSOLE_LOGLEVEL_QUIET 4 /* Shhh ..., when booted with "quiet" */
-#define CONSOLE_LOGLEVEL_DEFAULT 7 /* anything MORE serious than KERN_DEBUG */
+#define CONSOLE_LOGLEVEL_DEFAULT 4 /* anything MORE serious than KERN_DEBUG */
#define CONSOLE_LOGLEVEL_DEBUG 10 /* issue debug messages */
#define CONSOLE_LOGLEVEL_MOTORMOUTH 15 /* You can't shut this one up */
......@@ -2,7 +2,7 @@
# arg 2: the old package version
KERNEL_NAME=-CHAKRA-LTS
KERNEL_VERSION=3.14.66-1-CHAKRA-LTS
KERNEL_VERSION=4.4.17-1-CHAKRA-LTS
post_install () {
# updating module dependencies
......
# Maintainer: Neophytos Kolokotronis <tetris4 AT gmail DOT com>
_extramodules=extramodules-3.14-CHAKRA-LTS
_kver="$(cat /lib/modules/${_extramodules}/version)"
_kernelver=3.14.66
_rootOfSourceTree=/usr/src/linux-${_kver}
# Source global configuration
source ../linux-lts.conf
pkgname=ndiswrapper-lts
_pkgname=ndiswrapper
pkgver=1.59
pkgrel=8
pkgdesc="Module for NDIS (Windows Network Drivers) drivers supplied by vendors. For linux-testing."
pkgver=1.60
pkgrel=1
pkgdesc="Module for NDIS (Windows Network Drivers) drivers supplied by vendors. For linux-lts."
license=('GPL')
arch=('x86_64')
url="http://ndiswrapper.sourceforge.net"
install="ndiswrapper.install"
depends=("linux-lts=${_kernelver}")
makedepends=("linux-lts-headers=${_kernelver}")
source=("http://downloads.sourceforge.net/sourceforge/ndiswrapper/ndiswrapper-$pkgver.tar.gz"
"ndiswrapper-1.59.patch")
sha1sums=('75fbbda677fe91ee07a6f6a8e19b1f3e2479540f'
'f120e96fa9abab45e1c724aaac29da7b892820f0')
source=("http://downloads.sourceforge.net/sourceforge/ndiswrapper/ndiswrapper-$pkgver.tar.gz")
sha1sums=('20998237cf6d37b86391dc8736c10031110db578')
prepare() {
[ -z "$_kver" ] && error "Could not get kernel version from '/usr/lib/modules/${_extramodules}/version'..." && false
msg "Found kernel version: $_kver"
cd "$srcdir/$_pkgname-$pkgver"
patch -p1 -i ../ndiswrapper-1.59.patch
#patch -p1 -i ../ndiswrapper-1.59.patch
sed -i "/modinfo/s/s/usr\//" driver/Makefile
}
......
# Maintainer: Neophytos Kolokotronis <tetris4 AT gmail DOT com>
_extramodules=extramodules-3.14-CHAKRA-LTS
_kver="$(cat /lib/modules/${_extramodules}/version)"
_kernelver=3.14.66
# Source global configuration
source ../linux-lts.conf
pkgname=nvidia-304xx-lts
pkgver=304.131
pkgrel=1
pkgrel=2
pkgdesc="NVIDIA drivers for linux."
arch=('x86_64')
url="http://www.nvidia.com/"
......
# Maintainer: Neophytos Kolokotronis <tetris4 AT gmail DOT com>
_extramodules=extramodules-3.14-CHAKRA-LTS
_kver="$(cat /lib/modules/${_extramodules}/version)"
_kernelver=3.14.66
# Source global configuration
source ../linux-lts.conf
pkgname=nvidia-340xx-lts
pkgver=340.96
pkgrel=1
pkgrel=2
pkgdesc="NVIDIA drivers for linux."
arch=('x86_64')
url="http://www.nvidia.com/"
......
_extramodules=extramodules-3.14-CHAKRA-LTS
_kernelver=3.14.66
# Source global configuration
source ../linux-lts.conf
pkgname=('nvidia-lts')
pkgdesc=('NVIDIA drivers for linux-lts')
pkgver=364.19
pkgrel=1
pkgrel=2
arch=('x86_64')
url="http://www.nvidia.com/"
depends=("linux-lts=${_kernelver}" "nvidia-libgl" "nvidia-utils=${pkgver}")
......
#
# Chakra Packages for Chakra, part of chakraos.org
#
# Source global configuration
source ../linux-lts.conf
_extramodules=extramodules-3.14-CHAKRA-LTS
_kver="$(cat /lib/modules/${_extramodules}/version)"
_kernelver=3.14.66
pkgname=vhba-module-lts
_pkgname=vhba-module
pkgver=20140928
pkgrel=4
pkgrel=5
pkgdesc="Kernel module that emulates SCSI devices"
arch=('x86_64')
url="http://cdemu.sourceforge.net/"
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment