Commit 5611a451 authored by abveritas's avatar abveritas
Browse files

prep kde 4.10.1, pkrel reset, patches removed

parent 7c07bf6b
......@@ -13,7 +13,7 @@ _origname=common
pkgname=kde-common
arch=('x86_64')
pkgver=${_kdever}
pkgrel=3
pkgrel=1
pkgdesc="KDE SC - Common Configuration Files, Scripts and Artwork"
url="http://www.kde.org"
......
......@@ -3,7 +3,7 @@
#
post_install() {
echo " "
echo " > KDE Software Compilation 4.10.0"
echo " > KDE Software Compilation 4.10.1"
echo " > packaged by The Chakra Project"
echo " "
echo " Installation Prefix : /usr"
......@@ -11,12 +11,12 @@ post_install() {
echo " Update configs : /etc/chakra/updates.conf"
echo " Chakra Patches : /usr/share/chakra/patches"
echo " "
echo " WWW : http://chakra-linux.org"
echo " Wiki : http://chakra-linux.org/wiki/"
echo " Forums : http://chakra-linux.org/bbs/"
echo " Bugtracker: http://chakra-linux.org/bugs/"
echo " CCR : http://chakra-linux.org/ccr/"
echo " Bundles : http://chakra-linux.org/bundles.html"
echo " WWW : http://chakra-project.org"
echo " Wiki : http://chakra-project.org/wiki/"
echo " Forums : http://chakra-project.org/bbs/"
echo " Bugtracker: http://chakra-project.org/bugs/"
echo " CCR : http://chakra-project.org/ccr/"
echo " Bundles : http://chakra-project.org/bundles.html"
echo " ChangeLogs: http://gitorious.org/chakra-packages"
echo " "
}
......
......@@ -10,7 +10,7 @@ source ../_buildscripts/${current_repo}-${_arch}-cfg.conf
pkgname=kdeedu-marble
_pkgname=marble
pkgver=${_kdever}
pkgrel=2
pkgrel=1
pkgdesc="Desktop Globe"
url="http://kde.org/applications/education/marble/"
screenshot="http://www.kde.org/images/screenshots/marble.png"
......
#
# KDE SC Packages for Chakra, part of chakra-project.org
#
# maintainer (i686): Phil Miller <philm[at]chakra-project[dog]org>
# maintainer (x86_64): Manuel Tortosa <manutortosa[at]chakra-project[dot]org>
# include global config
source ../_buildscripts/${current_repo}-${_arch}-cfg.conf
# original name (used for the source and pkgnames)
_origname=libindicate
pkgname=${_origname}
pkgbranch=0.2
pkgver=0.2.3
pkgrel=4
pkgdesc='A small library for applications to raise "flags" on DBus for other components of the desktop to pick up and visualize. (Canonical Ayatana Project)'
arch=('i686' 'x86_64')
url="https://launchpad.net/libindicate"
license=('GPL')
depends=('glib2' 'dbus-glib' 'libxml2') # 'gtk2'
makedepends=()
groups=("kde-uninstall" "kde-support")
options=('!splitdbg' '!splithdr')
source=(http://launchpad.net/${_origname}/${pkgbranch}/${pkgver}/+download/${_origname}-${pkgver}.tar.gz
disable-libindicate-gtk-gtk-docs.patch disable-unneeded-stuff.patch)
md5sums=('c32f2cdd85534feea4a5ebd532ede641' # libindicate-0.2.3.tar.gz
'e307519e046c0cdb6a9928128044166e' # disable-libindicate-gtk-gtk-docs.patch
'0f8fe75f84a2f41b4c3ec700c07bb820') # disable-unneeded-stuff.patch
build() {
cd "$srcdir"/${_origname}-$pkgver
patch -Np0 -i "${srcdir}/../disable-unneeded-stuff.patch" || return 1
patch -Np0 -i "${srcdir}/../disable-libindicate-gtk-gtk-docs.patch" || return 1
./configure --prefix=/usr --disable-static --disable-gtk-doc --disable-gobject-introspection || return 1
make || return 1
make DESTDIR="$pkgdir" install || return 1
# cleanup docs
rm -R "$pkgdir"/usr/share
}
--- configure.orig 2010-06-18 15:38:44.674558460 +0200
+++ configure 2010-06-18 15:43:58.033698697 +0200
@@ -11556,138 +11556,6 @@ $as_echo "yes" >&6; }
fi
-
-GDK_PIXBUF_REQUIRED_VERSION=2.12
-
-
-pkg_failed=no
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for LIBINDICATEGTK" >&5
-$as_echo_n "checking for LIBINDICATEGTK... " >&6; }
-
-if test -n "$PKG_CONFIG"; then
- if test -n "$LIBINDICATEGTK_CFLAGS"; then
- pkg_cv_LIBINDICATEGTK_CFLAGS="$LIBINDICATEGTK_CFLAGS"
- else
- if test -n "$PKG_CONFIG" && \
- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"glib-2.0 >= \$GLIB_REQUIRED_VERSION
- gio-2.0 >= \$GIO_REQUIRED_VERSION
- gdk-pixbuf-2.0 >= \$GDK_PIXBUF_REQUIRED_VERSION
- gtk+-2.0 >= \$GTK_REQUIRED_VERSION
- dbus-glib-1 >= \$DBUS_REQUIRED_VERSION\""; } >&5
- ($PKG_CONFIG --exists --print-errors "glib-2.0 >= $GLIB_REQUIRED_VERSION
- gio-2.0 >= $GIO_REQUIRED_VERSION
- gdk-pixbuf-2.0 >= $GDK_PIXBUF_REQUIRED_VERSION
- gtk+-2.0 >= $GTK_REQUIRED_VERSION
- dbus-glib-1 >= $DBUS_REQUIRED_VERSION") 2>&5
- ac_status=$?
- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
- test $ac_status = 0; }; then
- pkg_cv_LIBINDICATEGTK_CFLAGS=`$PKG_CONFIG --cflags "glib-2.0 >= $GLIB_REQUIRED_VERSION
- gio-2.0 >= $GIO_REQUIRED_VERSION
- gdk-pixbuf-2.0 >= $GDK_PIXBUF_REQUIRED_VERSION
- gtk+-2.0 >= $GTK_REQUIRED_VERSION
- dbus-glib-1 >= $DBUS_REQUIRED_VERSION" 2>/dev/null`
-else
- pkg_failed=yes
-fi
- fi
-else
- pkg_failed=untried
-fi
-if test -n "$PKG_CONFIG"; then
- if test -n "$LIBINDICATEGTK_LIBS"; then
- pkg_cv_LIBINDICATEGTK_LIBS="$LIBINDICATEGTK_LIBS"
- else
- if test -n "$PKG_CONFIG" && \
- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"glib-2.0 >= \$GLIB_REQUIRED_VERSION
- gio-2.0 >= \$GIO_REQUIRED_VERSION
- gdk-pixbuf-2.0 >= \$GDK_PIXBUF_REQUIRED_VERSION
- gtk+-2.0 >= \$GTK_REQUIRED_VERSION
- dbus-glib-1 >= \$DBUS_REQUIRED_VERSION\""; } >&5
- ($PKG_CONFIG --exists --print-errors "glib-2.0 >= $GLIB_REQUIRED_VERSION
- gio-2.0 >= $GIO_REQUIRED_VERSION
- gdk-pixbuf-2.0 >= $GDK_PIXBUF_REQUIRED_VERSION
- gtk+-2.0 >= $GTK_REQUIRED_VERSION
- dbus-glib-1 >= $DBUS_REQUIRED_VERSION") 2>&5
- ac_status=$?
- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
- test $ac_status = 0; }; then
- pkg_cv_LIBINDICATEGTK_LIBS=`$PKG_CONFIG --libs "glib-2.0 >= $GLIB_REQUIRED_VERSION
- gio-2.0 >= $GIO_REQUIRED_VERSION
- gdk-pixbuf-2.0 >= $GDK_PIXBUF_REQUIRED_VERSION
- gtk+-2.0 >= $GTK_REQUIRED_VERSION
- dbus-glib-1 >= $DBUS_REQUIRED_VERSION" 2>/dev/null`
-else
- pkg_failed=yes
-fi
- fi
-else
- pkg_failed=untried
-fi
-
-
-
-if test $pkg_failed = yes; then
-
-if $PKG_CONFIG --atleast-pkgconfig-version 0.20; then
- _pkg_short_errors_supported=yes
-else
- _pkg_short_errors_supported=no
-fi
- if test $_pkg_short_errors_supported = yes; then
- LIBINDICATEGTK_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "glib-2.0 >= $GLIB_REQUIRED_VERSION
- gio-2.0 >= $GIO_REQUIRED_VERSION
- gdk-pixbuf-2.0 >= $GDK_PIXBUF_REQUIRED_VERSION
- gtk+-2.0 >= $GTK_REQUIRED_VERSION
- dbus-glib-1 >= $DBUS_REQUIRED_VERSION"`
- else
- LIBINDICATEGTK_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "glib-2.0 >= $GLIB_REQUIRED_VERSION
- gio-2.0 >= $GIO_REQUIRED_VERSION
- gdk-pixbuf-2.0 >= $GDK_PIXBUF_REQUIRED_VERSION
- gtk+-2.0 >= $GTK_REQUIRED_VERSION
- dbus-glib-1 >= $DBUS_REQUIRED_VERSION"`
- fi
- # Put the nasty error message in config.log where it belongs
- echo "$LIBINDICATEGTK_PKG_ERRORS" >&5
-
- as_fn_error "Package requirements (glib-2.0 >= $GLIB_REQUIRED_VERSION
- gio-2.0 >= $GIO_REQUIRED_VERSION
- gdk-pixbuf-2.0 >= $GDK_PIXBUF_REQUIRED_VERSION
- gtk+-2.0 >= $GTK_REQUIRED_VERSION
- dbus-glib-1 >= $DBUS_REQUIRED_VERSION) were not met:
-
-$LIBINDICATEGTK_PKG_ERRORS
-
-Consider adjusting the PKG_CONFIG_PATH environment variable if you
-installed software in a non-standard prefix.
-
-Alternatively, you may set the environment variables LIBINDICATEGTK_CFLAGS
-and LIBINDICATEGTK_LIBS to avoid the need to call pkg-config.
-See the pkg-config man page for more details.
-" "$LINENO" 5
-elif test $pkg_failed = untried; then
- { { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
-$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
-as_fn_error "The pkg-config script could not be found or is too old. Make sure it
-is in your PATH or set the PKG_CONFIG environment variable to the full
-path to pkg-config.
-
-Alternatively, you may set the environment variables LIBINDICATEGTK_CFLAGS
-and LIBINDICATEGTK_LIBS to avoid the need to call pkg-config.
-See the pkg-config man page for more details.
-
-To get pkg-config, see <http://pkg-config.freedesktop.org/>.
-See \`config.log' for more details." "$LINENO" 5; }
-else
- LIBINDICATEGTK_CFLAGS=$pkg_cv_LIBINDICATEGTK_CFLAGS
- LIBINDICATEGTK_LIBS=$pkg_cv_LIBINDICATEGTK_LIBS
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
-$as_echo "yes" >&6; }
- :
-fi
-
-
-
###########################
# GObject Introspection
###########################
@@ -11905,33 +11773,6 @@ fi
-gdu_cv_version_required=0.3.2
-
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking gnome-doc-utils >= $gdu_cv_version_required" >&5
-$as_echo_n "checking gnome-doc-utils >= $gdu_cv_version_required... " >&6; }
-if test -n "$PKG_CONFIG" && \
- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"gnome-doc-utils >= \$gdu_cv_version_required\""; } >&5
- ($PKG_CONFIG --exists --print-errors "gnome-doc-utils >= $gdu_cv_version_required") 2>&5
- ac_status=$?
- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
- test $ac_status = 0; }; then
- gdu_cv_have_gdu=yes
-else
- gdu_cv_have_gdu=no
-fi
-
-if test "$gdu_cv_have_gdu" = "yes"; then
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
-$as_echo "yes" >&6; }
- :
-else
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
-$as_echo "no" >&6; }
- as_fn_error "gnome-doc-utils >= $gdu_cv_version_required not found" "$LINENO" 5
-fi
-
-
-
# Check whether --with-help-dir was given.
if test "${with_help_dir+set}" = set; then :
withval=$with_help_dir;
@@ -12174,7 +12015,7 @@ _ACEOF
# Files
###########################
-ac_config_files="$ac_config_files Makefile libindicate/Makefile libindicate/indicate.pc libindicate-gtk/Makefile libindicate-gtk/indicate-gtk.pc examples/Makefile tests/Makefile docs/Makefile docs/reference/Makefile docs/reference/version.xml"
+ac_config_files="$ac_config_files Makefile libindicate/Makefile libindicate/indicate.pc examples/Makefile tests/Makefile docs/Makefile docs/reference/Makefile docs/reference/version.xml"
cat >confcache <<\_ACEOF
# This file is a shell script that caches the results of configure
@@ -13171,8 +13012,6 @@ do
"Makefile") CONFIG_FILES="$CONFIG_FILES Makefile" ;;
"libindicate/Makefile") CONFIG_FILES="$CONFIG_FILES libindicate/Makefile" ;;
"libindicate/indicate.pc") CONFIG_FILES="$CONFIG_FILES libindicate/indicate.pc" ;;
- "libindicate-gtk/Makefile") CONFIG_FILES="$CONFIG_FILES libindicate-gtk/Makefile" ;;
- "libindicate-gtk/indicate-gtk.pc") CONFIG_FILES="$CONFIG_FILES libindicate-gtk/indicate-gtk.pc" ;;
"examples/Makefile") CONFIG_FILES="$CONFIG_FILES examples/Makefile" ;;
"tests/Makefile") CONFIG_FILES="$CONFIG_FILES tests/Makefile" ;;
"docs/Makefile") CONFIG_FILES="$CONFIG_FILES docs/Makefile" ;;
--- Makefile.am.orig 2010-06-18 16:05:45.237734713 +0200
+++ Makefile.am 2010-06-18 16:07:24.701055207 +0200
@@ -1,9 +1,6 @@
SUBDIRS = \
libindicate \
- libindicate-gtk \
- examples \
- tests \
docs
EXTRA_DIST = \
--- Makefile.in.orig 2010-06-18 16:16:02.327669832 +0200
+++ Makefile.in 2010-06-18 16:16:20.357668793 +0200
@@ -256,9 +256,6 @@ top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
SUBDIRS = \
libindicate \
- libindicate-gtk \
- examples \
- tests \
docs
EXTRA_DIST = \
--- configure.ac.orig 2010-06-18 16:03:02.550252963 +0200
+++ configure.ac 2010-06-18 16:04:54.760240964 +0200
@@ -33,22 +33,9 @@ AC_SUBST(LIBINDICATE_REVISION)
AC_SUBST(LIBINDICATE_AGE)
###########################
-# Libindicate versioning
-###########################
-
-LIBINDICATEGTK_CURRENT=1
-LIBINDICATEGTK_REVISION=0
-LIBINDICATEGTK_AGE=0
-
-AC_SUBST(LIBINDICATEGTK_CURRENT)
-AC_SUBST(LIBINDICATEGTK_REVISION)
-AC_SUBST(LIBINDICATEGTK_AGE)
-
-###########################
# Dependencies
###########################
-GTK_REQUIRED_VERSION=2.12
DBUS_REQUIRED_VERSION=0.76
GLIB_REQUIRED_VERSION=2.18
GIO_REQUIRED_VERSION=2.18
@@ -61,16 +48,6 @@ PKG_CHECK_MODULES(LIBINDICATE, glib-2.0
AC_SUBST(LIBINDICATE_CFLAGS)
AC_SUBST(LIBINDICATE_LIBS)
-GDK_PIXBUF_REQUIRED_VERSION=2.12
-
-PKG_CHECK_MODULES(LIBINDICATEGTK, glib-2.0 >= $GLIB_REQUIRED_VERSION
- gio-2.0 >= $GIO_REQUIRED_VERSION
- gdk-pixbuf-2.0 >= $GDK_PIXBUF_REQUIRED_VERSION
- gtk+-2.0 >= $GTK_REQUIRED_VERSION
- dbus-glib-1 >= $DBUS_REQUIRED_VERSION)
-AC_SUBST(LIBINDICATEGTK_CFLAGS)
-AC_SUBST(LIBINDICATEGTK_LIBS)
-
###########################
# GObject Introspection
###########################
@@ -160,10 +137,6 @@ AC_OUTPUT([
Makefile
libindicate/Makefile
libindicate/indicate.pc
-libindicate-gtk/Makefile
-libindicate-gtk/indicate-gtk.pc
-examples/Makefile
-tests/Makefile
docs/Makefile
docs/reference/Makefile
docs/reference/version.xml
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment