Commit 665cd62e authored by AlmAck's avatar AlmAck

linux kernel LTS 4.4.110

parent 49839d63
......@@ -6,7 +6,7 @@ source ../linux-lts.conf
pkgname=acpi_call-lts
_pkgname=acpi_call
pkgver=1.1.0
pkgrel=6
pkgrel=7
pkgdesc="A kernel module that enables you to call parameterless ACPI methods by writing the method name to /proc/acpi/call, e.g. to turn off discrete graphics card in a dual graphics environment (like NVIDIA Optimus)."
arch=('x86_64')
url=("http://github.com/mkottman/acpi_call")
......
......@@ -6,7 +6,7 @@ source ../linux-lts.conf
pkgname=bbswitch-lts
_pkgname=bbswitch
pkgver=0.8
pkgrel=9
pkgrel=10
pkgdesc="kernel module allowing to switch dedicated graphics card on Optimus laptops"
arch=('x86_64')
url=("http://github.com/Bumblebee-Project/bbswitch")
......
......@@ -3,7 +3,7 @@ source ../linux-lts.conf
pkgname=broadcom-wl-lts
pkgver=6.30.223.271
pkgrel=5
pkgrel=6
pkgdesc='Broadcom 802.11abgn hybrid Linux networking device driver'
arch=('x86_64')
url='http://www.broadcom.com/support/802.11/linux_sta.php'
......
......@@ -6,7 +6,7 @@
# These are the "basic variables" appliable for the LTS kernal group
_kernelname="-CHAKRA-LTS"
_kernelver=4.4.93
_kernelver=4.4.110
_basekernel=4.4
_extramodules=extramodules-${_basekernel}${_kernelname}
......
......@@ -20,7 +20,7 @@ source=(http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.{xz,sign}
change-default-console-loglevel.patch)
md5sums=('9a78fa2eb6c68ca5a40ed5af08142599'
'SKIP'
'9ea16f52e9e01f5c1fb1cf3cfdff5468'
'0cab97888a42703dfff4d78f814176ec'
'SKIP'
'3aa1cc30eaab983fa01acfd2188bfa8a'
'232b52576a62c7a333e9fe7a1e1ca359'
......
#
# Automatically generated file; DO NOT EDIT.
# Linux/x86 4.4.6-1 Kernel Configuration
# Linux/x86 4.4.110-1 Kernel Configuration
#
CONFIG_64BIT=y
CONFIG_X86_64=y
......@@ -51,7 +51,7 @@ CONFIG_BUILDTIME_EXTABLE_SORT=y
CONFIG_INIT_ENV_ARG_LIMIT=32
CONFIG_CROSS_COMPILE=""
# CONFIG_COMPILE_TEST is not set
CONFIG_LOCALVERSION="-lts"
CONFIG_LOCALVERSION="-CHAKRA-LTS"
# CONFIG_LOCALVERSION_AUTO is not set
CONFIG_HAVE_KERNEL_GZIP=y
CONFIG_HAVE_KERNEL_BZIP2=y
......@@ -795,7 +795,6 @@ CONFIG_IA32_EMULATION=y
CONFIG_COMPAT=y
CONFIG_COMPAT_FOR_U64_ALIGNMENT=y
CONFIG_SYSVIPC_COMPAT=y
CONFIG_KEYS_COMPAT=y
CONFIG_X86_DEV_DMA_OPS=y
CONFIG_PMC_ATOM=y
CONFIG_NET=y
......@@ -1383,7 +1382,6 @@ CONFIG_OPENVSWITCH_VXLAN=m
CONFIG_OPENVSWITCH_GENEVE=m
CONFIG_VSOCKETS=m
CONFIG_VMWARE_VMCI_VSOCKETS=m
CONFIG_NETLINK_MMAP=y
CONFIG_NETLINK_DIAG=m
CONFIG_MPLS=y
CONFIG_NET_MPLS_GSO=m
......@@ -1918,7 +1916,7 @@ CONFIG_HMC6352=m
CONFIG_DS1682=m
# CONFIG_TI_DAC7512 is not set
CONFIG_VMWARE_BALLOON=m
CONFIG_BMP085=y
CONFIG_BMP085=m
CONFIG_BMP085_I2C=m
# CONFIG_BMP085_SPI is not set
CONFIG_USB_SWITCH_FSA9480=m
......@@ -7324,12 +7322,14 @@ CONFIG_DEFAULT_IO_DELAY_TYPE=0
# Security options
#
CONFIG_KEYS=y
CONFIG_KEYS_COMPAT=y
CONFIG_PERSISTENT_KEYRINGS=y
CONFIG_BIG_KEYS=y
CONFIG_TRUSTED_KEYS=m
CONFIG_ENCRYPTED_KEYS=m
# CONFIG_SECURITY_DMESG_RESTRICT is not set
CONFIG_SECURITY=y
CONFIG_PAGE_TABLE_ISOLATION=y
CONFIG_SECURITYFS=y
# CONFIG_SECURITY_NETWORK is not set
CONFIG_SECURITY_PATH=y
......
......@@ -6,7 +6,7 @@ source ../linux-lts.conf
pkgname=ndiswrapper-lts
_pkgname=ndiswrapper
pkgver=1.61
pkgrel=2
pkgrel=3
pkgdesc="Module for NDIS (Windows Network Drivers) drivers supplied by vendors. For linux-lts."
license=('GPL')
arch=('x86_64')
......
......@@ -5,11 +5,11 @@ source ../linux-lts.conf
pkgname=nvidia-304xx-lts
pkgver=304.137
pkgrel=1
pkgrel=2
pkgdesc="NVIDIA drivers for linux."
arch=('x86_64')
url="http://www.nvidia.com/"
depends=("linux-lts=${_kernelver}" "nvidia-304xx-libgl" "nvidia-304xx-utils=${pkgver}")
depends=("linux-lts=${_kernelver}" "nvidia-304xx-utils=${pkgver}")
makedepends=("linux-lts-headers=${_kernelver}")
conflicts=('nvidia-340xx-lts' 'nvidia-lts')
license=('custom')
......
......@@ -5,7 +5,7 @@ source ../linux-lts.conf
pkgname=nvidia-340xx-lts
pkgver=340.104
pkgrel=1
pkgrel=2
pkgdesc="NVIDIA drivers for linux."
arch=('x86_64')
url="http://www.nvidia.com/"
......
......@@ -3,11 +3,11 @@ source ../linux-lts.conf
pkgname=('nvidia-lts')
pkgdesc=('NVIDIA drivers for linux-lts')
pkgver=387.22
pkgver=387.34
pkgrel=1
arch=('x86_64')
url="http://www.nvidia.com/"
depends=("linux-lts=${_kernelver}" "nvidia-utils=${pkgver}" libgl)
depends=("linux-lts=${_kernelver}" "nvidia-utils=${pkgver}" 'libglvnd')
makedepends=("linux-lts-headers=${_kernelver}")
install=nvidia.install
license=('custom')
......@@ -17,7 +17,7 @@ _pkg="NVIDIA-Linux-x86_64-${pkgver}-no-compat32"
source=("http://us.download.nvidia.com/XFree86/Linux-x86_64/${pkgver}/NVIDIA-Linux-x86_64-${pkgver}-no-compat32.run")
#source=("NVIDIA-Linux-x86_64-${pkgver}.run::https://developer.nvidia.com/linux64bit")
md5sums=('b21f9bafb20409b337505c9b1d362c34')
md5sums=('a009bbc502c30e4b483d71be9fa51790')
prepare() {
sh "${_pkg}.run" --extract-only
......
......@@ -5,7 +5,7 @@ source ../linux-lts.conf
pkgname=vhba-module-lts
_pkgname=vhba-module
pkgver=20170610
pkgrel=1
pkgrel=2
pkgdesc="Kernel module that emulates SCSI devices"
arch=('x86_64')
url="http://cdemu.sourceforge.net/"
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment