Commit 6fbe0135 authored by Phil's avatar Phil
Browse files

nvidia: update to 290.10

chakra-hwd: adopt nvidia
parent 21463c8c
......@@ -8,7 +8,7 @@
source ../_buildscripts/${current_repo}-${_arch}-cfg.conf
pkgname=chakra-hardware-detection
pkgver=20111023
pkgver=20111122
pkgrel=1
pkgdesc="Hardware detection scripts for Chakra"
arch=('any')
......
......@@ -9,7 +9,7 @@ HW_DB_PATH="/opt/chakra/hwdb"
# VERSION OF THE "NVIDIA" DRIVER PKG
# (keep in sync with postinstall config)
NVIDIA_DRV_VER="285"
NVIDIA_DRV_VER="290"
# NVIDIA HW DATABASE FILE NAME
NV_DB="hw_nvidia_hwdb"
......
......@@ -8,7 +8,7 @@
_kernver="2.6.35-CHAKRA-LTS"
pkgname=nvidia-lts
pkgver=285.05.09
pkgver=290.10
pkgrel=1
pkgdesc="NVIDIA drivers for kernel26."
arch=('i686' 'x86_64')
......@@ -20,15 +20,15 @@ license=('custom')
install=nvidia.install
if [ "$CARCH" = "i686" ]; then
ARCH='x86'
_pkg="NVIDIA-Linux-${ARCH}-${pkgver}"
source=("http://us.download.nvidia.com/XFree86/Linux-${ARCH}/${pkgver}/${_pkg}.run")
md5sums=('2d469a90abef50320f548cfa8085e3a0')
_ARCH='x86'
_pkg="NVIDIA-Linux-${_ARCH}-${pkgver}"
source=("ftp://download.nvidia.com/XFree86/Linux-${_ARCH}/${pkgver}/${_pkg}.run")
md5sums=('50319a4b3818c12c9c7243525e0e6316')
elif [ "$CARCH" = "x86_64" ]; then
ARCH='x86_64'
_pkg="NVIDIA-Linux-${ARCH}-${pkgver}-no-compat32"
source=("http://us.download.nvidia.com/XFree86/Linux-${ARCH}/${pkgver}/${_pkg}.run")
md5sums=('2f4a0e78f5560c07220b7ed6fc1e27aa')
_ARCH='x86_64'
_pkg="NVIDIA-Linux-${_ARCH}-${pkgver}-no-compat32"
source=("ftp://download.nvidia.com/XFree86/Linux-${_ARCH}/${pkgver}/${_pkg}.run")
md5sums=('cebfba9a7e91716a06c66bb5b38d9661')
fi
build() {
......
......@@ -5,8 +5,8 @@
# maintainer (x86_64): Manuel Tortosa <manutortosa[at]chakra-project[dot]org>
pkgname=('nvidia-utils')
pkgver=285.05.09
pkgrel=3
pkgver=290.10
pkgrel=1
arch=('i686' 'x86_64')
url="http://www.nvidia.com/"
license=('custom')
......@@ -28,11 +28,11 @@ md5sums=('541cb36684b6764ccba73d7afe268bf5'
if [ "${CARCH}" = "i686" ]; then
ARCH='x86'
_pkg="NVIDIA-Linux-${ARCH}-${pkgver}"
md5sums[2]='2d469a90abef50320f548cfa8085e3a0'
md5sums[2]='50319a4b3818c12c9c7243525e0e6316'
elif [ "${CARCH}" = "x86_64" ]; then
ARCH='x86_64'
_pkg="NVIDIA-Linux-${ARCH}-${pkgver}-no-compat32"
md5sums[2]='2f4a0e78f5560c07220b7ed6fc1e27aa'
md5sums[2]='cebfba9a7e91716a06c66bb5b38d9661'
fi
source[2]="http://us.download.nvidia.com/XFree86/Linux-${ARCH}/${pkgver}/${_pkg}.run"
......
......@@ -8,8 +8,8 @@
_kernver=$(pacman -Q linux | cut -c7-9 | sed 's/linux //g')-CHAKRA
pkgname=nvidia
pkgver=285.05.09
pkgrel=3
pkgver=290.10
pkgrel=1
pkgdesc="NVIDIA drivers for linux."
arch=('i686' 'x86_64')
url="http://www.nvidia.com/"
......@@ -20,15 +20,15 @@ license=('custom')
install=nvidia.install
if [ "$CARCH" = "i686" ]; then
ARCH='x86'
_pkg="NVIDIA-Linux-${ARCH}-${pkgver}"
source=("http://us.download.nvidia.com/XFree86/Linux-${ARCH}/${pkgver}/${_pkg}.run")
md5sums=('2d469a90abef50320f548cfa8085e3a0')
_ARCH='x86'
_pkg="NVIDIA-Linux-${_ARCH}-${pkgver}"
source=("ftp://download.nvidia.com/XFree86/Linux-${_ARCH}/${pkgver}/${_pkg}.run")
md5sums=('50319a4b3818c12c9c7243525e0e6316')
elif [ "$CARCH" = "x86_64" ]; then
ARCH='x86_64'
_pkg="NVIDIA-Linux-${ARCH}-${pkgver}-no-compat32"
source=("http://us.download.nvidia.com/XFree86/Linux-${ARCH}/${pkgver}/${_pkg}.run")
md5sums=('2f4a0e78f5560c07220b7ed6fc1e27aa')
_ARCH='x86_64'
_pkg="NVIDIA-Linux-${_ARCH}-${pkgver}-no-compat32"
source=("ftp://download.nvidia.com/XFree86/Linux-${_ARCH}/${pkgver}/${_pkg}.run")
md5sums=('cebfba9a7e91716a06c66bb5b38d9661')
fi
build() {
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment