Commit 74ad4c9f authored by AlmAck's avatar AlmAck

pacman-helpme removed [skip-ci]

parent 63edc921
Pipeline #2729 skipped
#
# Core Packages for Chakra, part of chakra-project.org
#
# maintainer: abveritas@chakra-project.org
pkgname=pacman-helpme
pkgver=2013.01
pkgrel=1
pkgdesc="Scripts to assist with conflicts in updates"
arch=('x86_64')
url="http://www.chakra-project.org"
license=('GPL2')
depends=('filesystem')
makedepends=('asciidoc')
install=pacman-helpme.install
source=('pacman-helpme')
md5sums=('5c13e46fecfe8ae9f448338fadc905ea')
package() {
cd ${srcdir}
# setup /etc
mkdir ${pkgdir}/etc
install -m644 -t ${pkgdir}/etc pacman-helpme
}
#!/bin/bash
# Any needed instructions or command for updates
\ No newline at end of file
#!/bin/bash
# tputcolors
post_install() {
post_upgrade
}
post_upgrade() {
# remove symlinks from old talloc 2.0.1
if [ "$(pacman -Q talloc | cut -d " " -f2 | cut -d "-" -f1)" = "2.0.1" ] ; then
echo -e '\e[31;46m WARNING'
echo -e '\e[31;46m Talloc is an old package that created symlinks, which pacman does not recognize as belonging to talloc'
echo -e '\e[31;46m How to handle this update:'
echo -e '\e[31;46m sudo pacman -S talloc --force'
echo -e '\e[31;46m sudo pacman -Syu \e[0m'
fi
# getty@.service file conflict on updating to systemd-197
if [ "$(pacman -Q systemd | cut -d " " -f2 | cut -d "-" -f1)" = "196" ] ; then
echo -e '\e[31;46m WARNING'
echo -e '\e[31;46m To get all the way in line with upstream, in Systemd 196 getty@.service build'
echo -e '\e[31;46m inclusion was changed, so the symlink was owned by systemd, but that created a file conflict.'
echo -e '\e[31;46m It was masked in that update, this update it is no longer masked.'
echo -e '\e[31;46m How to handle this update:'
echo -e '\e[31;46m sudo pacman -S systemd --force'
echo -e '\e[31;46m sudo pacman -Syu \e[0m'
fi
}
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment