Commit 82389129 authored by Manuel's avatar Manuel

Fix path

parent ccea9b95
......@@ -5,7 +5,7 @@
pkgname=pacman
pkgver=4.1.0
pkgrel=2
pkgrel=3
pkgdesc="A library-based package manager with dependency support"
arch=('x86_64')
url="http://www.archlinux.org/pacman/"
......@@ -35,7 +35,7 @@ build() {
./configure --prefix=/usr --sysconfdir=/etc \
--localstatedir=/var --enable-doc \
--with-scriptlet-shell=/usr/bin/bash \
--with-scriptlet-shell=/bin/bash \
--with-ldconfig=/usr/bin/ldconfig
make
make -C contrib
......
#!/bin/sh
# tputcolors
# arg 1: the new package version
# arg 2: the old package version
post_upgrade() {
......@@ -7,6 +6,15 @@ post_upgrade() {
if [ "$(vercmp $2 3.0.2)" -lt 0 ]; then
_resetbackups
fi
if [ "$(vercmp $2 3.5.0)" -lt 0 ]; then
_warnupgrade
fi
}
_warnupgrade() {
echo ">>> The pacman database format has changed as of pacman 3.5.0."
echo ">>> You will need to run \`pacman-db-upgrade\` as root."
echo ">>>"
}
_resetbackups() {
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment