Commit 8a300d33 authored by totte's avatar totte

kdenetwork-krfb: Rename to krfb

parent 30fa6489
# Maintainer: H W Tovetjärn (totte) <totte@tott.es>
# Contributors: Manuel Tortosa <manutortosa@chakra-project.org>
# Include global configuration
source ../_buildscripts/${current_repo}-${_arch}-cfg.conf
pkgname="krfb"
arch=('x86_64')
pkgver=${_kdever}
pkgrel=1
pkgdesc="Desktop Sharing Server"
# note on libxdamage:
# not detected by namcap because libgl depends on it
# but nvidia providing libgl does not depend on libxdamage
depends=("kde-runtime>=${_kdever}" "kdelibs>=${_kdever}" 'libvncserver' 'libxdamage')
groups=("kde" "kdenetwork" "kde-uninstall")
categories=('network')
conflicts=("kdenetwork-common" "kdenetwork-doc" "kdenetwork-krfb")
replaces=("kdenetwork-krfb")
provides=("kdenetwork-krfb")
install=kdenetwork.install
url="http://www.kde.org"
license=('GPL' 'LGPL' 'FDL')
options=('docs' '!header' 'debug' 'log')
makedepends=('pkg-config' 'cmake' 'automoc4' 'docbook-xsl')
source=("$_mirror/${_pkgname}-$_kdever.tar.xz")
sha256sums=(`grep ${_pkgname}-$_kdever.tar.xz ../checksums.txt | cut -d " " -f1`)
build() {
cd ${srcdir}/${_pkgname}-${pkgver}
cmake . \
-DCMAKE_BUILD_TYPE=${_build_type} \
-DCMAKE_INSTALL_PREFIX=${_installprefix} \
-DCMAKE_SKIP_RPATH=ON \
-DCMAKE_{SHARED,MODULE,EXE}_LINKER_FLAGS='-Wl,--no-undefined -Wl,--as-needed'
make
}
package() {
cd ${srcdir}/${_pkgname}-${pkgver}
make DESTDIR=${pkgdir} install
}
post_install() {
if [ -e "/etc/chakra/updates.conf" ] ; then
. /etc/chakra/updates.conf
if [ "$UPDATE_XDG_ICON_DB" = "yes" ]; then
/usr/bin/chakra-update-icons
fi
if [ "$UPDATE_GLOBAL_CONFIG" = "yes" ]; then
/usr/bin/chakra-update-sycoca
fi
if [ "$UPDATE_USER_CONFIG" = "yes" ]; then
/usr/bin/chakra-update-user-sycoca
fi
else
echo " > WARNING"
echo " The package kde-common seems not to be installed,"
echo " this can possibly break the installation. Just install it"
echo " manually after this installation/update, run the following"
echo " commands and restart KDE afterwards:"
echo " sudo chakra-config-updater"
echo " kbuildsycoca4"
echo " "
fi
}
post_upgrade() {
if [ -e "/etc/chakra/updates.conf" ] ; then
. /etc/chakra/updates.conf
if [ "$UPDATE_XDG_ICON_DB" = "yes" ]; then
/usr/bin/chakra-update-icons
fi
if [ "$UPDATE_GLOBAL_CONFIG" = "yes" ]; then
/usr/bin/chakra-update-sycoca
fi
if [ "$UPDATE_USER_CONFIG" = "yes" ]; then
/usr/bin/chakra-update-user-sycoca
fi
else
echo " > WARNING"
echo " The package kde-common seems not to be installed,"
echo " this can possibly break the installation. Just install it"
echo " manually after this installation/update, run the following"
echo " commands and restart KDE afterwards:"
echo " sudo chakra-config-updater"
echo " kbuildsycoca4"
echo " "
fi
}
post_remove() {
if [ -e "/etc/chakra/updates.conf" ] ; then
. /etc/chakra/updates.conf
if [ "$UPDATE_XDG_ICON_DB" = "yes" ]; then
/usr/bin/chakra-update-icons
fi
if [ "$UPDATE_GLOBAL_CONFIG" = "yes" ]; then
/usr/bin/chakra-update-sycoca
fi
if [ "$UPDATE_USER_CONFIG" = "yes" ]; then
/usr/bin/chakra-update-user-sycoca
fi
else
echo " > WARNING"
echo " The package kde-common seems not to be installed,"
echo " this can possibly break the installation. Just install it"
echo " manually after this installation/update, run the following"
echo " commands and restart KDE afterwards:"
echo " sudo chakra-config-updater"
echo " kbuildsycoca4"
echo " "
fi
}
op=$1
shift
$op $*
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment