Commit 8c9b99aa authored by Neofytos Kolokotronis's avatar Neofytos Kolokotronis

ffmpeg-compat: removed as obsolete

parent 5460f229
#contributions from Arch: https://projects.archlinux.org/svntogit/packages.git/tree/trunk?h=packages/ffmpeg-compat
pkgname=ffmpeg-compat
pkgver=0.10.16
pkgrel=1
pkgdesc='Complete and free Internet live audio and video broadcasting solution'
arch=('x86_64')
url='http://ffmpeg.org/'
license=('GPL')
depends=('alsa-lib' 'bzip2' 'gsm' 'lame' 'libass'
'libmodplug' 'libpulse' 'libtheora' 'libva' 'libvorbis' 'libvpx'
'opencore-amr' 'openjpeg' 'rtmpdump' 'schroedinger' 'sdl' 'speex'
'v4l-utils' 'x264' 'xvidcore' 'zlib')
makedepends=('libvdpau' 'yasm')
source=(http://ffmpeg.org/releases/ffmpeg-$pkgver.tar.bz2)
sha256sums=('e77823cbd58dfdb61f88059476070bc432d80e3821c14abcf804ef709d2f3fd1')
build() {
cd ffmpeg-$pkgver
CFLAGS+=" -I/usr/include/openjpeg-1.5" \
./configure \
--prefix=/usr \
--incdir=/usr/include/ffmpeg-compat \
--libdir=/usr/lib/ffmpeg-compat \
--shlibdir=/usr/lib/ffmpeg-compat \
--disable-debug \
--disable-static \
--enable-gpl \
--enable-libass \
--enable-libfreetype \
--enable-libgsm \
--enable-libmodplug \
--enable-libmp3lame \
--enable-libopencore_amrnb \
--enable-libopencore_amrwb \
--enable-libopenjpeg \
--enable-libpulse \
--enable-librtmp \
--enable-libschroedinger \
--enable-libspeex \
--enable-libtheora \
--enable-libv4l2 \
--enable-libvorbis \
--enable-libvpx \
--enable-libx264 \
--enable-libxvid \
--enable-postproc \
--enable-runtime-cpudetect \
--enable-shared \
--enable-vdpau \
--enable-version3 \
--enable-x11grab
make
}
package() {
cd ffmpeg-$pkgver
make DESTDIR="$pkgdir" install
rm -rf "$pkgdir"/usr/{bin,share}
install -dm755 "$pkgdir"/etc/ld.so.conf.d/
echo -e '/usr/lib/\n/usr/lib/ffmpeg-compat/' > "$pkgdir"/etc/ld.so.conf.d/$pkgname.conf
}
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment