Commit b2001fe3 authored by Xuetian Weng's avatar Xuetian Weng
Browse files

fix polkit-qt4 replace

parent 26095f67
...@@ -6,12 +6,12 @@ pkgbase=polkit-qt ...@@ -6,12 +6,12 @@ pkgbase=polkit-qt
pkgname=('polkit-qt4' 'polkit-qt5') pkgname=('polkit-qt4' 'polkit-qt5')
pkgver=0.112.0 pkgver=0.112.0
# we use 0.x since it's not released yet # we use 0.x since it's not released yet
pkgrel=0.1 pkgrel=1
pkgdesc='A library that allows developers to access PolicyKit API with a nice Qt-style API' pkgdesc='A library that allows developers to access PolicyKit API with a nice Qt-style API'
arch=('i686' 'x86_64') arch=('i686' 'x86_64')
url='https://projects.kde.org/projects/kdesupport/polkit-qt-1' url='https://projects.kde.org/projects/kdesupport/polkit-qt-1'
license=('LGPL') license=('LGPL')
makedepends=('cmake' 'automoc4' 'polkit' 'qt4' 'qt5-base') makedepends=('cmake' 'automoc4' 'polkit' 'qt' 'qt5-base')
source=("http://download.kde.org/stable/apps/KDE4.x/admin/${pkgbase}-1-${pkgver}.tar.bz2" source=("http://download.kde.org/stable/apps/KDE4.x/admin/${pkgbase}-1-${pkgver}.tar.bz2"
'systembus-usage.patch') 'systembus-usage.patch')
md5sums=('bee71b71c12797e6fc498540a06c829b' md5sums=('bee71b71c12797e6fc498540a06c829b'
...@@ -42,10 +42,10 @@ build() { ...@@ -42,10 +42,10 @@ build() {
} }
package_polkit-qt4() { package_polkit-qt4() {
depends=('polkit' 'qt4') depends=('polkit' 'qt')
replaces=('polkit-qt') replaces=("polkit-qt<${pkgver}")
provides=('polkit-qt') provides=("polkit-qt=${pkgver}")
conflicts=('polkit-qt') conflicts=("polkit-qt<${pkgver}")
cd build cd build
make DESTDIR="${pkgdir}" install make DESTDIR="${pkgdir}" install
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment