Commit b6cbd42a authored by abveritas's avatar abveritas

deleted obsolete nvidia-96xx-lts, nvidia & madwifi lts packages rebuild

parent 2d8fdafa
......@@ -10,7 +10,7 @@ _kver="$(cat /lib/modules/${_extramodules}/version)"
pkgname=madwifi-lts
pkgver=0.9.4.4173
_ver=0.9.4-r4173-20111008
pkgrel=5
pkgrel=6
pkgdesc="Madwifi drivers for Atheros wireless chipsets"
arch=('x86_64')
license=('GPL')
......
......@@ -8,29 +8,23 @@ _extramodules=extramodules-3.0-lts
_kver="$(cat /lib/modules/${_extramodules}/version)"
pkgname=nvidia-173xx-lts
pkgver=173.14.35
pkgrel=4
arch=('i686' 'x86_64')
[ "$CARCH" = "i686" ] && ARCH=x86
[ "$CARCH" = "x86_64" ] && ARCH=x86_64
pkgver=173.14.36
pkgrel=1
arch=('x86_64')
ARCH=x86_64
url="http://www.nvidia.com/"
depends=('linux-lts>=3.0' 'linux-lts<3.1' 'nvidia-173xx-utils')
makedepends=('linux-lts-headers')
conflicts=('nvidia-96xx-lts' 'nvidia-lts')
license=('custom')
install=nvidia.install
source=("http://download.nvidia.com/XFree86/Linux-$ARCH/${pkgver}/NVIDIA-Linux-$ARCH-${pkgver}-pkg0.run"
"ftp://download.nvidia.com/XFree86/patches/security/2012-08-01/nvidia-blacklist-vga-pmu-registers-195.diff")
md5sums=('0fa45e6fc23a2dc69faa8a66ae0e0cc5')
[ "$CARCH" = "x86_64" ] && md5sums=('6934b522d2cf313ae6e94e25763fe1a8')
md5sums+=('4d9eeb020da469b6c75cab6e05f4cf77')
source=("http://download.nvidia.com/XFree86/Linux-$ARCH/${pkgver}/NVIDIA-Linux-$ARCH-${pkgver}-pkg0.run")
md5sums=('c341612429c2885980103b40542cb2b2')
build() {
sh "NVIDIA-Linux-$ARCH-${pkgver}-pkg0.run" --extract-only
cd "NVIDIA-Linux-$ARCH-${pkgver}-pkg0"
# apply security patch "http://nvidia.custhelp.com/app/answers/detail/a_id/3140"
patch -p0 < "${srcdir}/nvidia-blacklist-vga-pmu-registers-195.diff"
cd "usr/src/nv/"
ln -s Makefile.kbuild Makefile
make SYSSRC=/lib/modules/${_kver}/build module
......
......@@ -4,12 +4,11 @@
# maintainer abveritas@chakra-project.org
pkgname=nvidia-173xx-utils
pkgver=173.14.35
pkgver=173.14.36
pkgrel=1
pkgdesc="NVIDIA drivers utilities and libraries, 173xx branch."
arch=('i686' 'x86_64')
[ "$CARCH" = "i686" ] && ARCH=x86
[ "$CARCH" = "x86_64" ] && ARCH=x86_64
arch=('x86_64')
ARCH=x86_64
url="http://www.nvidia.com/"
depends=('xorg-server')
conflicts=('nvidia-utils' 'libgl')
......@@ -19,8 +18,7 @@ license=('custom')
install=nvidia.install
options=(!strip)
source=("http://download.nvidia.com/XFree86/Linux-${ARCH}/${pkgver}/NVIDIA-Linux-${ARCH}-${pkgver}-pkg0.run")
md5sums=('0fa45e6fc23a2dc69faa8a66ae0e0cc5')
[ "$CARCH" = "x86_64" ] && md5sums=('6934b522d2cf313ae6e94e25763fe1a8')
md5sums=('c341612429c2885980103b40542cb2b2')
package() {
cd $srcdir
......
#
# Chakra Packages for Chakra, part of chakra-project.org
#
# maintainer (i686): Phil Miller <philm[at]chakra-project[dog]org>
# maintainer (x86_64): Manuel Tortosa <manutortosa[at]chakra-project[dot]org>
# Find the kernel name inside the chroot
_extramodules=extramodules-`pacman -Q linux-lts | cut -c11-13 | sed 's/linux-lts //g'`-CHAKRA-LTS
_kver="$(cat /lib/modules/${_extramodules}/version)"
pkgname=nvidia-96xx-lts
pkgver=96.43.20
pkgrel=3
pkgdesc="NVIDIA drivers for kernel26, 96xx branch."
arch=('i686' 'x86_64')
[ "$CARCH" = "i686" ] && ARCH=x86
[ "$CARCH" = "x86_64" ] && ARCH=x86_64
url="http://www.nvidia.com/"
depends=('linux-lts>=3.0' 'linux-lts<3.1' 'nvidia-96xx-utils')
makedepends=('linux-lts-headers')
conflicts=('nvidia-lts' 'nvidia-173xx-lts')
license=('custom')
install=nvidia.install
source=("http://download.nvidia.com/XFree86/Linux-$ARCH/${pkgver}/NVIDIA-Linux-$ARCH-${pkgver}-pkg0.run")
md5sums=('875cc011385ea26ab5edd54a9b65a003')
[ "$CARCH" = "x86_64" ] && md5sums=('df3c87005487bdf54a6c5b783ff373db')
build() {
sh "NVIDIA-Linux-$ARCH-${pkgver}-pkg0.run" --extract-only
cd "NVIDIA-Linux-$ARCH-${pkgver}-pkg0/usr/src/nv/"
ln -s Makefile.kbuild Makefile
make SYSSRC=/lib/modules/${_kver}/build module
}
package() {
cd "NVIDIA-Linux-$ARCH-${pkgver}-pkg0/usr/src/nv/"
mkdir -p $pkgdir//lib/modules/${_extramodules}
install -m644 nvidia.ko $pkgdir/lib/modules/${_extramodules}
install -d -m755 "${pkgdir}/etc/modprobe.d"
sed -i -e "s/EXTRAMODULES='.*'/EXTRAMODULES='${_extramodules}'/" "${startdir}/nvidia.install"
gzip "${pkgdir}/lib/modules/${_extramodules}/nvidia.ko"
}
post_install() {
EXTRAMODULES='extramodules-3.0-CHAKRA-LTS'
depmod $(cat /lib/modules/$EXTRAMODULES/version)
echo 'In order to use nvidia module, reboot the system.'
echo "blacklist nouveau" > "/etc/modprobe.d/nouveau_blacklist.conf"
}
post_upgrade() {
EXTRAMODULES='extramodules-3.0-CHAKRA-LTS'
depmod $(cat /lib/modules/$EXTRAMODULES/version)
echo "blacklist nouveau" > "/etc/modprobe.d/nouveau_blacklist.conf"
}
post_remove() {
EXTRAMODULES='extramodules-3.0-CHAKRA-LTS'
depmod $(cat /lib/modules/$EXTRAMODULES/version)
rm "/etc/modprobe.d/nouveau_blacklist.conf"
}
\ No newline at end of file
......@@ -9,7 +9,7 @@ _kver="$(cat /lib/modules/${_extramodules}/version)"
pkgname=nvidia-lts
pkgver=310.19
pkgrel=1
pkgrel=2
pkgdesc="NVIDIA drivers for linux."
arch=('x86_64')
url="http://www.nvidia.com/"
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment