Commit b8eea051 authored by Xuetian Weng's avatar Xuetian Weng

rebuild kernel module against new kernel

parent 6e73fad9
......@@ -2,19 +2,20 @@
_extramodules=extramodules-3.2-lts
_kver="$(cat /lib/modules/${_extramodules}/version)"
_kernelver=3.2.63
pkgname=bbswitch-lts
_pkgname=bbswitch
pkgver=0.8
pkgrel=2
pkgrel=3
pkgdesc="kernel module allowing to switch dedicated graphics card on Optimus laptops"
arch=('x86_64')
url=("http://github.com/Bumblebee-Project/bbswitch")
license=('GPL')
provides=('bbswitch')
install=bbswitch.install
depends=('linux-lts>=3.2' 'linux-lts<3.4')
makedepends=('linux-lts' 'linux-lts-headers')
depends=("linux-lts=${_kernelver}")
makedepends=("linux-lts-headers=${_kernelver}")
source=("https://github.com/Bumblebee-Project/bbswitch/archive/v${pkgver}.tar.gz")
md5sums=('5b116b31ace3604ddf9d1fc1f4bc5807')
build() {
......
......@@ -3,17 +3,18 @@
_extramodules=extramodules-3.16-CHAKRA
_kver="$(cat /lib/modules/${_extramodules}/version)"
_kernelver=3.16.3
pkgname=bbswitch
pkgver=0.8
pkgrel=7
pkgrel=8
pkgdesc="kernel module allowing to switch dedicated graphics card on Optimus laptops"
arch=('x86_64')
url=("http://github.com/Bumblebee-Project/bbswitch")
license=('GPL')
install=bbswitch.install
depends=('linux>=3.16' 'linux<3.17')
makedepends=('linux' 'linux-headers')
depends=("linux>=${_kernelver}")
makedepends=("linux-headers=${_kernelver}")
source=("https://github.com/Bumblebee-Project/bbswitch/archive/v${pkgver}.tar.gz")
md5sums=('5b116b31ace3604ddf9d1fc1f4bc5807')
......
......@@ -2,21 +2,22 @@
_extramodules=extramodules-3.2-lts
_kernver="$(cat /usr/lib/modules/${_extramodules}/version)"
_kernelver=3.2.63
url_ref="http://support.amd.com/en-us/download/desktop?os=Linux+x86"
DLAGENTS="http::/usr/bin/curl --referer ${url_ref} -o %o %u"
pkgname=catalyst-lts
pkgver=14.4
pkgrel=2
pkgrel=3
_amdver=14.10.1006.1001
pkgdesc="AMD/ATI Catalyst drivers for linux. fglrx kernel module only"
arch=('x86_64')
url="http://www.amd.com"
screenshot="http://linuxtation3.files.wordpress.com/2007/03/pantallazo.jpg"
license=('custom')
depends=('linux-lts>=3.2' 'linux-lts<3.4' 'catalyst-utils')
makedepends=('gcc-libs' 'gcc>4.0.0' 'make' 'linux-lts-headers')
depends=("linux-lts=${_kernelver}" 'linux-lts<3.4' 'catalyst-utils')
makedepends=('gcc-libs' 'gcc>4.0.0' 'make' "linux-lts-headers=${_kernelver}")
conflicts=('catalyst-test' 'nvidia' 'xf86-video-ati' 'xf86-video-radeonhd')
install=catalyst.install
source=(http://www2.ati.com/drivers/linux/amd-catalyst-${pkgver/./-}-rev2-linux-x86-x86-64-may6.zip
......
......@@ -4,17 +4,21 @@
_extramodules=extramodules-3.16-CHAKRA
_kernver=$(cat /usr/lib/modules/${_extramodules}/version)
_kernelver=3.16.3
pkgname=(catalyst chd-catalyst)
pkgver=14.4
pkgrel=5
pkgrel=6
_amdver=14.10.1006.1001
pkgdesc="AMD/ATI Catalyst drivers for linux. fglrx kernel module only. Radeons HD 2 3 4 xxx ARE NOT SUPPORTED"
screenshot="http://linuxtation3.files.wordpress.com/2007/03/pantallazo.jpg"
arch=('x86_64')
url="http://www.amd.com"
license=('custom')
makedepends=('gcc-libs' 'gcc>4.0.0' 'make' 'linux-headers')
makedepends=('gcc-libs' 'gcc>4.0.0' 'make' "linux-headers=${_kernelver}")
url_ref="http://support.amd.com/en-us/download/desktop?os=Linux+x86"
DLAGENTS="http::/usr/bin/curl --referer ${url_ref} -o %o %u"
source=(
http://www2.ati.com/drivers/linux/amd-catalyst-${pkgver/./-}-rev2-linux-x86-x86-64-may6.zip
......@@ -81,7 +85,7 @@ build() {
package_catalyst() {
pkgdesc="AMD/ATI Catalyst drivers for linux. fglrx kernel module only"
screenshot="http://linuxtation3.files.wordpress.com/2007/03/pantallazo.jpg"
depends=('linux>=3.16' 'linux<3.17' 'catalyst-utils')
depends=("linux=${_kernelver}" 'catalyst-utils')
conflicts=('nvidia' 'xf86-video-ati' 'xf86-video-radeonhd' 'catalyst-legacy')
install=catalyst.install
......
KERNEL_VERSION=3.16.2-1-CHAKRA
KERNEL_VERSION=3.16.3-1-CHAKRA
remove_hook(){
......
......@@ -2,16 +2,17 @@
_extramodules=extramodules-3.16-CHAKRA
_kver=$(cat /usr/lib/modules/${_extramodules}/version)
_kernelver=3.16.3
pkgname=lirc-utils
pkgver=0.9.1
pkgrel=4
pkgrel=5
pkgdesc="Linux Infrared Remote Control utils"
arch=('x86_64')
url="http://www.lirc.org/"
license=('GPL')
depends=('alsa-lib' 'libx11' 'libftdi' 'linux')
makedepends=('help2man' 'linux-headers>=3.16' 'linux-headers<3.17' 'python2' 'libtool')
depends=('alsa-lib' 'libx11' 'libftdi' "linux=${_kernelver}")
makedepends=('help2man' "linux-headers=${_kernelver}" 'python2' 'libtool')
optdepends=('python2: pronto2lirc utility')
replaces=('lirc+pctv')
backup=('etc/lirc/lirc_options.conf' 'etc/lirc/lircd.conf' 'etc/lirc/lircmd.conf')
......
......@@ -3,17 +3,18 @@
# Find the kernel name inside the chroot
_extramodules=extramodules-3.2-lts
_kver="$(cat /usr/lib/modules/${_extramodules}/version)"
_kernelver=3.2.63
pkgname=madwifi-lts
pkgver=0.9.4.4182
_ver=r4182-20140204
pkgrel=2
pkgrel=3
pkgdesc="Madwifi drivers for Atheros wireless chipsets"
arch=('x86_64')
license=('GPL')
url="http://madwifi-project.org"
depends=('madwifi-utils' 'linux-lts>=3.2' 'linux-lts<3.4')
makedepends=('linux-lts-headers' 'sharutils')
depends=('madwifi-utils' "linux-lts=${_kernelver}")
makedepends=("linux-lts-headers=${_kernelver}" 'sharutils')
install=madwifi-ng.install
# subversion source: svn checkout http:/madwifi-project.org/svn/madwifi/trunk madwifi
source=(http://snapshots.madwifi-project.org/madwifi-0.9.4-current.tar.gz)
......
......@@ -4,15 +4,16 @@
# Find the kernel name inside the chroot
_extramodules=extramodules-3.2-lts
_kver="$(cat /usr/lib/modules/${_extramodules}/version)"
_kernelver=3.2.63
pkgname=nvidia-173xx-lts
pkgver=173.14.39
pkgrel=3
pkgrel=4
pkgdesc="NVIDIA drivers for linux - LTS package"
arch=('x86_64')
url="http://www.nvidia.com/"
depends=('linux-lts>=3.2' 'linux-lts<3.4' 'nvidia-173xx-utils')
makedepends=('linux-lts-headers')
depends=("linux-lts=${_kernelver}" 'nvidia-173xx-utils')
makedepends=("linux-lts-headers=${_kernelver}")
conflicts=('nvidia-96xx-lts' 'nvidia-lts')
license=('custom')
install=nvidia.install
......
......@@ -2,13 +2,14 @@
_extramodules=extramodules-3.16-CHAKRA
_kver="$(cat /usr/lib/modules/${_extramodules}/version)"
_kernelver=3.16.3
pkgname=(nvidia-173xx chd-nvidia-173xx)
pkgver=173.14.39
pkgrel=3
pkgrel=4
arch=('x86_64')
url="http://www.nvidia.com/"
makedepends=('linux-headers>=3.16' 'linux-headers<3.17')
makedepends=("linux-headers=${_kernelver}")
license=('custom')
source=("http://download.nvidia.com/XFree86/Linux-$arch/${pkgver}/NVIDIA-Linux-$arch-${pkgver}-pkg0.run"
"linux-3.14.patch"
......@@ -31,7 +32,7 @@ build() {
package_nvidia-173xx() {
pkgdesc="Legacy NVIDIA drivers for linux."
depends=('linux>=3.16' 'linux<3.17' 'nvidia-173xx-utils')
depends=("linux=${_kernelver}" 'nvidia-173xx-utils')
conflicts=('nvidia-96xx' 'nvidia')
install=nvidia.install
......
......@@ -3,15 +3,16 @@
# Find the kernel name inside the chroot
_extramodules=extramodules-3.2-lts
_kver="$(cat /usr/lib/modules/${_extramodules}/version)"
_kernelver=3.2.63
pkgname=nvidia-304xx-lts
pkgver=304.123
pkgrel=1
pkgrel=2
pkgdesc="NVIDIA drivers for linux."
arch=('x86_64')
url="http://www.nvidia.com/"
depends=('linux-lts>=3.2' 'linux-lts<3.4' "nvidia-304xx-utils=${pkgver}")
makedepends=('linux-lts-headers')
depends=("linux-lts=${_kernelver}" "nvidia-304xx-utils=${pkgver}")
makedepends=("linux-lts-headers=${_kernelver}")
conflicts=('nvidia-96xx-lts' 'nvidia-173xx-lts' 'nvidia-lts')
license=('custom')
install=nvidia.install
......
......@@ -2,13 +2,14 @@
_extramodules=extramodules-3.16-CHAKRA
_kver=$(cat /usr/lib/modules/${_extramodules}/version)
_kernelver=3.16.3
pkgname=('nvidia-304xx' 'chd-nvidia-304xx')
pkgver=304.123
pkgrel=2
pkgrel=3
arch=('x86_64')
url="http://www.nvidia.com/"
makedepends=('linux-headers' 'linux>=3.16' 'linux<3.17' "nvidia-304xx-utils=${pkgver}")
makedepends=("linux-headers=${_kernelver}" "linux=${_kernelver}" "nvidia-304xx-utils=${pkgver}")
license=('custom')
source=("https://gitorious.org/chakra/chakra-hardware-detection/blobs/raw/master/hwdb/nvidia_supported")
_pkg="NVIDIA-Linux-${arch}-${pkgver}-no-compat32"
......@@ -26,7 +27,7 @@ build() {
package_nvidia-304xx() {
pkgdesc="NVIDIA drivers for linux."
depends=('linux>=3.16' 'linux<3.17' "nvidia-304xx-utils=${pkgver}")
depends=('linux=3.16.3' "nvidia-304xx-utils=${pkgver}")
conflicts=('nvidia-96xx' 'nvidia-173xx' 'nvidia')
install=nvidia.install
......
......@@ -3,21 +3,22 @@
# Find the kernel name inside the chroot
_extramodules=extramodules-3.2-lts
_kver="$(cat /usr/lib/modules/${_extramodules}/version)"
_kernelver=3.2.63
pkgname=nvidia-lts
pkgver=340.32
pkgrel=2
pkgver=340.46
pkgrel=1
pkgdesc="NVIDIA drivers for linux."
arch=('x86_64')
url="http://www.nvidia.com/"
depends=('linux-lts>=3.2' 'linux-lts<3.4' "nvidia-utils=${pkgver}")
makedepends=('linux-lts-headers')
depends=("linux-lts=${_kernelver}" "nvidia-utils=${pkgver}")
makedepends=("linux-lts-headers=${_kernelver}")
conflicts=('nvidia-96xx-lts' 'nvidia-173xx-lts')
license=('custom')
install=nvidia.install
_pkg="NVIDIA-Linux-${_arch}-${pkgver}-no-compat32"
source=("http://us.download.nvidia.com/XFree86/Linux-${_arch}/${pkgver}/${_pkg}.run")
md5sums=('baea4c968a06d3eddec8fb1287bb38bb')
md5sums=('bf40adc20ac9819b5f86cd91f6409e39')
build() {
cd "${srcdir}"
......
......@@ -5,7 +5,7 @@ pkgbase=nvidia-utils
pkgname=('nvidia-utils' 'nvidia-libgl' 'opencl-nvidia' 'libcl')
# Edit chakra-hardware-detection/hooks/hwdetect_7_graphics on version jump from 3xx.xx
# Update nvidia-settings too
pkgver=340.32
pkgver=340.46
pkgrel=1
arch=('x86_64')
url="http://www.nvidia.com/"
......@@ -16,7 +16,7 @@ ARCH='x86_64'
_pkg="NVIDIA-Linux-${ARCH}-${pkgver}-no-compat32"
source=("ftp://download.nvidia.com/XFree86/Linux-${ARCH}/${pkgver}/${_pkg}.run")
md5sums=('baea4c968a06d3eddec8fb1287bb38bb')
md5sums=('bf40adc20ac9819b5f86cd91f6409e39')
create_links() {
# create soname links
......
......@@ -3,13 +3,15 @@
_extramodules=extramodules-3.16-CHAKRA
_kver=$(cat /usr/lib/modules/${_extramodules}/version)
_kernelver=3.16.3
pkgname=('nvidia' 'chd-nvidia')
pkgver=340.32
pkgrel=3
pkgver=340.46
pkgrel=1
arch=('x86_64')
url="http://www.nvidia.com/"
makedepends=('linux-headers>=3.16' 'linux-headers<3.17')
makedepends=("linux-headers=${_kernelver}")
license=('custom')
source=("https://gitorious.org/chakra/chakra-hardware-detection/blobs/raw/master/hwdb/nvidia_supported")
......@@ -17,7 +19,7 @@ _ARCH='x86_64'
_pkg="NVIDIA-Linux-${_ARCH}-${pkgver}-no-compat32"
source+=("ftp://download.nvidia.com/XFree86/Linux-${_ARCH}/${pkgver}/${_pkg}.run")
md5sums=('62d0cdb856cfae64753c0f3acf729d47'
'baea4c968a06d3eddec8fb1287bb38bb')
'bf40adc20ac9819b5f86cd91f6409e39')
build() {
cd "${srcdir}"
......@@ -32,7 +34,7 @@ build() {
package_nvidia() {
pkgdesc="NVIDIA drivers for linux."
depends=('linux>=3.16' 'linux<3.17' "nvidia-libgl" "nvidia-utils=${pkgver}")
depends=("linux=${_kernelver}" "nvidia-libgl" "nvidia-utils=${pkgver}")
conflicts=('nvidia-96xx' 'nvidia-173xx' 'nvidia-304xx' 'nvidia-bumblebee')
replaces=('nvidia-bumblebee')
provides=('nvidia-bumblebee')
......
......@@ -5,16 +5,17 @@
_extramodules=extramodules-3.16-CHAKRA
_kernver="$(cat /usr/lib/modules/$_extramodules/version || true)"
_kernelver=3.16.3
pkgname=r8168
pkgver=8.038.00
pkgrel=1
pkgrel=2
pkgdesc="A kernel module for Realtek 8168 network cards"
url="http://www.realtek.com.tw"
license=("GPL")
arch=('x86_64')
depends=('glibc' 'linux>=3.16' 'linux<3.17')
makedepends=('linux-headers')
depends=('glibc' "linux=${_kernelver}")
makedepends=("linux-headers=${_kernelver}")
install=$pkgname.install
source=("https://dl.dropboxusercontent.com/u/362439/archlinux/r8168-$pkgver.tar.bz2"
delayed_work_ethtool_ops_fix2.patch)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment