Commit c88998e6 authored by abveritas's avatar abveritas
Browse files

rebuild of the sound stack, pkrel up for all, changes to pulseaudio, mpg123, sdl, libao

parent 7a276112
......@@ -6,7 +6,7 @@
pkgname=alsa-firmware
pkgver=1.0.25
pkgrel=1
pkgrel=2
pkgdesc="ALSA firmware package"
arch=('i686' 'x86_64')
url="http://alsa-project.org/"
......
......@@ -9,7 +9,7 @@ source ../_buildscripts/${current_repo}-${_arch}-cfg.conf
pkgname=alsa-lib
pkgver=1.0.25
pkgrel=1
pkgrel=2
pkgdesc="An alternative implementation of Linux sound support"
arch=('i686' 'x86_64')
url="http://www.alsa-project.org"
......
......@@ -4,12 +4,9 @@
# maintainer (i686): Phil Miller <philm[at]chakra-project[dog]org>
# maintainer (x86_64): Manuel Tortosa <manutortosa[at]chakra-project[dot]org>
# include global config
source ../_buildscripts/${current_repo}-${_arch}-cfg.conf
pkgname=alsa-oss
pkgver=1.0.25
pkgrel=1
pkgrel=2
pkgdesc="OSS compatibility library"
arch=(i686 x86_64)
license=('GPL')
......
......@@ -6,7 +6,7 @@
pkgname=alsa-plugins
pkgver=1.0.25
pkgrel=1
pkgrel=2
pkgdesc="Extra alsa plugins"
arch=(i686 x86_64)
url="http://www.alsa-project.org"
......
......@@ -9,7 +9,7 @@ source ../_buildscripts/${current_repo}-${_arch}-cfg.conf
pkgname=alsa-utils
pkgver=1.0.25
pkgrel=1
pkgrel=2
pkgdesc="An alternative implementation of Linux sound support"
arch=('i686' 'x86_64')
url="http://www.alsa-project.org"
......
......@@ -9,7 +9,7 @@ source ../_buildscripts/${current_repo}-${_arch}-cfg.conf
pkgname=cdemu-client
pkgver=1.4.0
pkgrel=2
pkgrel=3
pkgdesc="Simple command-line client for controlling cdemu-daemon"
arch=('i686' 'x86_64')
url="http://cdemu.sourceforge.net/"
......
......@@ -9,7 +9,7 @@ source ../_buildscripts/${current_repo}-${_arch}-cfg.conf
pkgname=cdemu-daemon
pkgver=1.4.0
pkgrel=3
pkgrel=4
pkgdesc="CD/DVD-ROM device emulator daemon"
arch=('i686' 'x86_64')
backup=('etc/conf.d/cdemud'
......
......@@ -7,7 +7,7 @@
pkgname=('cdrdao')
pkgver=1.2.3
pkgrel=4
pkgrel=5
arch=('i686' 'x86_64')
license=('GPL')
url="http://cdrdao.sourceforge.net/"
......
......@@ -7,7 +7,7 @@
pkgname=celt
pkgver=0.11.1
pkgrel=5
pkgrel=6
pkgdesc="Low-latency audio communication codec"
arch=('i686' 'x86_64')
url="http://www.celt-codec.org"
......
......@@ -6,7 +6,7 @@
pkgname=directfb
pkgver=1.4.14
pkgrel=1
pkgrel=2
pkgdesc="A thin library that provides hardware graphics acceleration, input device handling and abstraction, integrated windowing system on top of the Linux Framebuffer Device"
arch=('i686' 'x86_64')
url="http://www.directfb.org"
......
......@@ -9,7 +9,7 @@ source ../_buildscripts/${current_repo}-${_arch}-cfg.conf
pkgname=dssi
pkgver=1.1.1
pkgrel=2
pkgrel=3
pkgdesc="An API for audio plugins, with particular application for software synthesis plugins with native user interfaces."
arch=("i686" "x86_64")
url="http://dssi.sourceforge.net/"
......
......@@ -9,7 +9,7 @@ source ../_buildscripts/${current_repo}-${_arch}-cfg.conf
pkgname=ffmpeg
pkgver=0.10
pkgrel=1
pkgrel=2
epoch=1
pkgdesc="Complete and free Internet live audio and video broadcasting solution for Linux/Unix"
arch=('i686' 'x86_64')
......
......@@ -9,7 +9,7 @@ source ../_buildscripts/${current_repo}-${_arch}-cfg.conf
pkgname=ffmpegthumbnailer
pkgver=2.0.7
pkgrel=2
pkgrel=3
pkgdesc="Lightweight video thumbnailer that can be used by file managers."
url="http://code.google.com/p/ffmpegthumbnailer/"
license=('GPL2')
......
......@@ -9,7 +9,7 @@ source ../_buildscripts/${current_repo}-${_arch}-cfg.conf
pkgname=flac
pkgver=1.2.1
pkgrel=6
pkgrel=7
pkgdesc="Free Lossless Audio Codec"
arch=('i686' 'x86_64')
url="http://flac.sourceforge.net/"
......
......@@ -7,7 +7,7 @@
pkgbase=gstreamer0.10-bad
pkgname=('gstreamer0.10-bad' 'gstreamer0.10-bad-plugins')
pkgver=0.10.22
pkgrel=5
pkgrel=6
arch=('i686' 'x86_64')
license=('LGPL' 'GPL')
makedepends=('pkgconfig' 'gstreamer0.10-base>=0.10.34' 'xvidcore' 'libdca' 'bzip2' 'libdc1394'
......
......@@ -10,7 +10,7 @@ source ../_buildscripts/${current_repo}-${_arch}-cfg.conf
pkgbase=('gstreamer0.10-base')
pkgname=('gstreamer0.10-base' 'gstreamer0.10-base-plugins')
pkgver=0.10.35
pkgrel=3
pkgrel=4
arch=('i686' 'x86_64')
license=('LGPL')
makedepends=('pkgconfig' "gstreamer0.10>=${pkgver}" 'orc' 'libxv' 'alsa-lib' 'cdparanoia' 'libvisual' 'libvorbis' 'libtheora' 'pango' 'gobject-introspection')
......
......@@ -10,11 +10,11 @@ source ../_buildscripts/${current_repo}-${_arch}-cfg.conf
pkgbase=gstreamer0.10-good
pkgname=('gstreamer0.10-good' 'gstreamer0.10-good-plugins')
pkgver=0.10.30
pkgrel=3
pkgrel=4
arch=('i686' 'x86_64')
license=('LGPL')
makedepends=('intltool' 'pkgconfig' 'gstreamer0.10-base>=0.10.34' 'libavc1394' 'libiec61883' 'aalib' 'libshout' 'libdv'
'esound' 'flac' 'wavpack' 'taglib' 'libsoup' 'v4l-utils' 'libcaca' 'bzip2' 'gdk-pixbuf2')
'flac' 'wavpack' 'taglib' 'libsoup' 'v4l-utils' 'libcaca' 'bzip2' 'gdk-pixbuf2' 'libpulse' 'jack' 'udev')
url="http://gstreamer.freedesktop.org/"
options=(!libtool !emptydirs)
source=(${url}/src/gst-plugins-good/gst-plugins-good-${pkgver}.tar.bz2)
......@@ -30,8 +30,7 @@ build() {
--disable-schemas-install \
--disable-hal \
--disable-gconf \
--disable-jack \
--disable-pulse \
--disable-esd \
--with-package-name="GStreamer Good Plugins (Chakra GNU/Linux)" \
--with-package-origin="http://www.chakra-project.org/"
......@@ -50,8 +49,8 @@ package_gstreamer0.10-good() {
}
package_gstreamer0.10-good-plugins() {
depends=("gstreamer0.10-good=${pkgver}" 'libavc1394' 'libiec61883' 'aalib' 'libshout' 'libdv' 'esound' 'flac'
'wavpack' 'taglib' 'libsoup' 'v4l-utils' 'libcaca' 'libpng' 'libjpeg' 'gdk-pixbuf2')
depends=("gstreamer0.10-good=${pkgver}" 'libavc1394' 'libiec61883' 'aalib' 'libshout' 'libdv' 'flac'
'wavpack' 'taglib' 'libsoup' 'v4l-utils' 'libcaca' 'libpng' 'libjpeg' 'gdk-pixbuf2' 'jack' 'libpulse' 'udev')
pkgdesc="GStreamer Multimedia Framework Good Plugins (gst-plugins-good)"
groups=('gstreamer0.10-plugins')
......
......@@ -6,7 +6,7 @@
pkgname=gstreamer0.10-pulse
pkgver=0.10.30
pkgrel=3
pkgrel=4
pkgdesc="A GStreamer 0.10 plugin for the PulseAudio sound server"
arch=('i686' 'x86_64')
license=('LGPL')
......
......@@ -5,7 +5,7 @@
pkgname=gstreamer0.10-python
pkgver=0.10.22
pkgrel=2
pkgrel=3
pkgdesc="Python bindings for GStreamer 0.10"
arch=('i686' 'x86_64')
license=('LGPL')
......
......@@ -7,7 +7,7 @@
pkgbase=gstreamer0.10-ugly
pkgname=('gstreamer0.10-ugly' 'gstreamer0.10-ugly-plugins')
pkgver=0.10.18
pkgrel=4
pkgrel=5
arch=('i686' 'x86_64')
license=('LGPL')
makedepends=('pkgconfig' 'gstreamer0.10-base' 'libdvdread' 'lame' 'libmpeg2' 'a52dec' 'libid3tag' 'libmad'
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment