Commit d10e0a4b authored by Manuel's avatar Manuel
Browse files

Update version

parent 81d436a5
# $Id: PKGBUILD 24494 2009-01-17 20:42:01Z jgc $
# Maintainer: Jan de Groot <jgc@archlinux.org>
#
# KDE SC Packages for Chakra, part of chakra-project.org
#
# maintainer (i686): Phil Miller <philm[at]chakra-project[dog]org>
# maintainer (x86_64): Manuel Tortosa <manutortosa[at]chakra-project[dot]org>
pkgname=libproxy
pkgver=0.3.1
pkgrel=2
pkgver=0.4.6
pkgrel=1
pkgdesc="A library that provides automatic proxy configuration management"
arch=(i686 x86_64)
license=('LGPL')
depends=('glibc')
makedepends=('libxmu' 'gconf' 'networkmanager')
optdepends=('libxmu: KDE and GNOME plugins'
'gconf: GNOME plugin'
'networkmanager: NetworkManager plugin')
depends=('gcc-libs')
optdepends=('gconf: GNOME configuration module'
'kdelibs: KDE configuration module'
'networkmanager: NetworkManager configuration module'
'perl: Perl bindings'
'python2: Python bindings')
makedepends=('gconf' 'cmake' 'networkmanager' 'automoc4' 'python2' 'kdelibs' 'perl')
url="http://libproxy.googlecode.com"
source=(http://libproxy.googlecode.com/files/${pkgname}-${pkgver}.tar.bz2
nm-dbus.patch)
source=(http://libproxy.googlecode.com/files/${pkgname}-${pkgver}.tar.gz)
options=('!libtool')
md5sums=('1745fe1bdf5beca1bf7269758f3906e8'
'a56ee1519bc3640257430b5fe5540a38')
md5sums=('199c6b120baf1f7258a55f38d5ec74f5')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
patch -Np1 -i "${srcdir}/nm-dbus.patch" || return 1
libtoolize --force || return 1
aclocal || return 1
autoconf || return 1
automake --add-missing || return 1
./configure --prefix=/usr --without-mozjs || return 1
make || return 1
make DESTDIR="${pkgdir}" install || return 1
mkdir build
cd build
cmake -DCMAKE_INSTALL_PREFIX=/usr \
-DLIBEXEC_INSTALL_DIR=/usr/lib/libproxy \
-DCMAKE_SKIP_RPATH=ON \
-DPERL_VENDORINSTALL=yes \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_CXX_FLAGS="${CXXFLAGS}" \
-DCMAKE_C_FLAGS="${CFLAGS}" \
..
make
}
package() {
cd "${srcdir}/${pkgname}-${pkgver}/build"
make DESTDIR="${pkgdir}" install
}
diff -Nur libproxy-0.3.1.orig//configure.ac libproxy-0.3.1/configure.ac
--- libproxy-0.3.1.orig//configure.ac 2009-10-05 21:42:34.000000000 +0300
+++ libproxy-0.3.1/configure.ac 2010-05-05 18:45:29.569107696 +0300
@@ -7,6 +7,7 @@
### Checks for programs.
AC_PROG_CC
AC_PROG_CPP
+AM_PROG_CC_C_O
AC_PROG_CXX
AC_PROG_INSTALL
AC_PROG_LIBTOOL
@@ -34,8 +35,9 @@
[PKG_CHECK_MODULES(mozjs, firefox-js, have_mozjs=yes,
[PKG_CHECK_MODULES(mozjs, mozilla-js, have_mozjs=yes,
[PKG_CHECK_MODULES(mozjs, seamonkey-js, have_mozjs=yes,have_mozjs=no)])])])
-PKG_CHECK_MODULES(NetworkManager, NetworkManager dbus-1,
- have_networkmanager=yes, have_networkmanager=no)
+PKG_CHECK_MODULES(NetworkManager, NetworkManager,
+ [PKG_CHECK_MODULES(DBUS, dbus-1, have_networkmanager=yes, have_networkmanager=no)],
+ have_networkmanager=no)
PKG_CHECK_MODULES(QtCore, QtCore, have_qtcore=yes, have_qtcore=no)
# Direct
@@ -124,12 +126,12 @@
[test x$have_networkmanager = xyes && with_networkmanager=yes])
if test x$with_networkmanager = xyes; then
if test x$have_networkmanager = xyes; then
- NETWORKMANAGER_CFLAGS="$NetworkManager_CFLAGS"
- NETWORKMANAGER_LIBS="$NetworkManager_LIBS"
+ NETWORKMANAGER_CFLAGS="$NetworkManager_CFLAGS $DBUS_CFLAGS"
+ NETWORKMANAGER_LIBS="$NetworkManager_LIBS $DBUS_LIBS"
AC_SUBST(NETWORKMANAGER_CFLAGS)
AC_SUBST(NETWORKMANAGER_LIBS)
else
- echo "NetworkManager module requires: NetworkManager!"
+ echo "NetworkManager module requires: NetworkManager and DBus!"
exit 1
fi
else
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment