Commit d7259591 authored by AlmAck's avatar AlmAck

linux-lts 4.4.115

parent c794628d
......@@ -6,7 +6,7 @@ source ../linux-lts.conf
pkgname=acpi_call-lts
_pkgname=acpi_call
pkgver=1.1.0
pkgrel=7
pkgrel=8
pkgdesc="A kernel module that enables you to call parameterless ACPI methods by writing the method name to /proc/acpi/call, e.g. to turn off discrete graphics card in a dual graphics environment (like NVIDIA Optimus)."
arch=('x86_64')
url=("http://github.com/mkottman/acpi_call")
......
......@@ -6,7 +6,7 @@ source ../linux-lts.conf
pkgname=bbswitch-lts
_pkgname=bbswitch
pkgver=0.8
pkgrel=10
pkgrel=11
pkgdesc="kernel module allowing to switch dedicated graphics card on Optimus laptops"
arch=('x86_64')
url=("http://github.com/Bumblebee-Project/bbswitch")
......
......@@ -3,7 +3,7 @@ source ../linux-lts.conf
pkgname=broadcom-wl-lts
pkgver=6.30.223.271
pkgrel=6
pkgrel=7
pkgdesc='Broadcom 802.11abgn hybrid Linux networking device driver'
arch=('x86_64')
url='http://www.broadcom.com/support/802.11/linux_sta.php'
......
......@@ -6,7 +6,7 @@
# These are the "basic variables" appliable for the LTS kernal group
_kernelname="-CHAKRA-LTS"
_kernelver=4.4.110
_kernelver=4.4.115
_basekernel=4.4
_extramodules=extramodules-${_basekernel}${_kernelname}
......
......@@ -20,9 +20,9 @@ source=(http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.{xz,sign}
change-default-console-loglevel.patch)
md5sums=('9a78fa2eb6c68ca5a40ed5af08142599'
'SKIP'
'0cab97888a42703dfff4d78f814176ec'
'6f3e057f552161d8dbc534f58b50f107'
'SKIP'
'3aa1cc30eaab983fa01acfd2188bfa8a'
'99d3696dce99d4eebf297fc542f6b22d'
'232b52576a62c7a333e9fe7a1e1ca359'
'df7fceae6ee5d7e7be7b60ecd7f6bb35')
validpgpkeys=(
......
This diff is collapsed.
# arg 1: the new package version
# arg 2: the old package version
KERNEL_NAME=-CHAKRA-LTS
KERNEL_VERSION=4.4.115-1-CHAKRA-LTS
post_install () {
# updating module dependencies
echo ">>> Updating module dependencies. Please wait ..."
depmod ${KERNEL_VERSION}
echo ">>> Generating initial ramdisk, using mkinitcpio. Please wait..."
mkinitcpio -p linux${KERNEL_NAME}
}
post_upgrade() {
if findmnt --fstab -uno SOURCE /boot &>/dev/null && ! mountpoint -q /boot; then
echo "WARNING: /boot appears to be a separate partition but is not mounted."
fi
if [ $(vercmp $2 3.13) -lt 0 ]; then
echo ">>> WARNING: AT keyboard support is no longer built into the kernel."
echo ">>> In order to use your keyboard during early init, you MUST"
echo ">>> include the 'keyboard' hook in your mkinitcpio.conf."
fi
# updating module dependencies
echo ">>> Updating module dependencies. Please wait ..."
depmod ${KERNEL_VERSION}
echo ">>> Generating initial ramdisk, using mkinitcpio. Please wait..."
mkinitcpio -p linux${KERNEL_NAME}
}
post_remove() {
# also remove the compat symlinks
rm -f boot/initramfs-linux${KERNEL_NAME}.img
rm -f boot/initramfs-linux${KERNEL_NAME}-fallback.img
}
......@@ -6,7 +6,7 @@ source ../linux-lts.conf
pkgname=ndiswrapper-lts
_pkgname=ndiswrapper
pkgver=1.61
pkgrel=3
pkgrel=4
pkgdesc="Module for NDIS (Windows Network Drivers) drivers supplied by vendors. For linux-lts."
license=('GPL')
arch=('x86_64')
......
......@@ -5,7 +5,7 @@ source ../linux-lts.conf
pkgname=nvidia-304xx-lts
pkgver=304.137
pkgrel=2
pkgrel=3
pkgdesc="NVIDIA drivers for linux."
arch=('x86_64')
url="http://www.nvidia.com/"
......
......@@ -4,8 +4,8 @@
source ../linux-lts.conf
pkgname=nvidia-340xx-lts
pkgver=340.104
pkgrel=2
pkgver=340.106
pkgrel=1
pkgdesc="NVIDIA drivers for linux."
arch=('x86_64')
url="http://www.nvidia.com/"
......@@ -16,7 +16,7 @@ license=('custom')
install=nvidia.install
_pkg="NVIDIA-Linux-x86_64-${pkgver}-no-compat32"
source=("http://us.download.nvidia.com/XFree86/Linux-x86_64/${pkgver}/${_pkg}.run")
md5sums=('efbd37cde63d50f657d55a6f2b321142')
md5sums=('37c84428b64696be2b104edbc9855f57')
prepare() {
sh "${_pkg}.run" --extract-only
......
......@@ -3,7 +3,7 @@ source ../linux-lts.conf
pkgname=('nvidia-lts')
pkgdesc=('NVIDIA drivers for linux-lts')
pkgver=387.34
pkgver=390.25
pkgrel=1
arch=('x86_64')
url="http://www.nvidia.com/"
......@@ -17,7 +17,7 @@ _pkg="NVIDIA-Linux-x86_64-${pkgver}-no-compat32"
source=("http://us.download.nvidia.com/XFree86/Linux-x86_64/${pkgver}/NVIDIA-Linux-x86_64-${pkgver}-no-compat32.run")
#source=("NVIDIA-Linux-x86_64-${pkgver}.run::https://developer.nvidia.com/linux64bit")
md5sums=('a009bbc502c30e4b483d71be9fa51790')
md5sums=('e41e28d1f380c64ec2eacae344fb5017')
prepare() {
sh "${_pkg}.run" --extract-only
......
......@@ -5,7 +5,7 @@ source ../linux-lts.conf
pkgname=vhba-module-lts
_pkgname=vhba-module
pkgver=20170610
pkgrel=2
pkgrel=3
pkgdesc="Kernel module that emulates SCSI devices"
arch=('x86_64')
url="http://cdemu.sourceforge.net/"
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment