Commit ee42de2e authored by AlmAck's avatar AlmAck

downgrade python3-diff-match-patch not compatible with translate-toolkit

Using the new version the generated error is:
pkg_resources.ContextualVersionConflict: (diff-match-patch 20181111 (/usr/lib/python3.6/site-packages), Requirement.parse('diff-match-patch==20121119'), {'translate-toolkit'})
parent e5b188cf
Pipeline #2739 passed with stages
in 1 minute and 31 seconds
......@@ -3,21 +3,26 @@
# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=python3-diff-match-patch
pkgver=20181111
pkgver=20121119
pkgrel=1
pkgdesc="Robust algorithms to perform the operations required for synchronizing plain text"
arch=('any')
url="https://pypi.org/project/diff-match-patch/"
license=('Apache')
makedepends=('python3' 'python3-setuptools')
source=(https://files.pythonhosted.org/packages/f0/2a/5ba07def0e9107d935aba62cf632afbd0f7c723a98af47ccbcab753d2452/diff-match-patch-$pkgver.tar.gz)
sha256sums=('a809a996d0f09b9bbd59e9bbd0b71eed8c807922512910e05cbd3f9480712ddb')
source=(https://pypi.python.org/packages/source/d/diff-match-patch/diff-match-patch-${pkgver}.tar.gz)
sha256sums=('9dba5611fbf27893347349fd51cc1911cb403682a7163373adacc565d11e2e4c')
prepare() {
cd "${srcdir}"/diff-match-patch-${pkgver}
sed -i 's/\/usr\/bin\/python2.4/\/usr\/bin\/python2.7/' python2/diff_match_patch/*
}
package() {
depends=('python3')
depends=('python3')
cd "${srcdir}"/diff-match-patch-$pkgver
cd "${srcdir}"/diff-match-patch-$pkgver
python3 setup.py install --root="${pkgdir}" -O1
find "${pkgdir}" -name *_py2.* -delete
python3 setup.py install --root="${pkgdir}" -O1
#find "${pkgdir}" -name *_py2.* -delete
}
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment