Commit 7851e5ed authored by Luca Giambonini's avatar Luca Giambonini

sound group (part 4)

parent 116f4697
--- build.xml 2012-09-14 18:22:48.000000000 +0000
+++ build.xml.patched 2013-01-09 10:19:28.414079935 +0000
@@ -46,9 +46,10 @@
<include name="**/*.rsc"/>
<include name="META-INF/**"/>
<include name="**/*.properties"/>
+ <include name="**/*.props"/>
<exclude name="META-INF/eclipse.inf"/>
</fileset>
</zip>
<delete dir="${output}" />
</target>
-</project>
\ No newline at end of file
+</project>
--- build.xml.orig 2013-10-03 13:55:28.579003290 +0000
+++ build.xml 2013-10-03 13:57:52.971400439 +0000
@@ -39,8 +39,6 @@
<compilerarg line="-Xlint:none"/>
</javac>
- <delete file="${basedir}/META-INF/MANIFEST.MF" failonerror="false"/>
- <copy tofile="${basedir}/META-INF/MANIFEST.MF" file="${basedir}/scripts/binary/META-INF/MANIFEST.MF"/>
<zip destfile="${basedir}/${jar_file}">
<fileset dir="${output}" />
<fileset dir="${basedir}">
# $Id$
# Maintainer: Guillaume ALAUX <guillaume@archlinux.org>
# Contributor: Jan de Groot <jgc@archlinux.org>
# Contributor: Allan McRae <allan@archlinux.org>
pkgname=eclipse-ecj
pkgver=4.4
pkgrel=1
_date=201406061215
pkgdesc='Eclipse java bytecode compiler'
arch=('any')
license=('EPL')
url='http://www.eclipse.org/'
depends=('java-runtime')
makedepends=('apache-ant' 'java-environment')
source=(http://download.eclipse.org/eclipse/downloads/drops4/R-${pkgver}-${_date}/ecjsrc-${pkgver}.jar
01-ecj-include-props.patch
02-buildxml-fix-manifest.patch
ecj)
sha256sums=('429a65013ae9740e4f05451f8e2968b389ec04ef2c7178ccfa5ef6714488fd12'
'8f6259c76dfe493549bbaec3c8a7ba29e82c70e127c918adca28737dcb570f6b'
'5ca6bd94c2b1cb4c6f116d38c160edf1c4ca520647ac74b26486f958254767af'
'63aff3d126243d303ddc4305cfa77827df72e87ccf85bd8a22a2f832357e396c')
build() {
cd "${srcdir}"
patch -p0 -i "$srcdir/01-ecj-include-props.patch"
patch -p0 -i "$srcdir/02-buildxml-fix-manifest.patch"
sed -i -e "s/Xlint:none/Xlint:none -encoding cp1252/g" build.xml
LANG=en_US.UTF-8
ant build
}
package() {
install -Dm644 "${srcdir}/ecj.jar" "${pkgdir}/usr/share/java/eclipse-ecj-${pkgver}.jar"
ln -s eclipse-ecj-${pkgver}.jar "${pkgdir}/usr/share/java/ecj.jar"
ln -s eclipse-ecj-${pkgver}.jar "${pkgdir}/usr/share/java/eclipse-ecj.jar"
install -Dm755 ecj "${pkgdir}/usr/bin/ecj"
install -D -m 644 ecj.1 "${pkgdir}/usr/share/man/man1/ecj.1"
}
#!/bin/sh
CLASSPATH=/usr/share/java/ecj.jar${CLASSPATH:+:}$CLASSPATH \
java org.eclipse.jdt.internal.compiler.batch.Main "$@"
......@@ -2,7 +2,7 @@
# Maintainer: Bruce Liu <brli@users.sourceforge.net>
pkgname=ffmpeg
pkgver=2.5.2
pkgver=2.5.3
pkgrel=1
pkgdesc="Complete and free Internet live audio and video broadcasting solution for Linux/Unix"
arch=('x86_64')
......@@ -16,7 +16,7 @@ depends=('alsa-lib' 'bzip2' 'fontconfig' 'freetype2' 'gnutls' 'harfbuzz' 'gsm' '
makedepends=('yasm')
source=("${url}/releases/${pkgname}-${pkgver}.tar.gz"
"${url}/releases/${pkgname}-${pkgver}.tar.gz.asc")
md5sums=('9bcb1a7884f17e09a79337db724fa3fb'
md5sums=('4d25b9ce1487bce0e882aa5380d24f36'
'SKIP')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
......
# Maintainer abveritas@chakra-project.org
# Maintainer almack
pkgname=libgsf
pkgver=1.14.28
pkgrel=2
pkgver=1.14.30
pkgrel=1
arch=('x86_64')
pkgdesc="The GNOME Structured File Library is a utility library for reading and writing structured file formats"
url="http://www.gnome.org/"
......@@ -10,7 +10,7 @@ license=('GPL' 'LGPL')
depends=('libxml2' 'glib2' 'bzip2')
makedepends=('intltool' 'pkgconfig' 'python2' 'gobject-introspection')
source=("http://ftp.gnome.org/pub/GNOME/sources/${pkgname}/1.14/${pkgname}-${pkgver}.tar.xz")
md5sums=('48cc1409951419c5e2be1a16f749adb2')
md5sums=('e7b672ef37ef6a853ce149c03e4d3a63')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
......
#
# Platform Packages for Chakra, part of chakra-project.org
# Platform Packages for Chakra, part of chakraos.org
#
# maintainer abveritas@chakra-project.org
# maintainer almack
pkgname=libmms
pkgver=0.6.2
pkgrel=4
pkgver=0.6.4
pkgrel=1
pkgdesc="MMS stream protocol library"
arch=('x86_64')
url="http://sourceforge.net/projects/libmms/"
license=(LGPL)
depends=('glib2')
source=("http://download.sourceforge.net/libmms/${pkgname}-${pkgver}.tar.gz")
md5sums=('9f63aa363deb4874e072a45850161bff')
md5sums=('d6b665b335a6360e000976e770da7691')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
......
diff -Nurp libmms-0.5.orig//src/mmsx.h libmms-0.5//src/mmsx.h
--- libmms-0.5.orig//src/mmsx.h 2010-03-03 11:42:14.000000000 +0100
+++ libmms-0.5//src/mmsx.h 2010-03-03 11:42:46.000000000 +0100
@@ -55,11 +55,11 @@ int mmsx_peek_header (mmsx_t *inst
mms_off_t mmsx_get_current_pos (mmsx_t *instance);
-uint32_t mmsx_get_asf_header_len (mmsx_t *this);
+uint32_t mmsx_get_asf_header_len (mmsx_t *instance);
-uint64_t mmsx_get_asf_packet_len (mmsx_t *this);
+uint64_t mmsx_get_asf_packet_len (mmsx_t *instance);
-int mmsx_get_seekable (mmsx_t *this);
+int mmsx_get_seekable (mmsx_t *instance);
#ifdef __cplusplus
}
......@@ -8,7 +8,7 @@
pkgbase=qt
pkgname=('qt' 'qt-private-headers' 'qt-docs')
pkgver=4.8.6
pkgrel=4
pkgrel=5
arch=('x86_64')
url='http://qt.nokia.com/'
license=('GPL3' 'LGPL')
......
......@@ -3,7 +3,7 @@
pkgname=vlc
pkgver=2.1.5
pkgrel=1
pkgrel=2
arch=('x86_64')
url="http://www.videolan.org/vlc/"
pkgdesc=('A multimedia player and framework that plays most multimedia files as well as DVD, Audio CD, VCD, and various streaming protocols')
......@@ -47,12 +47,20 @@ backup=('usr/share/vlc/lua/http/.hosts'
categories=('multimedia')
options=('!emptydirs')
install="vlc.install"
source=("http://download.videolan.org/pub/videolan/${pkgname}/${pkgver/.a}/${pkgname}-${pkgver/.a/a}.tar.xz")
sha1sums=('7f1cb6324a04cf393896bbb5976ca9febd7b3efc')
source=("http://download.videolan.org/pub/videolan/${pkgname}/${pkgver/.a}/${pkgname}-${pkgver/.a/a}.tar.xz"
'vlc-2.1.5-ffmpeg-2.4.patch')
sha1sums=('7f1cb6324a04cf393896bbb5976ca9febd7b3efc'
'9896793e605b5646a49506796dd2c28307635791')
screenshot='http://images1.videolan.org/vlc/screenshots/0.9.2/screenshot-kde4.jpg'
prepare() {
cd "${srcdir}/${pkgname}-${pkgver/.a}"
# VLC: patch for ffmpeg 2.4 compatibility, increment revision to rebuild.
# https://trac.macports.org/changeset/125496
patch -p1 -i "${srcdir}/vlc-2.1.5-ffmpeg-2.4.patch"
autoreconf -fi
sed -i -e 's:truetype/freefont:TTF:g' modules/text_renderer/freetype.c
sed -i -e 's:truetype/ttf-dejavu:TTF:g' modules/visualization/projectm.cpp
......@@ -62,7 +70,7 @@ prepare() {
build() {
cd "${srcdir}/${pkgname}-${pkgver/.a}"
CFLAGS+="-I/usr/include/samba-4.0" CPPFLAGS+="-I/usr/include/samba-4.0" \
CFLAGS+=" -I/usr/include/samba-4.0" CPPFLAGS+=" -I/usr/include/samba-4.0" \
./configure --prefix=/usr \
--sysconfdir=/etc \
--disable-rpath \
......
diff --git a/configure.ac b/configure.ac
index a684338..053713a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2242,8 +2242,8 @@ AC_ARG_ENABLE(avcodec,
[ --enable-avcodec libavcodec codec (default enabled)])
AS_IF([test "${enable_avcodec}" != "no"], [
PKG_CHECK_MODULES(AVCODEC,[libavcodec >= 53.34.0 libavutil >= 51.22.0], [
- PKG_CHECK_EXISTS([libavcodec < 56],, [
- AC_MSG_ERROR([libavcodec versions 56 and later are not supported yet.])
+ PKG_CHECK_EXISTS([libavcodec < 57],, [
+ AC_MSG_ERROR([libavcodec versions 57 and later are not supported yet.])
])
VLC_SAVE_FLAGS
CPPFLAGS="${CPPFLAGS} ${AVCODEC_CFLAGS}"
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment