Commit e93843df authored by Luca Giambonini's avatar Luca Giambonini

linux 4.18.5

parent e2b008b5
Pipeline #1107 failed with stages
in 28 minutes and 25 seconds
pkgname=acpi_call
pkgver=1.1.0
pkgrel=49
pkgrel=50
pkgdesc="A kernel module that enables you to call parameterless ACPI methods by writing the method name to /proc/acpi/call, e.g. to turn off discrete graphics card in a dual graphics environment (like NVIDIA Optimus)."
arch=('x86_64')
url="http://github.com/mkottman/acpi_call"
license=('GPL')
depends=("linux=4.18.3")
makedepends=("linux-headers=4.18.3")
depends=("linux=4.18.5")
makedepends=("linux-headers=4.18.5")
_extramodules=extramodules-CHAKRA
source=("https://github.com/mkottman/acpi_call/archive/v${pkgver}.tar.gz")
md5sums=('f69d40e130b0e5ed17ce8adb19e6dda1')
......
pkgname=bbswitch
pkgver=0.8
pkgrel=44
pkgrel=45
pkgdesc="kernel module allowing to switch dedicated graphics card on Optimus laptops"
arch=('x86_64')
url="http://github.com/Bumblebee-Project/bbswitch"
license=('GPL')
depends=("linux=4.18.3")
makedepends=("linux-headers=4.18.3")
depends=("linux=4.18.5")
makedepends=("linux-headers=4.18.5")
_extramodules=extramodules-CHAKRA
source=("https://github.com/Bumblebee-Project/bbswitch/archive/v${pkgver}.tar.gz")
md5sums=('5b116b31ace3604ddf9d1fc1f4bc5807')
......
pkgname=broadcom-wl
pkgver=6.30.223.271
pkgrel=26
pkgrel=27
pkgdesc='Broadcom 802.11abgn hybrid Linux networking device driver'
url='http://www.broadcom.com/support/802.11/linux_sta.php'
arch=('x86_64')
license=('custom')
depends=("linux=4.18.3")
makedepends=("linux-headers=4.18.3")
depends=("linux=4.18.5")
makedepends=("linux-headers=4.18.5")
_extramodules=extramodules-CHAKRA
source=("https://docs.broadcom.com/docs-and-downloads/docs/linux_sta/hybrid-v35_64-nodebug-pcoem-${pkgver//./_}.tar.gz"
#"http://ftp.de.debian.org/debian/pool/non-free/b/broadcom-sta/broadcom-sta_5.100.82.112.orig.tar.gz" "http://www.broadcom.com/docs/linux_sta/hybrid-portsrc_${ARCH}-v${pkgver//./_}.tar.gz" we need the debian version, because upstream URL doesn't exist anymore
......
......@@ -3,7 +3,7 @@
pkgname=btrfs-progs
pkgver=4.17
pkgrel=3
pkgrel=4
pkgdesc='Btrfs filesystem utilities'
arch=('x86_64')
depends=('glibc' 'util-linux' 'e2fsprogs' 'lzo2' 'zlib' 'zstd')
......
# toolchain build order: linux-api-headers->glibc->binutils->gcc->binutils->glibc
pkgname=linux-api-headers
pkgver=4.18.3
pkgver=4.18.5
pkgrel=1
pkgdesc="Kernel headers sanitized for use in userspace"
arch=('x86_64')
url="http://www.gnu.org/software/libc"
license=('GPL2')
source=(https://www.kernel.org/pub/linux/kernel/v4.x/linux-${pkgver}.tar.{xz,sign})
md5sums=('b5aafaf94f7631fd48574e22a74eaa5a'
md5sums=('22851fe6c82db6673a844bbb7c62df67'
'SKIP')
validpgpkeys=('ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
'647F28654894E3BD457199BE38DBBDC86092693E') # Greg Kroah-Hartman
......
......@@ -13,13 +13,13 @@ pkgname=(
'usbip'
'x86_energy_perf_policy'
)
pkgver=4.18.3
pkgver=4.18.5
pkgrel=1
license=('GPL2')
arch=('x86_64')
url='http://www.kernel.org'
options=('!strip')
makedepends=('git' "linux=4.18.3")
makedepends=('git' "linux=4.18.5")
# split packages need all package dependencies set manually in makedepends
# kernel source deps
makedepends+=('asciidoc' 'xmlto')
......@@ -37,7 +37,7 @@ source=("http://www.kernel.org/pub/linux/kernel/v4.x/linux-${pkgver}.tar.xz"
'cpupower.systemd'
'cpupower.service'
'usbipd.service')
sha256sums=('81ed3ccef8eb43cba3d2451a963d0bbaf5392af98435d42caee82d019a8443d4'
sha256sums=('fb090a3680eddf6f10bf895bc3075bd3f830e3d2429ce469982db5a28df647bd'
'4fa509949d6863d001075fa3e8671eff2599c046d20c98bb4a70778595cd1c3f'
'fbf6e0ce6eb0ef15703fe212958de6ca46e62188900b5e9f9272ed3cc9cfd54e'
'a89284d0ecb556ca53a66d1c2087b5fd6d0a901ab2769cd3aebb93f4478905dc'
......
......@@ -6,4 +6,4 @@
# These are the "basic variables" appliable for the normal kernel group
_kernelname="-CHAKRA"
_kernelver=4.18.3
_kernelver=4.18.5
......@@ -10,7 +10,7 @@
# packages in the right order to solve
# the dependencies correctly
#
# GitLab-CI:7
# GitLab-CI:0
#core_packages
linux
......
pkgbase=linux
pkgname=('linux' 'linux-headers' 'linux-docs')
pkgver=4.18.3
pkgver=4.18.5
_srcname=linux-$pkgver
pkgrel=2
pkgrel=1
arch=('x86_64')
url="https://www.kernel.org/"
license=('GPL2')
......@@ -21,7 +21,7 @@ validpgpkeys=(
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
'8218F88849AAC522E94CF470A5E9288C4FA415FA' # Jan Alexander Steffens (heftig)
)
sha256sums=('81ed3ccef8eb43cba3d2451a963d0bbaf5392af98435d42caee82d019a8443d4'
sha256sums=('fb090a3680eddf6f10bf895bc3075bd3f830e3d2429ce469982db5a28df647bd'
'SKIP'
'a7036446f02aab501936933d453f3a99c84904b9ad88ea662eb9618972abebf3'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
......
pkgname=ndiswrapper
pkgver=1.61
pkgrel=15
pkgrel=16
pkgdesc="Module for NDIS (Windows Network Drivers) drivers supplied by vendors. For linux-testing."
license=('GPL')
arch=('x86_64')
url="http://ndiswrapper.sourceforge.net"
depends=("linux=4.18.3")
makedepends=("linux-headers=4.18.3")
depends=("linux=4.18.5")
makedepends=("linux-headers=4.18.5")
provides=("ndiswrapper-utils=$pkgver")
replaces=('ndiswrapper-utils')
conflicts=('ndiswrapper-utils')
......
......@@ -2,7 +2,7 @@ pkgbase=nvidia-340xx-utils
pkgname=('nvidia-340xx-utils' 'opencl-nvidia-340xx')
# Edit chakra-hardware-detection/hooks/hwdetect_7_graphics on version jump from 3xx.xx
pkgver=340.107
pkgrel=3
pkgrel=4
arch=('x86_64')
url="http://www.nvidia.com/"
license=('custom')
......
......@@ -2,10 +2,10 @@
pkgbase=nvidia-340xx
pkgname=('nvidia-340xx' 'chd-nvidia-340xx' 'nvidia-340xx-dkms')
pkgver=340.107
pkgrel=4
pkgrel=5
arch=('x86_64')
url="http://www.nvidia.com/"
makedepends=("linux-headers=4.18.3")
makedepends=("linux-headers=4.18.5")
license=('custom')
source=("https://code.chakralinux.org/tools/chakra-hardware-detection/raw/master/hwdb/nvidia_supported"
'kernel-4.11.patch')
......@@ -39,7 +39,7 @@ build() {
package_nvidia-340xx() {
pkgdesc="NVIDIA drivers for linux."
depends=("linux=4.18.3" "nvidia-340xx-libgl" "nvidia-340xx-utils=${pkgver}")
depends=("linux=4.18.5" "nvidia-340xx-libgl" "nvidia-340xx-utils=${pkgver}")
conflicts=('nvidia-96xx' 'nvidia-173xx' 'nvidia-304xx' 'nvidia-bumblebee')
install=nvidia.install
......
......@@ -3,7 +3,7 @@ pkgname=('nvidia-390xx-utils' 'opencl-nvidia-390xx')
# Edit chakra-hardware-detection/hooks/hwdetect_7_graphics on version jump from 3xx.xx
# Update nvidia-settings too
pkgver=390.77
pkgrel=3
pkgrel=4
arch=('x86_64')
url="http://www.nvidia.com/"
license=('custom')
......
......@@ -2,11 +2,11 @@
pkgbase=nvidia-390xx
pkgname=(nvidia-390xx nvidia-390xx-dkms chd-nvidia-390xx)
pkgver=390.77
pkgrel=3
pkgrel=4
pkgdesc="NVIDIA drivers for linux, 390xx legacy branch"
arch=('x86_64')
url="http://www.nvidia.com/"
makedepends=("linux-headers=4.18.3" "nvidia-390xx-utils=${pkgver}")
makedepends=("linux-headers=4.18.5" "nvidia-390xx-utils=${pkgver}")
license=('custom')
options=('!strip')
source=("https://code.chakralinux.org/tools/chakra-hardware-detection/raw/master/hwdb/nvidia_supported_new")
......@@ -54,7 +54,7 @@ build() {
package_nvidia-390xx() {
pkgdesc="NVIDIA drivers for linux, 390xx legacy branch"
depends=("linux=4.18.3" "nvidia-390xx-utils=${pkgver}" 'libgl')
depends=("linux=4.18.5" "nvidia-390xx-utils=${pkgver}" 'libgl')
conflicts=('nvidia-96xx' 'nvidia-173xx' 'nvidia-304xx' 'nvidia-340xx')
install -Dt "${pkgdir}/usr/lib/modules/${_extramodules}" -m644 \
......
......@@ -3,7 +3,7 @@ pkgname=(nvidia-utils opencl-nvidia)
# Edit chakra-hardware-detection/hooks/hwdetect_7_graphics on version jump from 3xx.xx
# Update nvidia-settings too
pkgver=396.51
pkgrel=3
pkgrel=4
arch=('x86_64')
url="http://www.nvidia.com/"
license=('custom')
......
......@@ -2,10 +2,10 @@
pkgbase=nvidia
pkgname=(nvidia nvidia-dkms chd-nvidia)
pkgver=396.51
pkgrel=3
pkgrel=4
arch=('x86_64')
url="http://www.nvidia.com/"
makedepends=("linux-headers=4.18.3" "nvidia-utils=${pkgver}")
makedepends=("linux-headers=4.18.5" "nvidia-utils=${pkgver}")
license=('custom')
options=('!strip')
source=("https://code.chakralinux.org/tools/chakra-hardware-detection/raw/master/hwdb/nvidia_supported_new")
......@@ -52,7 +52,7 @@ build() {
package_nvidia() {
pkgdesc="NVIDIA drivers for linux"
depends=("linux=4.18.3" "nvidia-utils=${pkgver}")
depends=("linux=4.18.5" "nvidia-utils=${pkgver}")
conflicts=('nvidia-96xx' 'nvidia-173xx' 'nvidia-304xx')
install -Dt "${pkgdir}/usr/lib/modules/${_extramodules}" -m644 \
......
pkgname=r8168
pkgver=8.045.08
pkgrel=11
pkgrel=12
pkgdesc="A kernel module for Realtek 8168 network cards"
url="http://www.realtek.com.tw"
license=("GPL")
arch=('x86_64')
depends=('glibc' "linux=4.18.3")
makedepends=("linux-headers=4.18.3")
depends=('glibc' "linux=4.18.5")
makedepends=("linux-headers=4.18.5")
_extramodules=extramodules-CHAKRA
source=("https://github.com/mtorromeo/r8168/archive/$pkgver/$pkgname-$pkgver.tar.gz"
linux-4.15.patch)
......
pkgname=vhba-module
pkgver=20170610
pkgrel=13
pkgrel=14
pkgdesc="Kernel module that emulates SCSI devices"
arch=('x86_64')
url="http://cdemu.sourceforge.net/"
license=('GPL')
depends=("linux=4.18.3")
makedepends=("linux-headers=4.18.3")
depends=("linux=4.18.5")
makedepends=("linux-headers=4.18.5")
_extramodules=extramodules-CHAKRA
source=("http://downloads.sourceforge.net/cdemu/$pkgname-$pkgver.tar.bz2"
60-vhba.rules)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment