Commit 126c87af authored by abveritas's avatar abveritas

Version-up cherokee to 1.0.12, adding missing dep to videocatcher

parent 4cf22b9a
......@@ -7,7 +7,7 @@
# include global config
pkgname=cherokee
pkgver=1.0.10
pkgver=1.0.12
pkgrel=1
pkgdesc="A very fast, flexible and easy to configure Web Server"
arch=('i686' 'x86_64')
......@@ -29,9 +29,9 @@ source=(http://www.cherokee-project.com/download/1.0/$pkgver/cherokee-$pkgver.ta
cherokee.rc
cherokee.logrotate)
options=('!libtool')
md5sums=('bca6dc0ec3eedd1c6e35bce5885bacdc'
md5sums=('40a95ac6184641230ea1aea9892a1ea3'
'a2d2b69c6220fab57cda4f531b680f9f'
'213069423f1c4a6abbb6e13a5b261bcf')
'8d69341bd4002bffd69c6e82ff6c905f')
build() {
cd "$srcdir/$pkgname-$pkgver"
......
# Returns only the major and minor parts of a version number
major_minor() {
echo $(expr "$1" : '\([^\.]*\.[^\.]*\)')
}
post_upgrade() {
# We use http.http from now on. Change introduced in 0.98.1-2.
if [ $(vercmp 0.98.1-2 $2) -gt 0 ]; then
echo -n ">>> Removing cherokee system user and group... "
userdel cherokee &>/dev/null
groupdel cherokee &>/dev/null
echo "done."
fi
# Prior to 0.99.13-1, the logrotate file was installed with 755 permissions
if [ $(vercmp 0.99.13-1 $2) -gt 0 ]; then
chmod -x etc/logrotate.d/cherokee
fi
# 0.99.27 needs a tiny change in the configuration file
if [ $(vercmp 0.99.27-1 $2) -gt 0 ]; then
cat << EOM
==> Small change in /etc/cherokee.conf is required
Cherokee 0.99.27 fixes a bug that affected the I/O-cache subsystem. This
introduced a minor, harmless regression. To avoid getting the following
error:
(error) icons.c:184 - Duped suffix (case insensitive) 'z', pointing
to 'package.png'
you need to open up /etc/cherokee.conf in a text editor and locate the line
starting with "icons!suffix!package.png". From this line, you should remove
the "z" extension.
More information at:
http://lists.octality.com/pipermail/cherokee/2009-November/011684.html
http://svn.cherokee-project.com/changeset/3777
EOM
fi
# If upgrading from an earlier version, the configuration file
# may need to be converted
if [ $(vercmp $(major_minor $1) $(major_minor $2)) -gt 0 ]; then
cat << EOM
==> Configuration conversion is possibly required
Since you're upgrading from an older version, you may need to
convert your configuration file (i.e. /etc/cherokee/cherokee.conf)
to be compatible with the new cherokee version.
Converters have been installed in /usr/share/cherokee/converters
EOM
fi
}
......@@ -2,8 +2,8 @@
daily
rotate 14
compress
delaycompress
sharedscripts
postrotate
/bin/kill -USR2 `cat /var/run/cherokee.pid 2>/dev/null` 2>/dev/null || true
/bin/kill -HUP `cat /var/run/cherokee.pid 2>/dev/null` 2>/dev/null || true
endscript
}
Index: /cherokee/trunk/admin/market/Makefile.am
===================================================================
--- /cherokee/trunk/admin/market/Makefile.am (revision 5670)
+++ /cherokee/trunk/admin/market/Makefile.am (revision 5734)
@@ -7,5 +7,4 @@
Install_Log.py \
Menu.py \
-Package.py \
PageApp.py \
PageCategory.py \
Index: /erokee/trunk/admin/market/Package.py
===================================================================
--- /cherokee/trunk/admin/market/Package.py (revision 5460)
+++ (revision )
@@ -1,34 +1,0 @@
-# -*- coding: utf-8 -*-
-#
-# Cherokee-admin
-#
-# Authors:
-# Alvaro Lopez Ortega <alvaro@alobbs.com>
-#
-# Copyright (C) 2001-2010 Alvaro Lopez Ortega
-#
-# This program is free software; you can redistribute it and/or
-# modify it under the terms of version 2 of the GNU General Public
-# License as published by the Free Software Foundation.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA
-# 02110-1301, USA.
-#
-
-class Package_Install_Widget (CTK.Box):
- def __init__ (self, package_local_path):
- Box.__init__ (self)
-
- self.status_uncompress = CTK.ImageStock('loading')
- self.status_setup = CTK.ImageStock('loading')
-
- table = CTK.Table()
- table += [CTK.RawHTML ("Uncompress"),
-
......@@ -14,7 +14,7 @@ pkgdesc="A videocast client for KDE. It makes it possible to subscribe to video
arch=('i686' 'x86_64')
url="http://kde-apps.org/content/show.php/Videocatcher?content=121556"
license=('GPL')
depends=(kdepimlibs qt boost)
depends=('kdepimlibs' 'qt' 'boost' 'docbook-xsl')
source=(http://kde-apps.org/CONTENT/content-files/121556-$pkgname-$pkgver.tar.bz2)
md5sums=('6c3b1f2da7837aa0be576ed68b153c35')
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment