removed kde-workspace conflicts of several packages as an attempt to automate the switch to plasma5

parent d7ccd735
......@@ -3,14 +3,13 @@ source ../plasma.conf
pkgname=kmenuedit
pkgver=${PVersion}
pkgrel=1
pkgrel=2
pkgdesc='KDE menu editor'
arch=('x86_64')
url='https://projects.kde.org/projects/kde/workspace/kmenuedit'
license=('LGPL')
depends=('khotkeys')
makedepends=('extra-cmake-modules' 'kdoctools' 'python3')
conflicts=('kde-workspace')
groups=('plasma')
options=("debug")
source=("${PServer}/${pkgver}/${pkgname}-${PSubVersion}.tar.xz")
......
......@@ -3,14 +3,13 @@ source ../plasma.conf
pkgname=ksysguard
pkgver=${PVersion}
pkgrel=1
pkgrel=2
pkgdesc="KSysguard"
arch=('x86_64')
url='https://projects.kde.org/projects/kde/workspace/ksysguard'
license=('LGPL')
depends=('knewstuff' 'libksysguard' 'lm_sensors' 'xdg-utils' 'hicolor-icon-theme' 'kdelibs4support')
makedepends=('extra-cmake-modules' 'kdoctools' 'python3')
conflicts=('kde-workspace')
groups=('plasma')
options=("debug")
source=("${PServer}/${pkgver}/${pkgname}-${PSubVersion}.tar.xz")
......
......@@ -3,7 +3,7 @@ source ../plasma.conf
pkgname=kwin
pkgver=${PSubVersion}
pkgrel=3
pkgrel=4
pkgdesc='KDE Window manager'
arch=('x86_64')
url='https://projects.kde.org/projects/kde/workspace/kwin'
......@@ -13,7 +13,6 @@ depends=('qt5-multimedia' 'plasma-framework' 'knewstuff' 'libxcursor' 'kinit'
makedepends=('extra-cmake-modules' 'qt5-tools' 'kdoctools')
groups=('plasma')
install=${pkgname}.install
conflicts=('kde-workspace')
options=("debug")
source=("${PServer}/${pkgver}/${pkgname}-${pkgver}.tar.xz")
sha256sums=( $(getSum ${pkgname}) )
......
......@@ -3,14 +3,13 @@ source ../plasma.conf
pkgname=libksysguard
pkgver=${PVersion}
pkgrel=1
pkgrel=2
pkgdesc="KSysguard library"
arch=('x86_64')
url='https://projects.kde.org/projects/kde/workspace/libksysguard'
license=('LGPL')
depends=('libxres' 'plasma-framework' 'qt5-webkit')
makedepends=('extra-cmake-modules' 'kdoctools' 'python3')
conflicts=('kde-workspace')
groups=('plasma')
options=("debug")
source=("${PServer}/${pkgver}/${pkgname}-${PSubVersion}.tar.xz")
......
......@@ -4,7 +4,7 @@ source ../plasma.conf
pkgbase=plasma-workspace
pkgname=('plasma-workspace' 'drkonqi')
pkgver=${PVersion}
pkgrel=2
pkgrel=3
pkgdesc='KDE Plasma Workspace'
arch=('x86_64')
url='https://projects.kde.org/projects/kde/workspace/plasma-workspace'
......@@ -37,7 +37,6 @@ build() {
package_plasma-workspace() {
optdepends=('plasma-workspace-wallpapers: additional wallpapers'
'gpsd: GPS support for geolocation')
conflicts=('kde-workspace')
cd build
make DESTDIR="${pkgdir}" install
......
......@@ -3,14 +3,13 @@ source ../plasma.conf
pkgname=systemsettings
pkgver=${PVersion}
pkgrel=1
pkgrel=2
pkgdesc='KDE system settings'
arch=('x86_64')
url='https://projects.kde.org/projects/kde/workspace/systemsettings'
license=('LGPL')
depends=('kcmutils' 'khtml')
makedepends=('extra-cmake-modules' 'kdoctools' 'python3')
conflicts=('kde-workspace')
groups=('plasma')
options=("debug")
source=("${PServer}/${pkgver}/${pkgname}-${PSubVersion}.tar.xz")
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment