Commit 5823bab4 authored by chaves's avatar chaves
Browse files

'enet-old' is now named just 'enet', and was upgraded to its 1.2.3 version....

'enet-old' is now named just 'enet', and was upgraded to its 1.2.3 version. 1.2.x branch still needed for 0ad, and probably for SuperTuxKart.
parent 42f6ebd0
......@@ -6,35 +6,34 @@
# include global config
source ../_buildscripts/${current_repo}-${_arch}-cfg.conf
pkgname=enet-old
_pkgname=enet
pkgver=1.2.2
pkgname=enet
pkgver=1.2.3
pkgrel=1
pkgdesc='A relatively thin, simple and robust network communication layer on top of UDP. (Old Version)'
arch=('i686' 'x86_64')
provides=('enet')
conflicts=('enet')
url='http://enet.bespin.org/'
license=('custom')
license=('MIT')
changelog=ChangeLog
source=("http://$_pkgname.bespin.org/download/$_pkgname-$pkgver.tar.gz")
md5sums=('bae05cb752649e8c692944d5480fb861')
source=("http://$pkgname.bespin.org/download/$pkgname-$pkgver.tar.gz")
md5sums=('30be76b63db9bcebb89e142ddbada20b')
build() {
cd $_pkgname-$pkgver
cd $pkgname-$pkgver
CFLAGS="-fPIC" ./configure --prefix=/usr
CFLAGS="-fPIC" \
./configure \
--prefix=/usr
make
gcc -Wl,-soname,libenet.so.2 -shared -o libenet.so.2 *.o
# gcc -Wl,-soname,libenet.so.2 -shared -o libenet.so.2 *.o
}
package() {
cd $_pkgname-$pkgver
cd $pkgname-$pkgver
make prefix=$pkgdir/usr install
install -m 755 libenet.so.2 $pkgdir/usr/lib
# install -m 755 libenet.so.2 $pkgdir/usr/lib
# License:
install -D -m644 LICENSE $pkgdir/usr/share/licenses/$_pkgname/LICENSE
install -D -m644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
}
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment