Commit 64b1982d authored by Anke's avatar Anke
Browse files

Merge branch 'master' of gitorious.org:chakra-packages/apps

parents 13c09c71 131eebbf
#
# Apps Packages for Chakra, part of chakra-project.org
#
pkgname=fcgi
pkgver=2.4.0
pkgrel=1
depends=('gcc-libs')
pkgdesc="FASTCgi(fcgi) islanguage independent, high performant extension to CGI"
arch=(i686 x86_64)
license=('custom')
options=('!libtool' '!makeflags')
url="http://www.fastcgi.com"
source=(http://www.fastcgi.com/dist/${pkgname}-${pkgver}.tar.gz
gcc44-fix-include.patch)
md5sums=('d15060a813b91383a9f3c66faf84867e'
'a8028462163755f3ce457a5c641f237b')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
patch -Np1 -i "${srcdir}/gcc44-fix-include.patch"
libtoolize --force
aclocal
autoconf
automake --foreign
./configure --prefix=/usr
make
make DESTDIR="${pkgdir}" install
install -Dm644 LICENSE.TERMS "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
Author: Tatsuki Sugiura <sugi@nemui.org>
Origin: vendor, http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=504963
Bug-Debian: http://bugs.debian.org/504963
Forwarded: no
Last-Update: 2010-02-08
Index: libfcgi/libfcgi/fcgio.cpp
===================================================================
--- libfcgi.orig/libfcgi/fcgio.cpp 2010-01-23 19:13:53.000000000 +0900
+++ libfcgi/libfcgi/fcgio.cpp 2010-01-23 19:13:55.000000000 +0900
@@ -22,6 +22,7 @@
#define DLLAPI __declspec(dllexport)
#endif
+#include <cstdio>
#include <limits.h>
#include "fcgio.h"
......@@ -8,7 +8,7 @@ source ../_buildscripts/${current_repo}-${_arch}-cfg.conf
pkgname=grass
pkgver=6.4.0
pkgrel=3
pkgrel=5
pkgdesc='Geographic Information System (GIS) used for geospatial data management and analysis, image processing, graphics/maps production, spatial modeling, and visualization.'
arch=('i686' 'x86_64')
url='http://grass.itc.it/index.php'
......@@ -27,8 +27,9 @@ source=("http://grass.itc.it/grass64/source/${pkgname}-${pkgver}.tar.gz"
"${pkgname}.desktop"
"${pkgname}.sh"
"${pkgname}.png")
md5sums=('ac3233aa3351f8e060ea48246aa01c7f'
'055e4157bf9713572c16edf9d2af921c'
'0323f2533f47cf75f1a0340bef546a11'
'db93730dd330f1539bd31b4373e1c00e'
'ae778ed261a40b078a8465994a0eb25e')
......
......@@ -5,7 +5,7 @@ GenericName=GIS
GenericName[it]=GIS
Comment="Geographic Information System (GIS) used for geospatial data management and analysis"
Comment[it]="Geographic Information System (GIS) usato per la gestione e analisi di dati geospaziali."
Exec=/usr/bin/grass64
Exec=/usr/bin/grass64 -tcltk
Icon=/usr/share/pixmaps/grass.png
Terminal=false
MultipleArgs=false
......
#
# Apps Packages for Chakra, part of chakra-project.org
#
pkgname=postgis
pkgver=1.5.2
pkgrel=1
pkgdesc="Adds support for geographic objects to PostgreSQL"
arch=('i686' 'x86_64')
url="http://postgis.refractions.net/"
license=('GPL')
depends=('postgresql' 'proj' 'geos')
source=(http://postgis.refractions.net/download/$pkgname-$pkgver.tar.gz)
md5sums=('772ec1d0f04d6800cd7e2420a97a7483')
build() {
cd ${srcdir}/$pkgname-$pkgver
./configure --prefix=/usr
make
}
package() {
cd ${srcdir}/$pkgname-$pkgver
make DESTDIR=${pkgdir} install
}
......@@ -8,8 +8,8 @@
source ../_buildscripts/${current_repo}-${_arch}-cfg.conf
pkgname=qbittorrent
pkgver=2.7.2
pkgrel=2
pkgver=2.7.3
pkgrel=1
pkgdesc="A bittorrent client written in C++ / Qt4 using the good libtorrent library"
arch=('i686' 'x86_64')
url="http://www.qbittorrent.org/"
......@@ -20,7 +20,7 @@ optdepends=('python2: needed for search'
'geoip: improves peer country resolution')
install=qbittorrent.install
source=(http://downloads.sourceforge.net/sourceforge/qbittorrent/${pkgname}-${pkgver}.tar.gz)
md5sums=('0ebd9ff8a0963b5cc7092f328d6df105')
md5sums=('ff1b294133f8dadc781c8f0df50d248d')
build()
{
......
#
# Chakra Packages for Chakra, part of chakra-project.org
#
pkgname=qgis
pkgver=1.6.0
pkgrel=1
pkgdesc='A Geographic Information System (GIS) that supports vector, raster & database formats.'
url='http://qgis.org/'
license=('GPL')
arch=('i686' 'x86_64')
depends=('libmysqlclient' 'postgresql-libs' 'sqlite3' 'jasper' 'curl' 'qt' 'python2' 'pyqt' 'giflib' 'xerces-c' 'cfitsio' 'qwt' 'gdal')
makedepends=('grass' 'gsl' 'postgis' 'netcdf' 'cmake' 'fcgi' 'sip')
optdepends=('postgis: postgis support and SPIT plugin'
'fcgi: qgis mapserver'
'sip: python-support'
'grass: grass plugin'
'gsl: georeferencer ')
options=('!makeflags')
source=("http://qgis.org/downloads/${pkgname}-${pkgver}.tar.bz2"
'qgis.desktop'
'ticket_3378.diff')
md5sums=('9ea8a784d970f5009b0e6271820248f6'
'8ab66039f2aba519b92f52272ec3c13e'
'402f3d39a344367fd55bdaa324deb797')
build() {
cd ${pkgname}-${pkgver}
# fix compilation error https://trac.osgeo.org/qgis/ticket/3378
patch -Np3 -i ${srcdir}/ticket_3378.diff
cd ${srcdir}
rm -rf build
mkdir build
cd build
cmake ../${pkgname}-${pkgver} \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_SKIP_RPATH=ON \
-DCMAKE_INSTALL_PREFIX=/usr \
-DGRASS_PREFIX=/opt/grass \
-DQGIS_MANUAL_SUBDIR=share/man
make
}
package() {
cd build
make DESTDIR=${pkgdir} install
# install some freedesktop.org compatibility
install -D -m644 ${srcdir}/${pkgname}.desktop \
${pkgdir}/usr/share/applications/${pkgname}.desktop
}
[Desktop Entry]
Name=Quantum GIS
GenericName="GIS"
Comment="Geographic Information System (GIS) that supports vector, raster & database formats"
Exec=/usr/bin/qgis
Icon=/usr/share/qgis/images/icons/qgis-icon.png
Terminal=false
MultipleArgs=false
Type=Application
Categories=Application;Science
Index: /trunk/qgis/python/core/conversions.sip
===================================================================
--- /trunk/qgis/python/core/conversions.sip (revision 14323)
+++ /trunk/qgis/python/core/conversions.sip (revision 14988)
@@ -16,4 +16,5 @@
%Feature QSETINT_CONVERSION
+%Feature QSETTYPE_CONVERSION
%ModuleHeaderCode
@@ -321,5 +322,5 @@
%End
-
+%If (QSETTYPE_CONVERSION)
template <TYPE>
%MappedType QSet<TYPE>
@@ -395,6 +396,5 @@
};
-
-
+%End
template<TYPE>
Index: /trunk/qgis/python/CMakeLists.txt
===================================================================
--- /trunk/qgis/python/CMakeLists.txt (revision 14330)
+++ /trunk/qgis/python/CMakeLists.txt (revision 14988)
@@ -44,4 +44,8 @@
ENDIF(NOT PYQT4_VERSION_NUM LESS 263941)
+IF(NOT PYQT4_VERSION_NUM LESS 264194) # 0x040802
+ SET(SIP_DISABLE_FEATURES ${SIP_DISABLE_FEATURES} QSETTYPE_CONVERSION)
+ENDIF(NOT PYQT4_VERSION_NUM LESS 264194)
+
# core module
FILE(GLOB sip_files_core core/*.sip)
......@@ -5,7 +5,7 @@
# maintainer (x86_64): Manuel Tortosa <manutortosa[at]chakra-project[dot]org>
pkgname=wine
pkgver=1.3.17
pkgver=1.3.18
pkgrel=1
_pkgbasever=${pkgver/rc/-rc}
......@@ -136,5 +136,5 @@ package() {
}
# vim:set ts=8 sts=2 sw=2 et:
md5sums=('f8d9d1d8cdab27ad311fa3743a1a0bc5')
md5sums=('17fb6334af12af17feb843f68272b070')
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment