Commit af86d18b authored by Xuetian Weng's avatar Xuetian Weng

update obs, rebuild cantata freerdp. [skip-ci]

parent 4960dcdf
Pipeline #523 skipped
pkgname=cantata
pkgver=2.3.0
pkgrel=1
pkgrel=2
pkgdesc='Qt5 client for the music player daemon (MPD)'
arch=('x86_64')
arch=(x86_64)
url='https://github.com/CDrummond/cantata'
license=('GPL')
depends=('qt5-svg' 'qt5-multimedia' 'libmtp' 'libcddb' 'libmusicbrainz5' 'mpg123' 'taglib-extras'
'cdparanoia' 'media-player-info' 'udisks2')
optdepends=('perl-uri: dynamic playlist' 'mpd: playback' 'ffmpeg: ReplayGain support')
makedepends=('cmake' 'qt5-tools' 'ffmpeg')
install=$pkgname.install
license=(GPL)
depends=(libmtp libmusicbrainz5 mpg123 vlc taglib-extras media-player-info libcdio-paranoia udisks2 qt5-multimedia)
optdepends=('perl-uri: dynamic playlist' 'mpd: playback' 'ffmpeg: ReplayGain support' 'libebur128: ReplayGain support'
'sshfs: remote devices support')
makedepends=(cmake qt5-tools ffmpeg libebur128)
source=("https://github.com/CDrummond/cantata/releases/download/v$pkgver/$pkgname-$pkgver.tar.bz2")
sha256sums=('15a4496cdacbb6d22880dcca3011bd0d7738fc07b03e34aa745d1533c7f33db7')
......
pkgname=freerdp
pkgver=2.0.0_rc2
#_commit=6001cb710dc67eb8811362b7bf383754257a902b
_pkgver=${pkgver/_/-}
_pkgver=${_pkgver/+/-}
pkgrel=2
......@@ -15,8 +16,16 @@ makedepends=('krb5' 'cmake' 'damageproto' 'fixesproto' 'renderproto'
'xmlto' 'docbook-xsl' 'git')
provides=('libwinpr-tools2.so' 'libfreerdp-client2.so' 'libfreerdp2.so'
'libwinpr2.so')
source=($pkgname-$pkgver.tar.gz::https://github.com/FreeRDP/FreeRDP/archive/${pkgver/_/-}.tar.gz)
sha256sums=('SKIP')
#source=("FreeRDP-${_pkgver}::git://github.com/FreeRDP/FreeRDP.git#commit=${_commit}")
source=($pkgname-$pkgver.tar.gz::https://github.com/FreeRDP/FreeRDP/archive/${pkgver/_/-}.tar.gz
fix_nla-8cd156a-backport.patch)
sha256sums=('a09e338b996fada44bf1277f423240d0fa82289799e2e5dea9d9c63201554de1'
'2d449e0c1adee1ef131501e1613fc4c59fd122ca866d09f52eeff61236de81e4')
prepare() {
cd "$srcdir"/FreeRDP-${_pkgver}
# patch -Np1 -i "${srcdir}/fix_nla-8cd156a-backport.patch"
}
build() {
cd "$srcdir"/FreeRDP-${_pkgver}
......
From: Bernhard Miklautz <bernhard.miklautz@thincast.com>
Date: Wed, 14 Mar 2018 13:39:23 +0100
Subject: [PATCH] fix nla: don't use server version
FreeRDP currently only supports CredSSP protocol version 3. However the
current implementation always sent back the version received by the
server indicating that this version was supported.
With recent windows updates applied the protocol changed and this approach
doesn't work anymore (see
https://msdn.microsoft.com/en-us/library/mt752485.aspx for protocol changes).
With this fix FreeRDP always sends version 3 as supported version.
Credit goes to @mfleisz.
Fixes #4449
(patch above adjusted to apply on top of FreeRDP-2.0.0-rc1)
---
libfreerdp/core/nla.c | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)
diff --git a/libfreerdp/core/nla.c b/trunk/src/FreeRDP-2.0.0-rc1/libfreerdp/core/nla.c
index 47e0870..4bfcf7e 100644
--- a/libfreerdp/core/nla.c
+++ b/libfreerdp/core/nla.c
@@ -1663,14 +1663,17 @@ BOOL nla_send(rdpNla* nla)
static int nla_decode_ts_request(rdpNla* nla, wStream* s)
{
int length;
+ UINT32 version = 0;
/* TSRequest */
if (!ber_read_sequence_tag(s, &length) ||
!ber_read_contextual_tag(s, 0, &length, TRUE) ||
- !ber_read_integer(s, &nla->version))
+ !ber_read_integer(s, &version))
{
return -1;
}
+ if (version < nla->version)
+ nla->version = version;
/* [1] negoTokens (NegoData) */
if (ber_read_contextual_tag(s, 1, &length, TRUE) != FALSE)
--
2.16.2
# Arch contributor: https://git.archlinux.org/svntogit/packages.git/plain/trunk/PKGBUILD?h=packages/libebur128
pkgname=libebur128
pkgver=1.2.4
pkgrel=1
pkgdesc="A library that implements the EBU R 128 standard for loudness normalisation."
arch=(x86_64)
url="https://github.com/jiixyj/libebur128"
license=(MIT)
depends=(glibc)
makedepends=(cmake)
source=($pkgname-$pkgver.tar.gz::"https://github.com/jiixyj/$pkgname/archive/v$pkgver.tar.gz")
sha256sums=('2ee41a3a5ae3891601ae975d5ec2642b997d276ef647cf5c5b363b6127f7add8')
prepare() {
mkdir -p build
}
build() {
cd build
cmake ../$pkgname-$pkgver \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_STATIC_LIBS=OFF
make
}
package() {
cd build
make DESTDIR="$pkgdir" install
install -Dm644 "$srcdir"/$pkgname-$pkgver/COPYING "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
pkgname=obs-studio
pkgver=21.0.2
pkgrel=2
pkgver=21.1.2
pkgrel=1
pkgdesc="Free, open source software for live streaming and recording"
arch=('x86_64')
url="https://obsproject.com"
license=('GPL2')
depends=('ffmpeg' 'jansson' 'libxinerama' 'libxkbcommon-x11'
'qt5-x11extras' 'curl' 'hicolor-icon-theme' 'jack')
'qt5-x11extras' 'curl' 'jack' 'gtk-update-icon-cache')
makedepends=('cmake' 'libfdk-aac' 'libxcomposite' 'x264' 'vlc' 'swig' 'python3' 'luajit')
optdepends=('libfdk-aac: FDK AAC codec support'
'libxcomposite: XComposite capture support'
'vlc: VLC plugin'
'luajit: scripting support'
'python3: scripting support')
install=$pkgname.install
source=("$pkgname-$pkgver::https://github.com/jp9000/obs-studio/archive/$pkgver.tar.gz")
sha256sums=('b8faa5f50b2139204275fe4ce8b3a3caadc2a66f1562ff3df367cb40562e9bc8')
'python: scripting support'
'vlc: VLC Media Source support')
source=($pkgname-$pkgver.tar.gz::https://github.com/jp9000/obs-studio/archive/$pkgver.tar.gz
'qt-5.11.patch::https://github.com/obsproject/obs-studio/commit/4fd06b9825465ae5eb2a9b862cdb89098f655f14.patch')
md5sums=('fc36a9e8d8c8018955c64197f18f839a'
'e13f53eeda3154176fa458e089510cfe')
prepare() {
cd $pkgname-$pkgver
mkdir -p build
patch -Np1 -i ../qt-5.11.patch
}
build() {
cd $pkgname-$pkgver/build
cd $pkgname-$pkgver
mkdir -p build; cd build
cmake -DCMAKE_INSTALL_PREFIX=/usr \
-DOBS_VERSION_OVERRIDE="$pkgver-$pkgrel" ..
cmake -DCMAKE_INSTALL_PREFIX="/usr" \
-DOBS_VERSION_OVERRIDE="$pkgver-$pkgrel" ..
make
}
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment