Commit d1046885 authored by Manuel's avatar Manuel

Fix kdepim for work with both kdes

parent 55953b9b
......@@ -35,7 +35,7 @@ depends=('polkit-kde-agent' "kdepimlibs>=${_kdever}" "kdebase-runtime>=${_kdever
makedepends=('pkgconfig' 'cmake' 'automoc4' 'networkmanager' 'bluez' "kdebindings-python>=${_kdever}"
"kdebindings-ruby>=${_kdever}" 'oxygen-icons' 'qedje' "kdebase-runtime>=${_kdever}" 'gpsd' 'samba'
'libraw1394' 'libdmtx' 'consolekit' 'docbook-xsl' 'google-gadgets-qt>=0.11.2')
'libraw1394' 'libdmtx' 'consolekit' 'docbook-xsl' 'google-gadgets-qt>=0.11.2' 'boost')
source=($_mirror/${pkgbase}-$_kdever.tar.bz2
mishaaq-kcm_touchpad-00370b5.tar.gz
......
......@@ -23,7 +23,7 @@ url="http://www.kde.org"
license=('GPL' 'LGPL' 'FDL')
install=${pkgbase}.install
options=('docs' '!splithdr' 'splitdbg' 'log')
depends=("kdepimlibs>=${_kdever}" "kdebase-runtime>=${_kdever}" "kdelibs>=${_kdever}")
depends=("kdepimlibs>=${_kdever}" "kdebase-runtime" "kdelibs>=${_kdever}")
makedepends=('pkgconfig' 'cmake' 'automoc4')
groups=("kde" "kdepim" "kde-uninstall" "kde-minimal")
......
......@@ -10,7 +10,7 @@ source ../_buildscripts/${current_repo}-${_arch}-cfg.conf
#
# package info
#
pkgbase=('kdepim')
pkgbase="kdepim"
pkgname=('kdepim-common'
'kdepim-doc'
'kdepim-akonadiconsole'
......@@ -42,8 +42,8 @@ license=('GPL' 'LGPL' 'FDL')
options=('!docs' '!splithdr' 'splitdbg' 'log')
makedepends=('pkgconfig' 'cmake' 'automoc4' 'boost' "kdelibs>=${_kdever}" "kdepimlibs>=${_kdever}"
"kdepim-runtime>=${pkgver}" 'libxss' "kdebase-runtime>=${_kdever}"
'kde-agent' 'libindicate-qt>=0.2.2' 'docbook-xml')
"kdepim-runtime" 'libxss' "kdebase-runtime"
'kde-agent' 'libindicate-qt>=0.2.2' 'docbook-xml' 'dblatex')
source=($_mirror/${pkgbase}-${pkgver}.tar.bz2)
......@@ -56,10 +56,6 @@ build()
{
cd ${srcdir}/${pkgbase}-${pkgver}
# Documents translations don't compile atm
# rm ${startdir}/src/kdepim-4.5.94/doc-translations/CMakeLists.txt
# touch ${startdir}/src/kdepim-4.5.94/doc-translations/CMakeLists.txt
msg "starting build ..."
cmake . -DCMAKE_BUILD_TYPE=${_build_type} \
-DCMAKE_INSTALL_PREFIX=${_installprefix} \
......@@ -77,8 +73,8 @@ build()
package_kdepim-common()
{
pkgdesc="KDE PIM - Common files and libraries"
depends=("kdepimlibs>=${_kdever}" 'libxss' "kdebase-runtime>=${_kdever}" 'kde-agent'
'libxss' 'libindicate-qt>=0.2.2' "kdepim-runtime>=${pkgver}")
depends=("kdepimlibs>=${_kdever}" 'libxss' "kdebase-runtime" 'kde-agent'
'libxss' 'libindicate-qt>=0.2.2' "kdepim-runtime>=${_kdever}")
groups=("kde" "kdepim" "kde" "kde-uninstall")
install=${pkgbase}.install
......@@ -96,7 +92,6 @@ package_kdepim-doc()
{
pkgdesc="KDE PIM - Documentation"
groups=("${pkgbase}" "kde" "kde-doc" "kde-uninstall")
depends=("${pkgbase}-common>=${pkgver}")
splitdirs="doc"
for i in ${splitdirs} ; do
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment