Commit fb7b6109 authored by AlmAck's avatar AlmAck

remove all .install referencies in the kdeapps group

we use alpm hooks
no pkgrel++, no build [skip-ci]
parent a0caaa2d
Pipeline #652 skipped
......@@ -13,7 +13,6 @@ makedepends=(extra-cmake-modules postgresql qt5-tools boost python kdesignerplug
checkdepends=('xorg-server-xvfb')
optdepends=('postgresql: PostgreSQL backend'
'mariadb: MariaDB backend')
install="${pkgname}.install"
conflicts=('akonadi-client')
provides=('akonadi-client' 'akonadi-qt4')
replaces=('akonadi-client' 'akonadi-qt4')
......
post_install() {
update-mime-database usr/share/mime &> /dev/null
}
post_upgrade() {
post_install
}
post_remove() {
post_install
}
post_install() {
xdg-icon-resource forceupdate --theme hicolor &> /dev/null
update-desktop-database -q
}
post_upgrade() {
post_install
}
post_remove() {
post_install
}
......@@ -18,7 +18,6 @@ optdepends=("p7zip: 7Z format support"
conflicts=(kdeutils-ark)
replaces=(kdeutils-ark)
groups=('kde' 'kde-uninstall' 'kde-applications' 'kdeutils')
install=kdeutils.install
source=("https://download.kde.org/stable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig})
sha256sums=('088b1fe8cca84bce022cc012f604280228598c4f70917ac425e95ac8131a8d22'
......
post_install() {
if [ -e "/etc/chakra/updates.conf" ] ; then
. /etc/chakra/updates.conf
if [ "$UPDATE_XDG_ICON_DB" = "yes" ]; then
/usr/bin/chakra-update-icons
fi
if [ "$UPDATE_GLOBAL_CONFIG" = "yes" ]; then
/usr/bin/chakra-update-sycoca
fi
if [ "$UPDATE_USER_CONFIG" = "yes" ]; then
/usr/bin/chakra-update-user-sycoca
fi
else
echo " > WARNING"
echo " The package chakra-common seems not to be installed,"
echo " this can possibly break the installation. Just install it"
echo " manually after this installation/update, run the following"
echo " commands and restart KDE afterwards:"
echo " sudo chakra-config-updater"
echo " kbuildsycoca4"
echo " "
fi
}
post_upgrade() {
if [ -e "/etc/chakra/updates.conf" ] ; then
. /etc/chakra/updates.conf
if [ "$UPDATE_XDG_ICON_DB" = "yes" ]; then
/usr/bin/chakra-update-icons
fi
if [ "$UPDATE_GLOBAL_CONFIG" = "yes" ]; then
/usr/bin/chakra-update-sycoca
fi
if [ "$UPDATE_USER_CONFIG" = "yes" ]; then
/usr/bin/chakra-update-user-sycoca
fi
else
echo " > WARNING"
echo " The package chakra-common seems not to be installed,"
echo " this can possibly break the installation. Just install it"
echo " manually after this installation/update, run the following"
echo " commands and restart KDE afterwards:"
echo " sudo chakra-config-updater"
echo " kbuildsycoca4"
echo " "
fi
}
post_remove() {
if [ -e "/etc/chakra/updates.conf" ] ; then
. /etc/chakra/updates.conf
if [ "$UPDATE_XDG_ICON_DB" = "yes" ]; then
/usr/bin/chakra-update-icons
fi
if [ "$UPDATE_GLOBAL_CONFIG" = "yes" ]; then
/usr/bin/chakra-update-sycoca
fi
if [ "$UPDATE_USER_CONFIG" = "yes" ]; then
/usr/bin/chakra-update-user-sycoca
fi
else
echo " > WARNING"
echo " The package chakra-common seems not to be installed,"
echo " this can possibly break the installation. Just install it"
echo " manually after this installation/update, run the following"
echo " commands and restart KDE afterwards:"
echo " sudo chakra-config-updater"
echo " kbuildsycoca4"
echo " "
fi
}
op=$1
shift
$op $*
......@@ -12,7 +12,6 @@ depends=(hicolor-icon-theme kdeclarative knewstuff qt5-gstreamer qt5-multimedia)
makedepends=(extra-cmake-modules kdoctools boost)
conflicts=(kdeedu-artikulate)
replaces=(kdeedu-artikulate)
install=$pkgname.install
options=('docs' 'debug')
source=("https://download.kde.org/stable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig})
sha256sums=('8ab0241662a978ed6df4c924dc274391427d2be51961ac9b8bad14fe599581cc'
......
post_install() {
xdg-icon-resource forceupdate --theme hicolor &> /dev/null
update-desktop-database -q
}
post_upgrade() {
post_install
}
post_remove() {
post_install
}
post_install() {
xdg-icon-resource forceupdate --theme hicolor &> /dev/null
}
post_upgrade() {
post_install
}
post_remove() {
post_install
}
......@@ -23,7 +23,6 @@ replaces=('kdeedu-cantor')
conflicts=('kdeedu-cantor')
groups=('kde' 'kde-uninstall' 'kde-applications' 'kdeedu')
options=('docs' 'debug')
install=${pkgname}.install
source=("https://download.kde.org/stable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig})
sha256sums=('aab96ae512c3ddfaaf288ca0531b685c689a40a31222326441501b9a18bc320d'
'SKIP')
......
post_install() {
xdg-icon-resource forceupdate --theme hicolor &> /dev/null
update-desktop-database -q
}
post_upgrade() {
post_install
}
post_remove() {
post_install
}
......@@ -13,7 +13,6 @@ makedepends=(extra-cmake-modules python3 kdoctools)
conflicts=(kdesdk-cervisia)
replaces=(kdesdk-cervisia)
groups=('kde' 'kde-uninstall' 'kde-applications' 'kdesdk')
install=kdesdk.install
options=('docs' 'debug')
source=("https://download.kde.org/stable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig})
......
post_install() {
if [ -e "/etc/chakra/updates.conf" ] ; then
. /etc/chakra/updates.conf
if [ "$UPDATE_XDG_ICON_DB" = "yes" ]; then
/usr/bin/chakra-update-icons
fi
if [ "$UPDATE_GLOBAL_CONFIG" = "yes" ]; then
/usr/bin/chakra-update-sycoca
fi
if [ "$UPDATE_USER_CONFIG" = "yes" ]; then
/usr/bin/chakra-update-user-sycoca
fi
else
echo " > WARNING"
echo " The package chakra-common seems not to be installed,"
echo " this can possibly break the installation. Just install it"
echo " manually after this installation/update, run the following"
echo " commands and restart KDE afterwards:"
echo " sudo chakra-config-updater"
echo " kbuildsycoca4"
echo " "
fi
}
post_upgrade() {
if [ -e "/etc/chakra/updates.conf" ] ; then
. /etc/chakra/updates.conf
if [ "$UPDATE_XDG_ICON_DB" = "yes" ]; then
/usr/bin/chakra-update-icons
fi
if [ "$UPDATE_GLOBAL_CONFIG" = "yes" ]; then
/usr/bin/chakra-update-sycoca
fi
if [ "$UPDATE_USER_CONFIG" = "yes" ]; then
/usr/bin/chakra-update-user-sycoca
fi
else
echo " > WARNING"
echo " The package chakra-common seems not to be installed,"
echo " this can possibly break the installation. Just install it"
echo " manually after this installation/update, run the following"
echo " commands and restart KDE afterwards:"
echo " sudo chakra-config-updater"
echo " kbuildsycoca4"
echo " "
fi
}
post_remove() {
if [ -e "/etc/chakra/updates.conf" ] ; then
. /etc/chakra/updates.conf
if [ "$UPDATE_XDG_ICON_DB" = "yes" ]; then
/usr/bin/chakra-update-icons
fi
if [ "$UPDATE_GLOBAL_CONFIG" = "yes" ]; then
/usr/bin/chakra-update-sycoca
fi
if [ "$UPDATE_USER_CONFIG" = "yes" ]; then
/usr/bin/chakra-update-user-sycoca
fi
else
echo " > WARNING"
echo " The package chakra-common seems not to be installed,"
echo " this can possibly break the installation. Just install it"
echo " manually after this installation/update, run the following"
echo " commands and restart KDE afterwards:"
echo " sudo chakra-config-updater"
echo " kbuildsycoca4"
echo " "
fi
}
op=$1
shift
$op $*
post_install() {
echo " "
echo " Plasma 5 based KDE Frameworks 5"
echo " Packaged by the Chakra Project"
echo " Packaged by the Chakra Linux team"
echo " "
echo " Installation prefix: /usr"
echo " Configuration directory: ~/.config"
......@@ -9,12 +9,10 @@ post_install() {
echo " "
echo " Website: https://chakralinux.org"
echo " News: https://community.chakralinux.org/c/news"
echo " Wiki: https://chakralinux.org/wiki/"
echo " Forum: https://community.chakralinux.org"
echo " Bugtracker: https://chakralinux.org/bugtracker/"
echo " Packages: https://chakralinux.org/packages/"
echo " Bugtracker: https://code.chakralinux.org"
echo " CCR: https://chakralinux.org/ccr/"
echo " Changelogs: http://chakralinux.org/code/"
echo " Changelogs: https://community.chakralinux.org/tags/release"
echo " "
}
......
......@@ -12,7 +12,6 @@ makedepends=('extra-cmake-modules' 'kdoctools' 'python3')
conflicts=('kde-baseapps-dolphin<15.04.3-1')
replaces=(kde-baseapps-dolphin)
groups=('kde' 'kde-uninstall' 'kde-applications' 'kdebase')
install=$pkgname.install
options=('docs' 'debug')
source=("https://download.kde.org/stable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig})
sha256sums=('b27ecfc4864638d88f2efd59f183d469f801ba0d85c37ca872e85ed70ba8683e'
......
post_install() {
xdg-icon-resource forceupdate --theme hicolor &> /dev/null
update-desktop-database -q
}
post_upgrade() {
post_install
}
post_remove() {
post_install
}
......@@ -15,7 +15,6 @@ conflicts=('kdeutils-filelight')
replaces=('kdeutils-filelight')
groups=('kde' 'kde-uninstall' 'kde-applications' 'kdeutils')
categories=('utils')
install=kdeutils.install
source=("https://download.kde.org/stable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig})
sha256sums=('c2bf1b4f529d38d4a8885217377771052b5a46502ad411dabf1b3f42b9fb1cc4'
'SKIP')
......
post_install() {
if [ -e "/etc/chakra/updates.conf" ] ; then
. /etc/chakra/updates.conf
if [ "$UPDATE_XDG_ICON_DB" = "yes" ]; then
/usr/bin/chakra-update-icons
fi
if [ "$UPDATE_GLOBAL_CONFIG" = "yes" ]; then
/usr/bin/chakra-update-sycoca
fi
if [ "$UPDATE_USER_CONFIG" = "yes" ]; then
/usr/bin/chakra-update-user-sycoca
fi
else
echo " > WARNING"
echo " The package chakra-common seems not to be installed,"
echo " this can possibly break the installation. Just install it"
echo " manually after this installation/update, run the following"
echo " commands and restart KDE afterwards:"
echo " sudo chakra-config-updater"
echo " kbuildsycoca4"
echo " "
fi
}
post_upgrade() {
if [ -e "/etc/chakra/updates.conf" ] ; then
. /etc/chakra/updates.conf
if [ "$UPDATE_XDG_ICON_DB" = "yes" ]; then
/usr/bin/chakra-update-icons
fi
if [ "$UPDATE_GLOBAL_CONFIG" = "yes" ]; then
/usr/bin/chakra-update-sycoca
fi
if [ "$UPDATE_USER_CONFIG" = "yes" ]; then
/usr/bin/chakra-update-user-sycoca
fi
else
echo " > WARNING"
echo " The package chakra-common seems not to be installed,"
echo " this can possibly break the installation. Just install it"
echo " manually after this installation/update, run the following"
echo " commands and restart KDE afterwards:"
echo " sudo chakra-config-updater"
echo " kbuildsycoca4"
echo " "
fi
}
post_remove() {
if [ -e "/etc/chakra/updates.conf" ] ; then
. /etc/chakra/updates.conf
if [ "$UPDATE_XDG_ICON_DB" = "yes" ]; then
/usr/bin/chakra-update-icons
fi
if [ "$UPDATE_GLOBAL_CONFIG" = "yes" ]; then
/usr/bin/chakra-update-sycoca
fi
if [ "$UPDATE_USER_CONFIG" = "yes" ]; then
/usr/bin/chakra-update-user-sycoca
fi
else
echo " > WARNING"
echo " The package chakra-common seems not to be installed,"
echo " this can possibly break the installation. Just install it"
echo " manually after this installation/update, run the following"
echo " commands and restart KDE afterwards:"
echo " sudo chakra-config-updater"
echo " kbuildsycoca4"
echo " "
fi
}
op=$1
shift
$op $*
......@@ -12,7 +12,6 @@ depends=('kded' 'kactivities-frameworks' 'libkdcraw' 'libkipi' 'baloo-kf5' 'lcms
makedepends=('extra-cmake-modules' 'kdoctools' 'python3')
optdepends=('qt5-imageformats: support for tiff, webp, and more image formats'
'kimageformats: support for dds, xcf, exr, psd, and more image formats')
install=${pkgname}.install
groups=('kde' 'kde-uninstall' 'kde-applications' 'kdegraphics')
provides=('kdegraphics-gwenview')
replaces=('kdegraphics-gwenview')
......
post_install() {
xdg-icon-resource forceupdate --theme hicolor &> /dev/null
update-desktop-database -q
}
post_upgrade() {
post_install
}
post_remove() {
post_install
}
......@@ -16,7 +16,6 @@ optdepends=('dvd+rw-tools: for dvd burning support'
'emovix: for bootable multimedia cd/dvd support'
'cdrdao: for disk-at-once (DAO) mode support'
'cdparanoia: for cd ripping support')
install=$pkgname.install
options=('debug')
source=("https://download.kde.org/stable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig})
sha256sums=('d6c3ec1ee2952421f1585167185409eb15ddeadabb4d1fd6df0478a2588ac6fb'
......
post_install() {
xdg-icon-resource forceupdate --theme hicolor &> /dev/null
update-mime-database usr/share/mime &> /dev/null
}
post_upgrade() {
post_install
}
post_remove() {
post_install
}
......@@ -15,7 +15,6 @@ replaces=('kdeedu-kalgebra')
conflicts=('kdeedu-kalgebra')
groups=("kde" "kdeedu" "kde-uninstall")
categories=('education')
install=${pkgname}.install
source=("https://download.kde.org/stable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig})
sha256sums=('1c4abdcc0229a80bb2da83b063f4e76983597ac7f791b7afb462388538c3c3ee'
'SKIP')
......
post_install() {
xdg-icon-resource forceupdate --theme hicolor &> /dev/null
update-desktop-database -q
}
post_upgrade() {
post_install
}
post_remove() {
post_install
}
......@@ -15,7 +15,6 @@ conflicts=('kdeedu-kanagram')
replaces=('kdeedu-kanagram')
groups=("kde" "kdeedu" "kde-uninstall")
categories=('education')
install=${pkgname}.install
source=("https://download.kde.org/stable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig})
sha256sums=('7d687bda6187a27af4d651128fad20bf14d2e73b7ccc4368840ba603ba8d8926'
'SKIP')
......
post_install() {
xdg-icon-resource forceupdate --theme hicolor &> /dev/null
}
post_upgrade() {
post_install
}
post_remove() {
post_install
}
......@@ -12,7 +12,6 @@ replaces=('kdesdk-kapptemplate')
conflicts=('kdesdk-kapptemplate')
provides=('kdesdk-kapptemplate')
categories=('programming')
install=${pkgname}.install
license=('GPL' 'LGPL' 'FDL')
source=("https://download.kde.org/stable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig})
sha256sums=('ace6eb0285e52c1f7d14b4d25041b4b12946575e5e5f074f3c7f4ecae113bfb4'
......
post_install() {
xdg-icon-resource forceupdate --theme hicolor &> /dev/null
}
post_upgrade() {
post_install
}
post_remove() {
post_install
}
......@@ -41,7 +41,6 @@ package_kwrite() {
groups=('kde')
url="http://www.kde.org/applications/utilities/kwrite/"
screenshot="https://www.kde.org/images/screenshots/kwrite.png"
install='kwrite.install'
replaces=('kde-baseapps-kwrite')
conflicts=('kde-baseapps-kwrite')
provides=('kde-baseapps-kwrite')
......@@ -58,7 +57,6 @@ package_kate() {
groups=('kde')
url="http://www.kde.org/applications/utilities/kate/"
screenshot="https://www.kde.org/images/screenshots/kate.png"
install='kate.install'
replaces=('kdesdk-kate')
conflicts=('kdesdk-kate')
provides=('kdesdk-kate')
......
post_install() {
xdg-icon-resource forceupdate --theme hicolor &> /dev/null
update-desktop-database -q
update-mime-database usr/share/mime &> /dev/null
}
post_upgrade() {
post_install
}
post_remove() {
post_install
}
\ No newline at end of file
post_install() {
xdg-icon-resource forceupdate --theme hicolor &> /dev/null
update-desktop-database -q
}
post_upgrade() {
post_install
}
post_remove() {
post_install
}
\ No newline at end of file
post_install() {
xdg-icon-resource forceupdate --theme hicolor &> /dev/null
}
post_upgrade() {
post_install
}
post_remove() {
post_install
}
......@@ -9,7 +9,6 @@ screenshot="http://www.kde.org/images/screenshots/kcachegrind.png"
groups=(kde-applications kdesdk)
depends=(kio hicolor-icon-theme)
makedepends=(extra-cmake-modules kdoctools python3 qt5-tools)
install=kdesdk.install
license=('GPL' 'LGPL' 'FDL')
options=('docs' 'debug')
conflicts=(kdesdk-kcachegrind)
......
post_install() {
if [ -e "/etc/chakra/updates.conf" ] ; then
. /etc/chakra/updates.conf