disable_upgrade.patch 507 Bytes
Newer Older
1 2 3 4 5 6 7
--- upgrade.py.orig	2013-10-31 12:46:54.000000000 +0100
+++ upgrade.py	2013-12-04 14:58:03.000000000 +0100
@@ -134,6 +134,11 @@ except getopt.GetoptError, e:
 if os.getenv("HPLIP_DEBUG"):
     log.set_level('debug')
 
+
totte's avatar
totte committed
8
+log.error("HPLIP upgrade is disabled by Chakra for security reasons, if you like to upgrade HPLIP, use the Chakra software package manager pacman or open a bugreport on https://code.chakralinux.org")
9 10 11 12 13 14
+clean_exit(1)
+
+
 for o, a in opts:
     if o in ('-h', '--help'):
         usage()