Commit 060d998e authored by Luca Giambonini's avatar Luca Giambonini

octopi 0.7.0 (added knotifications for -qt5 version, compatible with kf5)

added new octopi deps, gist
parent d19c63dc
pkgname=gist
pkgver=4.3.0
pkgrel=1
pkgdesc="Provides a gist command to use from the terminal to upload content to https://gist.github.com/."
arch=('x86_64')
url="http://github.com/defunkt/gist"
license=('MIT')
depends=('ruby')
source=("https://github.com/defunkt/${pkgname}/archive/v${pkgver}.tar.gz")
md5sums=('d7a5e77aba92c677fd89a4a8ec36d077')
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
install -Dm755 build/${pkgname} "${pkgdir}/usr/bin/${pkgname}"
install -Dm644 build/${pkgname}.1 "${pkgdir}/usr/share/man/man1/${pkgname}.1"
install -Dm644 LICENSE.MIT "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
......@@ -3,19 +3,19 @@
pkgbase=octopi
pkgname=('octopi' 'octopi-notifier' 'octopi-qt5' 'octopi-notifier-qt5')
pkgver=0.6.0
pkgver=0.7.0
pkgrel=1
url="https://octopiproject.wordpress.com/"
arch=('x86_64')
license=('GPL3')
depends=('pacman' 'pacmanlogviewer' 'mirror-check')
depends=('pacman' 'pacmanlogviewer' 'mirror-check' 'gist')
makedepends=('automoc4' 'qt' 'qt5-declarative')
conflicts=('oktopi')
replaces=('oktopi')
categories=('system')
screenshot=('http://octopiproject.files.wordpress.com/2014/01/octopi_in_kaos.png')
gitsha=94d4adf
gitsha=f17ee4f
source=("$pkgname"::"git://github.com/aarnt/${pkgname}.git#commit=${gitsha}")
md5sums=('SKIP')
......@@ -124,7 +124,7 @@ package_octopi-notifier() {
package_octopi-qt5() {
pkgdesc="Octopi, a powerful Pacman frontend using Qt libs - Qt5 version"
depends+=('qt5-declarative')
depends+=('qt5-declarative' 'knotifications')
provides+=('octopi')
conflicts+=('octopi')
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment