KDE Apps 14.12

parent 34df31b7
......@@ -3,7 +3,7 @@
pkgname=akonadi
pkgver=1.13.0
pkgrel=2
pkgrel=3
pkgdesc="PIM layer, which provides an asynchronous API to access all kinds of PIM data"
arch=('x86_64')
url='http://www.akonadi-project.org'
......
......@@ -86,7 +86,7 @@ sha256sums=('39e41a6acf246af4050d3e253b028f6abb739e19ec03d3c17ebf467b68be3962'
'530ecdbe32c8f33991cd6c2ccf29212f28bb4462d1844f5acba335b5984a9347'
'9e0c9408c9bc12aeca2fd66a4723b57a6878307ba956df7cca43f8112dd71429'
'0e419422afb09ccebd3f532cde784e97adfd5ad7816701c17966597f54915bfc'
'b406d31064f7ce7e82a5c428574ab47908ce227a5fbe61171be4ef3f297ebe58')
'0b8768ba00e821469067982ba8e37839ade1e979c0dc8ad68ae5172e67864cea')
package() {
# Install scripts for gpg/ssh-agent
......
This diff is collapsed.
# Contributor: Andrea Scarpino <andrea@archlinux.org>
# Contributions from Arch: https://projects.archlinux.org/svntogit/packages.git/tree/trunk/PKGBUILD?h=packages/extra-cmake-modules
source ../frameworks.conf
pkgname=extra-cmake-modules
pkgver=1.3.0
pkgver=1.7.0
pkgrel=1
pkgdesc='Extra CMake modules'
arch=('any')
arch=('x86_64')
url='https://projects.kde.org/projects/kdesupport/extra-cmake-modules'
license=('LGPL')
depends=('cmake')
makedepends=('python3-sphinx') # qt5-tools for QtHelp pages
source=("$KFServer/$KFVersion/${pkgname}-${pkgver}.tar.xz")
sha256sums=( $(getSum $pkgname) )
......@@ -21,7 +22,8 @@ build() {
cd build
cmake ../${pkgname}-${pkgver} \
-DCMAKE_INSTALL_PREFIX=$KFInstallPrefix \
-DCMAKE_BUILD_TYPE=$KFBuildType
-DCMAKE_BUILD_TYPE=$KFBuildType \
-DBUILD_HTML_DOCS=OFF
make
}
......
......@@ -8,7 +8,7 @@ pkgname=kde-base-artwork
pkgver=${_kdever}
pkgrel=1
pkgdesc="KDE KSplash theme"
arch=('any')
arch=('x86_64')
url='http://www.kde.org/'
license=('LGPL')
makedepends=('kdelibs' 'cmake' 'automoc4')
......
......@@ -68,7 +68,7 @@ pkgver=${_kdever}
pkgrel=1
url="http://www.kde.org"
license=('GPL' 'FDL')
depends=("kdelibs>=${_kdever}" 'automoc4' 'docbook-xsl')
depends=("kdelibs>=${_libsver}" 'automoc4' 'docbook-xsl')
options=('docs' 'log')
source=(${_mirror}/${pkgbase}/kde-l10n-ar-${pkgver}.tar.xz
${_mirror}/${pkgbase}/kde-l10n-bg-${pkgver}.tar.xz
......@@ -83,6 +83,7 @@ source=(${_mirror}/${pkgbase}/kde-l10n-ar-${pkgver}.tar.xz
${_mirror}/${pkgbase}/kde-l10n-es-${pkgver}.tar.xz
${_mirror}/${pkgbase}/kde-l10n-et-${pkgver}.tar.xz
${_mirror}/${pkgbase}/kde-l10n-eu-${pkgver}.tar.xz
${_mirror}/${pkgbase}/kde-l10n-fa-${pkgver}.tar.xz
${_mirror}/${pkgbase}/kde-l10n-fi-${pkgver}.tar.xz
${_mirror}/${pkgbase}/kde-l10n-fr-${pkgver}.tar.xz
${_mirror}/${pkgbase}/kde-l10n-ga-${pkgver}.tar.xz
......@@ -138,6 +139,7 @@ sha256sums=(
`grep "kde-l10n-es-${pkgver}.tar.xz" ../checksums.txt | cut -d " " -f1`
`grep "kde-l10n-et-${pkgver}.tar.xz" ../checksums.txt | cut -d " " -f1`
`grep "kde-l10n-eu-${pkgver}.tar.xz" ../checksums.txt | cut -d " " -f1`
`grep "kde-l10n-fa-${pkgver}.tar.xz" ../checksums.txt | cut -d " " -f1`
`grep "kde-l10n-fi-${pkgver}.tar.xz" ../checksums.txt | cut -d " " -f1`
`grep "kde-l10n-fr-${pkgver}.tar.xz" ../checksums.txt | cut -d " " -f1`
`grep "kde-l10n-ga-${pkgver}.tar.xz" ../checksums.txt | cut -d " " -f1`
......@@ -195,6 +197,7 @@ build() {
'es'
'et'
'eu'
'fa'
'fi'
'fr'
'ga'
......@@ -508,6 +511,17 @@ package_kde-l10n-eu()
popd
}
package_kde-l10n-fa()
{
pkgdesc="KDE language support: Persian"
groups=("kde-uninstall" "kde-l10n")
categories=('localization')
pushd ${srcdir}/kde-l10n-fi-${pkgver}
make DESTDIR=${pkgdir} install
popd
}
package_kde-l10n-fi()
{
pkgdesc="KDE language support: Finnish"
......
......@@ -7,7 +7,7 @@ source ../_buildscripts/${current_repo}-${_arch}-cfg.conf
pkgname='kde-runtime'
arch=('x86_64')
pkgver=${_kdever}
pkgrel=3
pkgrel=1
pkgdesc='Plugins and applications necessary for the running of KDE applications'
url='http://www.kde.org'
license=('GPL'
......@@ -17,8 +17,8 @@ options=('docs'
'!header'
'debug'
'log')
depends=("kdelibs>=${_kdever}"
"baloo>=${_kdever}"
depends=("kdelibs>=${_libsver}"
"baloo>=${_oldkdever}"
"kactivities"
'oxygen-icons'
'xorg-xauth'
......@@ -34,7 +34,7 @@ depends=("kdelibs>=${_kdever}"
makedepends=('pkgconfig'
'cmake'
'automoc4'
"kdepimlibs>=${_kdever}"
"kdepimlibs>=${_libsver}"
'openslp'
'docbook-xsl'
'networkmanager'
......@@ -56,12 +56,10 @@ install=kde-runtime.install
noextract=(branding.svgz)
source=("$_mirror/${pkgname}-$_kdever.tar.xz"
'branding.svgz'
'Remove-volume-control-from-KNotify.patch'
'kio_bookmarks_sanitize.patch')
'Remove-volume-control-from-KNotify.patch')
sha256sums=(`grep ${pkgname}-$_kdever.tar.xz ../checksums.txt | cut -d" " -f1`
'586c5461d66ef13d5c43fb269e16c4da51812ae25a0d1b132f0bbbcdb22505e5'
'87bb4bd5f20a95d10f03930477b7cc41c1a68b04e1ca57836b5836fe29c8e7bf'
'66e45c895a6f2eba609789d10bb918f33e34d17923abd1dbe05e838a0971d824')
'87bb4bd5f20a95d10f03930477b7cc41c1a68b04e1ca57836b5836fe29c8e7bf')
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
......@@ -72,8 +70,6 @@ prepare() {
msg "Applying patches..."
patch -p1 -i ${srcdir}/Remove-volume-control-from-KNotify.patch
# https://www.kde.org/info/security/advisory-20141113-1.txt
patch -p1 -i ${srcdir}/kio_bookmarks_sanitize.patch
}
build() {
......
......@@ -10,7 +10,7 @@ pkgname=("kde-workspace" "kde4-integration")
arch=('x86_64')
pkgver=${_workspace_ver}
#pkgver=4.11.11
pkgrel=4
pkgrel=1
url="http://www.kde.org"
license=('GPL' 'LGPL' 'FDL')
makedepends=('pkgconfig'
......@@ -18,7 +18,7 @@ makedepends=('pkgconfig'
'automoc4'
'networkmanager'
'bluez'
"kdebindings-python2>=${_kdever}"
"kdebindings-python2>=${_oldkdever}"
'oxygen-icons'
"kde-runtime>=${_kdever}"
'gpsd'
......@@ -29,8 +29,7 @@ makedepends=('pkgconfig'
'docbook-xsl'
'prison'
'qrencode'
"kdepimlibs>=${_kdever}"
"kde-runtime>=${_kdever}"
"kdepimlibs>=${_libsver}"
'qimageblitz'
'mesa'
"libkactivities4"
......@@ -50,7 +49,7 @@ makedepends=('pkgconfig'
'libqalculate'
'prison'
'qrencode'
"kdepim-runtime>=${_kdever}"
"kdepim-runtime>=${_libsver}"
"kde-base-artwork>=${_kdever}"
'xcb-util-keysyms'
'xcb-util-wm')
......@@ -149,7 +148,7 @@ package_kde-workspace() {
pkgdesc="KDE Workspace"
install=${pkgname}.install
depends=('polkit-kde-agent'
"kdepimlibs>=${_kdever}"
"kdepimlibs>=${_libsver}"
"kde-runtime>=${_kdever}"
'qimageblitz'
'mesa'
......@@ -171,7 +170,7 @@ package_kde-workspace() {
'libqalculate'
'prison'
'qrencode'
"kdepim-runtime>=${_kdever}"
"kdepim-runtime>=${_libsver}"
"kde-base-artwork>=${_kdever}"
'xcb-util-keysyms'
'xcb-util-wm'
......
......@@ -15,7 +15,7 @@ license=('GPL'
'LGPL'
'FDL')
depends=("kde-runtime>=${_kdever}"
"kdelibs>=${_kdever}"
"kdelibs>=${_libsver}"
'speech-dispatcher')
conflicts=("kdeaccessibility-doc")
replaces=("${pkgbase}-kttsd"
......@@ -34,7 +34,7 @@ makedepends=('pkgconfig'
'cmake'
'automoc4'
"kde-runtime>=${_kdever}"
"kdelibs>=${_kdever}"
"kdelibs>=${_libsver}"
"speech-dispatcher>=0.6.7"
'docbook-xsl')
categories=('accessibility')
......
......@@ -35,7 +35,7 @@ makedepends=('pkgconfig'
'cmake'
'automoc4'
"kde-runtime>=${_kdever}"
"kdelibs>=${_kdever}"
"kdelibs>=${_libsver}"
"speech-dispatcher>=0.6.7"
'docbook-xsl')
categories=('accessibility')
......
......@@ -6,8 +6,7 @@ source ../_buildscripts/${current_repo}-${_arch}-cfg.conf
pkgname=('kdeaccessibility-kmag')
_pkgname="kmag"
arch=('i686'
'x86_64')
arch=('x86_64')
pkgver=${_kdever}
pkgrel=1
pkgdesc="Screen magnifier"
......@@ -16,7 +15,7 @@ license=('GPL'
'LGPL'
'FDL')
depends=("kde-runtime>=${_kdever}"
"kdelibs>=${_kdever}")
"kdelibs>=${_libsver}")
conflicts=("kdeaccessibility-doc")
provides=('kmag')
install='kdeaccessibility.install'
......@@ -32,7 +31,7 @@ makedepends=('pkgconfig'
'cmake'
'automoc4'
"kde-runtime>=${_kdever}"
"kdelibs>=${_kdever}"
"kdelibs>=${_libsver}"
"speech-dispatcher>=0.6.7"
'docbook-xsl')
categories=('accessibility')
......
......@@ -15,7 +15,7 @@ license=('GPL'
'LGPL'
'FDL')
depends=("kde-runtime>=${_kdever}"
"kdelibs>=${_kdever}"
"kdelibs>=${_libsver}"
"libxtst")
makedepends=("automoc4")
conflicts=("kdeaccessibility-doc")
......
......@@ -15,7 +15,7 @@ license=('GPL'
'LGPL'
'FDL')
depends=("kde-runtime>=${_kdever}"
"kdelibs>=${_kdever}")
"kdelibs>=${_libsver}")
conflicts=("kdeaccessibility-doc")
provides=('kmouth')
install='kdeaccessibility.install'
......@@ -31,7 +31,7 @@ makedepends=('pkgconfig'
'cmake'
'automoc4'
"kde-runtime>=${_kdever}"
"kdelibs>=${_kdever}"
"kdelibs>=${_libsver}"
"speech-dispatcher>=0.6.7"
'docbook-xsl')
categories=('accessibility')
......
......@@ -18,7 +18,7 @@ license=('GPL'
depends=("kde-runtime>=${_kdever}"
'r'
'libspectre'
"kdeedu-analitza>=${_kdever}"
"kdeedu-analitza>=${_oldkdever}"
"python2")
makedepends=('cmake'
'automoc4'
......
......@@ -15,7 +15,7 @@ url='http://www.kde.org'
license=('GPL'
'LGPL'
'FDL')
depends=("kdelibs>=${_kdever}"
depends=("kdelibs>=${_libsver}"
"avogadro"
"ocaml"
"facile"
......
......@@ -12,7 +12,7 @@ pkgdesc="Libraries used by KDE Education applications"
arch=('x86_64')
url='http://www.kde.org'
license=('GPL' 'LGPL' 'FDL')
depends=("kdelibs>=${_kdever}")
depends=("kdelibs>=${_libsver}")
makedepends=('cmake'
'automoc4')
replaces=('kdeedu-common')
......
......@@ -16,7 +16,7 @@ license=('GPL'
'FDL')
depends=("kdegames-libkdegames>=${_kdever}"
"kdegames-libkmahjongg>=${_kdever}"
"kdebindings-python2>=${_kdever}"
"kdebindings-python2>=${_oldkdever}"
"python2-twisted")
makedepends=('pkg-config'
'cmake'
......
......@@ -28,7 +28,7 @@ options=('docs'
'debug'
'log')
source=("$_mirror/${_pkgname}-$_kdever.tar.xz")
sha256sums=(`grep " ${_pkgname}-$_kdever.tar.xz" ../checksums.txt | cut -d " " -f1`)
sha256sums=(`grep " ${_pkgname}-${_kdever}.tar.xz" ../checksums.txt | cut -d " " -f1`)
build() {
cd ${srcdir}/${_pkgname}-${pkgver}
......
......@@ -14,7 +14,7 @@ url='http://www.kde.org'
license=('GPL'
'LGPL'
'FDL')
depends=("kdelibs>=${_kdever}")
depends=("kdelibs>=${_libsver}")
makedepends=('pkg-config'
'cmake'
'automoc4')
......
......@@ -14,7 +14,7 @@ url='http://www.kde.org'
license=('GPL'
'LGPL'
'FDL')
depends=("kdelibs>=${_kdever}"
depends=("kdelibs>=${_libsver}"
"kdegames-libkdegames>=${_kdever}")
makedepends=('pkg-config'
'cmake'
......
......@@ -14,7 +14,7 @@ url='https://projects.kde.org/projects/kde/kdegraphics/ksaneplugin'
license=('GPL'
'LGPL'
'FDL')
depends=("kdegraphics-libksane>=${_kdever}")
depends=("kdegraphics-libksane>=${_libsver}")
makedepends=('cmake'
'automoc4')
groups=('kde'
......
......@@ -14,7 +14,7 @@ arch=('x86_64')
license=('GPL'
'LGPL'
'FDL')
depends=("kdelibs>=${_kdever}"
depends=("kdelibs>=${_libsver}"
"kdegraphics-libkipi>=${_kdever}")
makedepends=('cmake'
'automoc4')
......
......@@ -15,7 +15,7 @@ url="https://projects.kde.org/projects/kde/kdegraphics/libs/libkdcraw"
license=('GPL'
'LGPL'
'FDL')
depends=("kdelibs>=${_kdever}"
depends=("kdelibs>=${_libsver}"
'lcms'
'libjpeg'
'libraw')
......
......@@ -15,7 +15,7 @@ url='https://projects.kde.org/projects/kde/kdegraphics/libs/libkexiv2'
license=('GPL'
'LGPL'
'FDL')
depends=("kdelibs>=${_kdever}"
depends=("kdelibs>=${_libsver}"
'lcms'
'libjpeg'
'exiv2>=0.24')
......
......@@ -7,14 +7,14 @@ source ../_buildscripts/${current_repo}-${_arch}-cfg.conf
pkgname=kdegraphics-libkipi
_pkgname=libkipi
pkgver=${_kdever}
pkgrel=2
pkgrel=1
pkgdesc='An interface to use kipi-plugins from a KDE application'
arch=('x86_64')
url='https://projects.kde.org/projects/kde/kdegraphics/libs/libkipi'
license=('GPL'
'LGPL'
'FDL')
depends=("kdelibs>=${_kdever}")
depends=("kdelibs>=${_libsver}")
makedepends=('cmake'
'automoc4'
'pkg-config')
......
......@@ -14,7 +14,7 @@ url='https://projects.kde.org/projects/kde/kdegraphics/libs/libksane'
license=('GPL'
'LGPL'
'FDL')
depends=("kdelibs>=${_kdever}"
depends=("kdelibs>=${_libsver}"
'sane')
makedepends=('cmake'
'automoc4')
......
......@@ -27,7 +27,7 @@ categories=('office')
# note on libxxf86vm:
# not detected by namcap because libgl depends on it
# but nvidia providing libgl does not depend on libxxf86vm
depends=("kdelibs>=${_kdever}"
depends=("kdelibs>=${_libsver}"
"kde-runtime>=${_kdever}"
'libxxf86vm'
'sane'
......
......@@ -13,7 +13,7 @@ url='https://projects.kde.org/projects/kde/kdegraphics/kdegraphics-strigi-analyz
license=('GPL'
'LGPL'
'FDL')
depends=("kdelibs>=${_kdever}"
depends=("kdelibs>=${_libsver}"
'strigi')
makedepends=('pkg-config'
'cmake'
......
......@@ -14,7 +14,7 @@ url='https://projects.kde.org/projects/kde/kdegraphics/svgpart'
license=('GPL'
'LGPL'
'FDL')
depends=("kdelibs>=${_kdever}")
depends=("kdelibs>=${_libsver}")
makedepends=('pkg-config'
'cmake'
'automoc4')
......
......@@ -6,7 +6,7 @@ source ../_buildscripts/${current_repo}-${_arch}-cfg.conf
pkgname="kdelibs"
arch=('x86_64')
pkgver=${_kdever}
pkgver=${_libsver}
pkgrel=1
pkgdesc="KDE Core Libraries"
url="http://www.kde.org"
......@@ -70,7 +70,7 @@ optdepends=('phonon-gstreamer: GStreamer Phonon backend (default)'
'avahi: Service discovery on your local network'
'aspell: Spell checking'
'hspell: Hebrew spell checking')
provides=("${pkgname}=${_kdever}"
provides=("${pkgname}=${_libsver}"
"kdelibs-doc")
replaces=('kdelibs-experimental'
'arts'
......@@ -80,12 +80,12 @@ groups=("kde"
"kde-uninstall")
conflicts=("kdelibs-doc")
install=${pkgname}.install
source=($_mirror/${pkgname}-$_kdever.tar.xz
source=($_mirror/${pkgname}-$_libsver.tar.xz
01_chakra_tag.patch
02_kde_applications_menu.patch
03_chakra_menu.patch
MergeDir.patch)
sha256sums=(`grep $pkgname-$_kdever.tar.xz ../checksums.txt | cut -d " " -f1`
sha256sums=(`grep $pkgname-$_libsver.tar.xz ../checksums.txt | cut -d " " -f1`
'029e2d07c5fc8676d143b903aa181fc470e5b469d49ccf107e19031f562bf4e3'
'b2d25c76081ea6bb31d90c4c6b619ce64ac36de3a6eefb2f9990d3dbf8cd9c91'
'505e9e5e969be5094b3f713b865d5927cc3de1f4693915174732b20793228c4f'
......
......@@ -9,7 +9,7 @@ arch=('x86_64')
pkgver=${_kdever}
pkgrel=1
pkgdesc='Konqueror plugin to share a directory with the local network'
depends=("kdelibs>=${_kdever}"
depends=("kdelibs>=${_libsver}"
'smbclient')
conflicts=("kdenetwork-common"
"kdenetwork-doc")
......
......@@ -12,7 +12,7 @@ pkgrel=2
pkgdesc="Kopete, the instant messenger"
url="http://kde.org/applications/internet/kopete/"
depends=("kde-runtime>=${_kdever}"
"kdepimlibs>=${_kdever}"
"kdepimlibs>=${_libsver}"
'qca-ossl'
'libotr>=4.0.0'
'libmsn'
......
......@@ -12,7 +12,7 @@ pkgdesc="Desktop Sharing Server"
# note on libxdamage:
# not detected by namcap because libgl depends on it
# but nvidia providing libgl does not depend on libxdamage
depends=("kde-runtime>=${_kdever}" "kdelibs>=${_kdever}" 'libvncserver' 'libxdamage')
depends=("kde-runtime>=${_kdever}" "kdelibs>=${_libsver}" 'libvncserver' 'libxdamage')
groups=("kde" "kdenetwork" "kde-uninstall")
categories=('network')
conflicts=("kdenetwork-common" "kdenetwork-doc")
......
......@@ -7,7 +7,7 @@ source ../_buildscripts/${current_repo}-${_arch}-cfg.conf
pkgbase=kdepim-runtime
pkgname=${pkgbase}
arch=('x86_64')
pkgver=${_kdever}
pkgver=${_libsver}
pkgrel=1
pkgdesc='Extends the functionality of KDE PIM'
url='https://projects.kde.org/projects/kde/kdepim-runtime'
......@@ -19,9 +19,9 @@ options=('docs'
'!header'
'debug'
'log')
depends=("kdepimlibs>=${_kdever}"
depends=("kdepimlibs>=${_libsever}"
"kde-runtime>=${_kdever}"
"kdelibs>=${_kdever}"
"kdelibs>=${_libsver}"
'prison'
'libdmtx'
'qrencode'
......@@ -35,8 +35,8 @@ groups=('kde'
'kdepim'
'kde-uninstall'
'kde-minimal')
source=($_mirror/${pkgbase}-$_kdever.tar.xz)
sha256sums=(`grep ${pkgbase}-$_kdever.tar.xz ../checksums.txt | cut -d" " -f1`)
source=($_mirror/${pkgbase}-$_libsver.tar.xz)
sha256sums=(`grep ${pkgbase}-$_libsver.tar.xz ../checksums.txt | cut -d" " -f1`)
prepare() {
cd "${srcdir}"
......
......@@ -21,8 +21,8 @@ pkgname=('kdepim-common'
'kdepim-kontact'
'kdepim-korganizer'
'kdepim-ktimetracker')
pkgver=${_kdever}
pkgrel=2
pkgver=${_libsver}
pkgrel=1
arch=('x86_64')
url="http://pim.kde.org"
license=('GPL'
......@@ -36,10 +36,10 @@ makedepends=('pkg-config'
'cmake'
'automoc4'
'boost'
"kdelibs>=${_kdever}"
"kdepimlibs>=${_kdever}"
"kdelibs>=${_libsver}"
"kdepimlibs>=${_libsver}"
'grantlee>=0.3.0'
"kdepim-runtime>=${_kdever}"
"kdepim-runtime>=${_libsver}"
'libxss'
"kde-runtime>=${_kdever}"
'libsamplerate'
......@@ -48,10 +48,10 @@ makedepends=('pkg-config'
"chakra-common>=${_kdever}"
'docbook-xml'
'dblatex'
"baloo-widgets>=${_kdever}"
"baloo-widgets>=${_oldkdever}"
'link-grammar')
source=($_mirror/${pkgbase}-${pkgver}.tar.xz)
sha256sums=(`grep ${pkgbase}-$_kdever.tar.xz ../checksums.txt | cut -d" " -f1`)
sha256sums=(`grep ${pkgbase}-$_libsver.tar.xz ../checksums.txt | cut -d" " -f1`)
prepare() {
mkdir "${srcdir}/build"
......@@ -75,7 +75,7 @@ package_kdepim-akonadiconsole() {
"${pkgbase}"
"kde-uninstall")
depends=("${pkgbase}-common>=${pkgver}"
"baloo-widgets>=${_kdever}")
"baloo-widgets>=${_oldkdever}")
install=${pkgbase}.install
cd "${srcdir}"/build/akonadiconsole
......@@ -296,8 +296,8 @@ package_kdepim-ktnef() {
"${pkgbase}"
"kde-uninstall")
categories=('accessories')
depends=("kdebase-runtime>=${pkgver}"
"kdepimlibs>=${pkgver}")
depends=("kdebase-runtime>=${_oldkdever}"
"kdepimlibs>=${libsver}")
install=${pkgbase}.install
cd "${srcdir}"/build/ktnef
......@@ -306,7 +306,7 @@ package_kdepim-ktnef() {
package_kdepim-common() {
pkgdesc="KDE PIM common files and libraries"
depends=("kdepimlibs>=${_kdever}"
depends=("kdepimlibs>=${_libsver}"
"kde-runtime>=${_kdever}"
"chakra-common>=${_kdever}"
"kdepim-runtime>=${_pkgver}"
......
......@@ -6,7 +6,7 @@ source ../_buildscripts/${current_repo}-${_arch}-cfg.conf
pkgname="kdepimlibs"
arch=('x86_64')
pkgver=${_kdever}
pkgver=${_libsver}
pkgrel=1
pkgdesc="KDE PIM libraries"
url="http://www.kde.org"
......@@ -18,7 +18,7 @@ options=('docs'
'!header'
'debug'
'log')
depends=("kdelibs>=${_kdever}"
depends=("kdelibs>=${_lbsver}"
'akonadi>=1.12.90'
'libical'
'gpgme'
......@@ -37,8 +37,8 @@ makedepends=('pkg-config'
groups=('kde'
'kde-uninstall'
'kde-minimal')
source=($_mirror/${pkgname}-$_kdever.tar.xz)
sha256sums=(`grep ${pkgname}-$_kdever.tar.xz ../checksums.txt | cut -d" " -f1`)
source=($_mirror/${pkgname}-$_libsver.tar.xz)
sha256sums=(`grep ${pkgname}-$_libsver.tar.xz ../checksums.txt | cut -d" " -f1`)
build() {
cd ${srcdir}
......
......@@ -11,7 +11,7 @@ pkgver=${_kdever}
pkgrel=1
pkgdesc="Computer aided translation system"
screenshot="http://www.kde.org/images/screenshots/lokalize.png"
depends=("kde-runtime>=${_kdever}" "kdebindings-pykde4>=${_kdever}" "kdesdk-strigi-analyzers>=${_kdever}" "hunspell")
depends=("kde-runtime>=${_kdever}" "kdebindings-pykde4>=${_oldkdever}" "kdesdk-strigi-analyzers>=${_kdever}" "hunspell")
makedepends=("automoc4")
optdepends=('translate-toolkit: enable extra python script')
conflicts=('kdesdk-doc')
......
......@@ -9,7 +9,7 @@ arch=('x86_64')
pkgver=${_kdever}
pkgrel=1
pkgdesc='Strigi analyzers for the KDE SDK'
depends=("kdelibs>=${_kdever}")
depends=("kdelibs>=${_libsver}")
provides=('kdesdk-strigi-analyzer')
replaces=('kdesdk-strigi-analyzer')
conflicts=('kdesdk-common' 'kdesdk-strigi-analyzer')
......
......@@ -37,7 +37,7 @@ install=kdeutils.install
makedepends=('pkg-config'
'cmake'
'automoc4'
"kdelibs>=${_kdever}"
"kdelibs>=${_libsver}"
"kde-baseapps>=${_kdever}"
"kde-workspace>=${_workspace_ver}"
'libarchive'
......
......@@ -33,7 +33,7 @@ install=kdeutils.install
makedepends=('pkg-config'
'cmake'
'automoc4'
"kdelibs>=${_kdever}")
"kdelibs>=${_libsver}")
source=($_mirror/${_pkgname}-$_kdever.tar.xz)
sha256sums=(`grep ${_pkgname}-$_kdever.tar.xz ../checksums.txt | cut -d " " -f1`)
......
......@@ -23,7 +23,7 @@ depends=("kde-runtime>=${_kdever}"
makedepends=('pkg-config'
'cmake'
'automoc4'
"kdelibs>=${_kdever}")
"kdelibs>=${_libsver}")
conflicts=("kdeutils-doc"
"kdeutils-common")
provides=("kcalc")
......
......@@ -31,7 +31,7 @@ install=kdeutils.install
makedepends=('pkg-config'
'cmake'
'automoc4'
"kdelibs>=${_kdever}")
"kdelibs>=${_libsver}")
source=($_mirror/${_pkgname}-$_kdever.tar.xz)
sha256sums=(`grep ${_pkgname}-$_kdever.tar.xz ../checksums.txt | cut -d " " -f1`)
......
......@@ -30,7 +30,7 @@ install=kdeutils.install
makedepends=('pkg-config'
'cmake'
'automoc4'
"kdelibs>=${_kdever}")
"kdelibs>=${_libsver}")
source=($_mirror/${_pkgname}-$_kdever.tar.xz)
sha256sums=(`grep ${_pkgname}-$_kdever.tar.xz ../checksums.txt | cut -d " " -f1`)
......
......@@ -29,7 +29,7 @@ groups=("kde"
makedepends=('pkg-config'
'cmake'
'automoc4'
"kdelibs>=${_kdever}")
"kdelibs>=${_libsver}")
categories=('utils')
source=($_mirror/${_pkgname}-$_kdever.tar.xz)
sha256sums=(`grep ${_pkgname}-$_kdever.tar.xz ../checksums.txt | cut -d " " -f1`)
......