Commit d9300ba6 authored by Luca Giambonini's avatar Luca Giambonini

python3 rebuild / updates

parent 6a7e5f5e
pkgbase=python-itsdangerous
pkgname=('python3-itsdangerous' 'python2-itsdangerous')
pkgver=0.24
pkgrel=1
pkgrel=2
pkgdesc='Various helpers to pass trusted data to untrusted environments'
arch=('any')
url="http://pypi.python.org/pypi/itsdangerous"
......
pkgbase=python-keyring
pkgname=('python3-keyring' 'python2-keyring')
pkgver=10.2
pkgver=10.4.0
pkgrel=1
pkgdesc="Store and access your passwords safely."
arch=('any')
......@@ -9,7 +9,7 @@ license=('PSF' 'MIT')
makedepends=('python3-setuptools' 'python2-setuptools' 'python3' 'python2')
optdepends=('kdeutils-kwallet: supports the KDE Kwallet service.')
source=("https://pypi.io/packages/source/k/keyring/keyring-$pkgver.tar.gz")
sha1sums=('24de60ada6d4ba286877bffad87619a1e51f5763')
sha1sums=('485136b7b239c69b75c26524de20cbce5a61e759')
prepare() {
cp -a keyring-$pkgver{,-py2}
......
......@@ -2,7 +2,7 @@
pkgbase=python-magic
pkgname=(python2-magic python3-magic)
pkgver=5.25
pkgver=5.29
pkgrel=1
pkgdesc="Python bindings to the magic library"
arch=('x86_64')
......
pkgbase=python-matplotlib
pkgname=('python2-matplotlib' 'python3-matplotlib')
pkgver=1.5.1
pkgver=2.1.0
pkgrel=1
pkgdesc="A python plotting library, making publication quality plots"
arch=('x86_64')
......@@ -10,12 +10,12 @@ makedepends=('python2-pytz' 'python2-numpy' 'python2-pyqt4' 'python3-pytz' 'pyth
'python3-pyqt4' 'tk' 'python3-cairo' 'python2-cairo' 'python3-dateutil'
'python2-dateutil' 'python3-gobject' 'python2-gobject' 'python3-pyparsing'
'python2-pyparsing' 'python3-six' 'ghostscript' 'texlive-bin'
'python3-tornado' 'python2-tornado' 'python3-pyqt5' 'python2-pyqt5'
'python3-pyqt5' 'python2-pyqt5'
'libxkbcommon-x11' 'python3-pillow' 'python2-pillow' 'python3-setuptools'
'python2-setuptools' 'python3-cycler' 'python2-cycler')
source=("$pkgbase-$pkgver.tar.gz::https://github.com/matplotlib/matplotlib/archive/v$pkgver.tar.gz"
setup.cfg)
sha512sums=('da99fffcb4fb600ed4386ce89e61725768d4209f3bd4ab174e0d8474c24b2736516a4299ceaa0714b276d7d02c3e33e39a6204e014569ec3f6249085b1ba7a0d'
sha512sums=('19fa97eeb483218f92d72900654984387e90b9f9cc8fd62209443a6eaeb1415e68d7d9c20c5ae0028f99836db58f12aff3af56e756a4673f5130e3f5a724ca87'
'0f594854acc9dfda700b4c9bf9a5fa284897b5f612f8dd1da274e682b4bb59392034e058ed661a4f973e43577199c7412cee07774faee19d87e57fd6161574f4')
prepare() {
......
......@@ -2,16 +2,16 @@
pkgbase=python-mock
pkgname=(python2-mock python3-mock)
pkgver=1.3.0
pkgrel=2
pkgver=2.0.0
pkgrel=1
pkgdesc='Mocking and Patching Library for Testing'
url='http://www.voidspace.org.uk/python/mock/'
makedepends=('python3-setuptools' 'python2-setuptools')
checkdepends=('python3-nose' 'python2-nose' 'python3-pbr' 'python3-six' 'git')
checkdepends=('python3-nose' 'python2-nose' 'python3-pbr' 'python2-pbr' 'python3-six' 'python2-six' 'git')
license=('BSD')
arch=('any')
source=("http://pypi.python.org/packages/source/m/mock/mock-$pkgver.tar.gz")
md5sums=('73ee8a4afb3ff4da1b4afa287f39fdeb')
source=("https://pypi.python.org/packages/0c/53/014354fc93c591ccc4abff12c473ad565a2eb24dcd82490fae33dbf2539f/mock-2.0.0.tar.gz")
md5sums=('0febfafd14330c9dcaa40de2d82d40ad')
build() {
cd "$srcdir"
......
pkgbase=python-mpmath
pkgname=('python2-mpmath' 'python3-mpmath')
pkgver=0.19
pkgrel=2
pkgver=1.0.0
pkgrel=1
pkgdesc='Python library for arbitrary-precision floating-point arithmetic.'
arch=('any')
url='http://mpmath.org/'
license=('BSD')
makedepends=('python3-setuptools' 'python2-setuptools')
source=("http://mpmath.org/files/mpmath-${pkgver}.tar.gz")
sha1sums=('65da0ed4ed01d067f0f5b890ca28ad2f2fb56343')
sha1sums=('667569ac2d71708613f66c6a094b0cb74e82b430')
prepare(){
cp -R mpmath-$pkgver mpmath2-$pkgver
......@@ -26,7 +26,8 @@ package_python2-mpmath() {
depends=('python2-gmpy2')
cd mpmath2-${pkgver}
find -name '*.py' | xargs sed -e 's|#!/usr/bin/python|#!/usr/bin/python2|' -i
find -name '*.py' | xargs sed -e 's|#!/usr/bin/python|#!/usr/bin/python2|' \
-e 's|#!/usr/bin/env python|#!/usr/bin/env python2|' -i
python2 setup.py install --root "$pkgdir" --optimize=1
......
......@@ -5,7 +5,7 @@
pkgbase=python-msgpack
pkgname=('python3-msgpack' 'python2-msgpack')
pkgver=0.4.8
pkgrel=1
pkgrel=2
url='https://github.com/msgpack/msgpack-python'
arch=('x86_64')
license=('Apache')
......
pkgbase=python-pandas
pkgname=('python2-pandas' 'python3-pandas')
pkgver=0.17.1
pkgrel=2
pkgver=0.20.3
pkgrel=1
pkgdesc="Cross-section and time series data analysis toolkit"
arch=('x86_64')
url="http://pandas.pydata.org/"
license=('BSD')
makedepends=('python3-setuptools' 'python3-dateutil' 'python3-numpy' 'python3-pytz'
'python2-setuptools' 'python2-dateutil' 'python2-numpy' 'python2-pytz')
source=("https://pypi.python.org/packages/source/p/pandas/pandas-${pkgver}.tar.gz")
sha1sums=('2e515ad85d872b8aabda3da7586f002b7826d425')
'python2-setuptools' 'python2-dateutil' 'python2-numpy' 'python2-pytz'
'cython3' 'cython2')
source=("https://github.com/pydata/pandas/archive/v${pkgver}.tar.gz")
sha1sums=('af0b1cc4e3479bca71359be5760b9d2c416298f9')
prepare() {
cd "$srcdir"
......
pkgbase=python-pbr
pkgname=(python3-pbr python2-pbr)
pkgver=1.8.1
pkgver=3.1.1
pkgrel=1
pkgdesc="Python Build Reasonableness"
arch=('any')
url=https://pypi.python.org/pypi/pbr
license=(Apache)
makedepends=(python2-setuptools python3-setuptools git)
source=(http://pypi.python.org/packages/source/p/${pkgname#*-}/${pkgname#*-}-$pkgver.tar.gz)
sha256sums=('e2127626a91e6c885db89668976db31020f0af2da728924b56480fc7ccf09649')
source=("$pkgbase-$pkgver.tar.gz::https://github.com/openstack-dev/pbr/archive/$pkgver.tar.gz")
sha256sums=('cf742ca9b8e28fff579cc2d6d7be740a43679b2fba5603627ea7881c5d663ad5')
prepare() {
cp -a ${pkgname#*-}-$pkgver python2-pbr-$pkgver
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment