Commit 3abb3760 authored by Chaoting Liu's avatar Chaoting Liu

gimp: update to 2.10.4, close FS#8, remove deprecated commands in

.install [skip-ci]
parent 12cc3068
Pipeline #892 skipped
pkgname=gimp
pkgver=2.8.22
_pkgver=2.8
pkgrel=3
pkgver=2.10.4
_pkgver=2.10
pkgrel=1
pkgdesc="GNU Image Manipulation Program (Development Version)"
arch=('x86_64')
url="http://www.gimp.org/"
license=('GPL3' 'LGPL3')
depends=('libpng' 'pygtk' 'lcms' 'libxpm' 'libwmf' 'librsvg' 'libmng' 'dbus-glib' \
'jasper' 'libexif' 'gegl=0.2.0' 'desktop-file-utils' 'hicolor-icon-theme' 'babl')
makedepends=('intltool' 'libwebkit-gtk2' 'poppler-glib' 'alsa-lib' 'iso-codes' 'curl' 'ghostscript')
depends=('babl' 'dbus-glib' 'desktop-file-utils' 'gegl' 'glib-networking' 'hicolor-icon-theme'
'jasper' 'lcms' 'libheif' 'libexif' 'libgudev' 'libmng' 'libmypaint' 'librsvg' 'libwebp'
'libwmf' 'libxmu' 'libxpm' 'mypaint-brushes' 'openexr' 'poppler-data' 'pygtk')
makedepends=('alsa-lib' 'curl' 'ghostscript' 'gtk-doc' 'intltool' 'iso-codes' 'poppler-glib')
optdepends=('gutenprint: for sophisticated printing only as gimp has built-in cups print support'
'poppler-glib: for pdf support'
'alsa-lib: for MIDI event controller module'
'curl: for URI support'
'ghostscript: for postscript support')
options=('!makeflags')
install=gimp.install
source=("http://download.gimp.org/pub/gimp/v${_pkgver}/gimp-${pkgver}.tar.bz2" "linux.gpl")
md5sums=('7e4fd7a53b1d3c32dff642ab1a94b44d'
source=("http://download.gimp.org/pub/gimp/v${_pkgver}/$pkgname-$pkgver.tar.bz2" "linux.gpl")
md5sums=('9e0a3703a920da8b3e51e845fa3bff7d'
'bb27bc214261d36484093e857f015f38')
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
cd $pkgname-$pkgver
_mypaintver=$(echo /usr/lib/libmypaint-*.so | grep -o -E '\-[0-9]+(\.[0-9]+)*' | head -1)
sed -i "s|\\(libmypaint\\)\\( >= libmypaint_required_version\\)|\\1${_mypaintver}\\2|g" configure.ac
autoreconf -vi
}
build() {
cd "${srcdir}/gimp-${pkgver}"
PYTHON=/usr/bin/python2 ./configure --prefix=/usr --sysconfdir=/etc \
cd $pkgname-$pkgver
PYTHON=/usr/bin/python2 ./configure \
--prefix=/usr --sysconfdir=/etc --libexec=/usr/bin \
--enable-mp \
--enable-gimp-console \
--enable-python \
--with-libcurl \
--with-gif-compression=lzw \
--with-gimpdir=.config/gimp \
--with-bug-report-url='https://code.chakralinux.org/packages/gtk/issues/?search=gimp' \
--without-aa \
--without-hal \
--without-gvfs \
......@@ -41,13 +45,13 @@ build() {
}
package() {
cd "${srcdir}/gimp-${pkgver}"
make DESTDIR="${pkgdir}" install
sed -i 's|#![ ]*/usr/bin/env python|#!/usr/bin/env python2|' "${pkgdir}"/usr/lib/gimp/2.0/plug-ins/*.py
install -D -m644 "${srcdir}/linux.gpl" "${pkgdir}/usr/share/gimp/2.0/palettes/Linux.gpl"
cd $pkgname-$pkgver
make DESTDIR=$pkgdir install
sed -i 's|#![ ]*/usr/bin/env python|#!/usr/bin/env python2|' $pkgdir/usr/lib/gimp/2.0/plug-ins/*.py
install -D -m644 ../linux.gpl $pkgdir/usr/share/gimp/2.0/palettes/Linux.gpl
ln -sf gimp-console-${pkgver}.1.gz "${pkgdir}/usr/share/man/man1/gimp-console.1.gz"
ln -sf gimprc-${pkgver}.5.gz "${pkgdir}/usr/share/man/man5/gimprc.5.gz"
ln -sf gimptool-2.0.1.gz "${pkgdir}/usr/share/man/man1/gimptool.1.gz"
ln -s gimp-${pkgver}.1.gz "${pkgdir}/usr/share/man/man1/gimp.1.gz"
ln -sf gimp-console-$pkgver.1.gz $pkgdir/usr/share/man/man1/gimp-console.1.gz
ln -sf gimprc-$pkgver.5.gz $pkgdir/usr/share/man/man5/gimprc.5.gz
ln -sf gimptool-2.0.1.gz $pkgdir/usr/share/man/man1/gimptool.1.gz
ln -s gimp-$pkgver.1.gz $pkgdir/usr/share/man/man1/gimp.1.gz
}
pkgname=gimp
pkgver=2.10.4
_pkgver=2.10
pkgrel=1
pkgdesc="GNU Image Manipulation Program (Development Version)"
arch=('x86_64')
url="http://www.gimp.org/"
license=('GPL3' 'LGPL3')
depends=('babl' 'dbus-glib' 'desktop-file-utils' 'gegl' 'glib-networking' 'hicolor-icon-theme'
'jasper' 'lcms' 'libheif' 'libexif' 'libgudev' 'libmng' 'libmypaint' 'librsvg' 'libwebp'
'libwmf' 'libxmu' 'libxpm' 'mypaint-brushes' 'openexr' 'poppler-data' 'pygtk' 'libgexiv2')
makedepends=('alsa-lib' 'curl' 'ghostscript' 'gtk-doc' 'intltool' 'iso-codes' 'poppler-glib' 'poppler-data')
optdepends=('gutenprint: for sophisticated printing only as gimp has built-in cups print support'
'poppler-glib: for pdf support'
'alsa-lib: for MIDI event controller module'
'curl: for URI support'
'ghostscript: for postscript support')
source=("http://download.gimp.org/pub/gimp/v${_pkgver}/$pkgname-$pkgver.tar.bz2" "linux.gpl")
md5sums=('9e0a3703a920da8b3e51e845fa3bff7d'
'bb27bc214261d36484093e857f015f38')
prepare() {
cd $pkgname-$pkgver
_mypaintver=$(echo /usr/lib/libmypaint-*.so | grep -o -E '\-[0-9]+(\.[0-9]+)*' | head -1)
sed -i "s|\\(libmypaint\\)\\( >= libmypaint_required_version\\)|\\1${_mypaintver}\\2|g" configure.ac
autoreconf -vi
}
build() {
cd $pkgname-$pkgver
PYTHON=/usr/bin/python2 ./configure --prefix=/usr --sysconfdir=/etc \
--enable-mp \
--enable-gimp-console \
--enable-python \
--with-libcurl \
--with-gif-compression=lzw \
--with-gimpdir=.config/gimp \
--without-aa \
--without-hal \
--without-gvfs \
--without-gnomevfs
make
}
package() {
cd $pkgname-$pkgver
make DESTDIR=$pkgdir install
sed -i 's|#![ ]*/usr/bin/env python|#!/usr/bin/env python2|' $pkgdir/usr/lib/gimp/2.0/plug-ins/*.py
install -D -m644 ../linux.gpl $pkgdir/usr/share/gimp/2.0/palettes/Linux.gpl
ln -sf gimp-console-$pkgver.1.gz $pkgdir/usr/share/man/man1/gimp-console.1.gz
ln -sf gimprc-$pkgver.5.gz $pkgdir/usr/share/man/man5/gimprc.5.gz
ln -sf gimptool-2.0.1.gz $pkgdir/usr/share/man/man1/gimptool.1.gz
ln -s gimp-$pkgver.1.gz $pkgdir/usr/share/man/man1/gimp.1.gz
}
post_install() {
update-desktop-database -q
gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
/sbin/ldconfig -r .
}
post_upgrade() {
post_install
/sbin/ldconfig -r .
echo 'we now set local configuration in ~/.config/gimp,'
echo 'please consider manually moving it from ~/.gimp-2.8 before you start it.'
}
post_remove() {
post_install
/sbin/ldconfig -r .
}
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment