Commit 5eadc192 authored by Luca Giambonini's avatar Luca Giambonini

moved [extra] pkgs from /extra to /usr as discussed here: https://www.loomio.org/discussions/7563

parent 90f5cddc
......@@ -2,12 +2,12 @@ md5sums=('68099241871f4e47eee06bebc7ce20a1'
'9c1c06c1f7eaffd5dd383b7e0348b6db')
pkgname=amule
pkgver=10808
pkgrel=2
pkgrel=3
pkgdesc="An eMule-like client for ed2k p2p network"
arch=('x86_64')
url="http://www.amule.org"
license=('GPL')
depends=('wxgtk' 'gd' 'geoip' 'libupnp' 'crypto++' 'filesystem-extra')
depends=('wxgtk' 'gd' 'geoip' 'libupnp' 'crypto++')
makedepends=('ccache')
source=("http://amule.sourceforge.net/tarballs/aMule-SVN-r${pkgver}.tar.bz2"
"http://chakra.sourceforge.net/sources/oxygen-themes/aMule_Oxygen_Skin.zip")
......@@ -17,8 +17,8 @@ md5sums=('68099241871f4e47eee06bebc7ce20a1'
build() {
cd "${srcdir}/aMule-SVN-r${pkgver}"
./configure --prefix=/extra/usr \
--mandir=/extra/usr/share/man \
./configure --prefix=/usr \
--mandir=/usr/share/man \
--enable-cas \
--enable-wxcas \
--enable-amule-daemon \
......@@ -42,5 +42,5 @@ package() {
make DESTDIR=${pkgdir}/ install
cp -f $srcdir/aMule_Oxygen_Skin.zip $pkgdir/extra/usr/share/amule/skins/
cp -f $srcdir/aMule_Oxygen_Skin.zip $pkgdir/usr/share/amule/skins/
}
......@@ -2,7 +2,7 @@ pkgname=ardour
_pkgname=Ardour3
pkgver=3.5.14
_pkgver=3.5
pkgrel=1
pkgrel=2
pkgdesc="Professional-grade digital audio workstation"
arch=('x86_64')
url="http://ardour.org/"
......@@ -26,8 +26,8 @@ prepare() {
build() {
cd "$srcdir/$_pkgname-$_pkgver"
python2 waf configure --prefix=/extra/usr \
--configdir=/extra/etc \
python2 waf configure --prefix=/usr \
--configdir=/etc \
--docs
python2 waf build $MAKEFLAGS
......@@ -40,5 +40,5 @@ package() {
# install some freedesktop.org compatibility
install -Dm644 "$srcdir/$pkgname.desktop" \
"$pkgdir/extra/usr/share/applications/$pkgname.desktop"
"$pkgdir/usr/share/applications/$pkgname.desktop"
}
pkgname=audacity
pkgver=2.0.5
pkgrel=1
pkgrel=2
pkgdesc="A program that lets you manipulate digital audio waveforms"
arch=('x86_64')
url="http://audacity.sourceforge.net/"
license=('GPL')
depends=('libvorbis' 'libmad' 'libid3tag' 'wxgtk' 'libsamplerate' 'lame'
'hicolor-icon-theme' 'shared-mime-info' 'desktop-file-utils' 'redland'
'jack' 'soundtouch' 'filesystem-extra')
'jack' 'soundtouch')
makedepends=('zip' 'python' 'pkgconfig')
options=('!makeflags')
install="${pkgname}.install"
......@@ -16,7 +16,7 @@ sha256sums=('e287541dd017f523fd9a06d5140b8f72fe9a0450709de7c398baffa106db2b79')
build() {
cd ${pkgname}-src-${pkgver}
WX_CONFIG=/extra/usr/bin/wx-config ./configure --prefix=/extra/usr \
WX_CONFIG=/usr/bin/wx-config ./configure --prefix=/usr \
--enable-unicode
make
}
......
......@@ -2,19 +2,19 @@
pkgname=babl
pkgver=0.1.10
pkgrel=2
pkgrel=3
pkgdesc="Dynamic, any to any, pixel format conversion library"
arch=('x86_64')
url="http://gegl.org/babl/"
license=('LGPL3')
depends=('glibc' 'filesystem-extra')
depends=('glibc')
options=('!libtool' '!makeflags')
source=("ftp://ftp.gimp.org/pub/babl/${pkgver%.*}/${pkgname}-${pkgver}.tar.bz2")
md5sums=('9e1542ab5c0b12ea3af076a9a2f02d79')
build() {
cd $srcdir/$pkgname-$pkgver
./configure --prefix=/extra/usr
./configure --prefix=/usr
make
}
......
pkgname=bluegriffon
pkgver=1.7.2
pkgrel=1
pkgrel=2
pkgdesc='The next-generation Web Editor'
url="http://bluegriffon.org/"
arch=('x86_64')
license=('MPL' 'GPL' 'LGPL')
depends=('libpng' 'libjpeg' 'desktop-file-utils' 'libxt' 'mime-types' 'nss' 'shared-mime-info' 'filesystem-extra' 'gtk2')
depends=('libpng' 'libjpeg' 'desktop-file-utils' 'libxt' 'mime-types' 'nss' 'shared-mime-info' 'gtk2')
makedepends=('wget')
install='bluegriffon.install'
source=("http://bluegriffon.org/freshmeat/${pkgver}/bluegriffon-${pkgver}.Ubuntu13.04.x86_64.tar.bz2"
......@@ -17,11 +17,11 @@ md5sums=('fbae6365980d87dde5e4ce044d55be38'
package() {
cd ${srcdir}
mkdir -p ${pkgdir}/extra/usr/{bin,lib,share/{applications,pixmaps}}
cp -R bluegriffon ${pkgdir}/extra/usr/lib/${pkgname}
mkdir -p ${pkgdir}/usr/{bin,lib,share/{applications,pixmaps}}
cp -R bluegriffon ${pkgdir}/usr/lib/${pkgname}
install -m644 ${srcdir}/${pkgname}.desktop ${pkgdir}/extra/usr/share/applications/
install -m644 ${srcdir}/bluegriffon/chrome/icons/default/default48.png ${pkgdir}/extra/usr/share/pixmaps/${pkgname}-icon.png
install -m644 ${srcdir}/${pkgname}.desktop ${pkgdir}/usr/share/applications/
install -m644 ${srcdir}/bluegriffon/chrome/icons/default/default48.png ${pkgdir}/usr/share/pixmaps/${pkgname}-icon.png
ln -sf /extra/usr/lib/bluegriffon/bluegriffon $pkgdir/extra/usr/bin/
ln -sf /usr/lib/bluegriffon/bluegriffon $pkgdir/usr/bin/
}
......@@ -4,7 +4,7 @@
pkgname=chromium
pkgver=30.0.1599.114
pkgrel=2
pkgrel=3
_verbld=${pkgver}-1 # used for libpdf and pepper-flash
_pepperflashver=11.9.900.117
_toolchains_rev=12029
......@@ -12,7 +12,7 @@ pkgdesc="The open-source project behind Google Chrome, an attempt at creating a
arch=('x86_64')
url="http://www.chromium.org/"
license=('BSD')
depends=('gtk2' 'dbus-glib' 'nss' 'alsa-lib' 'xdg-utils' 'bzip2' 'libevent' 'libxss' 'libgcrypt' 'ttf-dejavu' 'dbus' 'desktop-file-utils' 'hicolor-icon-theme' 'systemd' 'speech-dispatcher' 'flac' 'opus' 'libxml2' 'libpulse' 'icu' 'v8' 'zlib' 'filesystem-extra')
depends=('gtk2' 'dbus-glib' 'nss' 'alsa-lib' 'xdg-utils' 'bzip2' 'libevent' 'libxss' 'libgcrypt' 'ttf-dejavu' 'dbus' 'desktop-file-utils' 'hicolor-icon-theme' 'systemd' 'speech-dispatcher' 'flac' 'opus' 'libxml2' 'libpulse' 'icu' 'v8' 'zlib')
makedepends=('python2' 'perl' 'gperf' 'yasm' 'mesa' 'libgnome-keyring' 'elfutils' 'lib32-gcc-libs' 'subversion' 'ninja')
install=chromium.install
source=(http://commondatastorage.googleapis.com/chromium-browser-official/${pkgname}-${pkgver}.tar.xz
......@@ -44,9 +44,9 @@ sha1sums=('70477efec5b6fa1b4ca81f3087e40bf7fd377cf4'
'4dba1c5504537a3565cd93345e4c6eabd98d5d05'
'd9f4b2b624e8580c947ddf2377480122b295460f'
'b595fda0dc2f18af1723976a9bf9c5725d3ec31c'
'd02e7eaaa5de9407d8744a03a1306c117b659098'
'fa93e2d3d4d52a1a29a1c446092a158f05751fcc'
'3d9663f614113c137016fadb963e150f11f17402'
'3ab45403f3e8ddfeeba6a5aee9f683d57883fb90'
'19eff765ec1316f4ae057d48919b2fdd6b3a5bea'
'11332bcd0318d573bea1aa0744213a5d006aecc4'
'5cd50202719569cb9bc6624ad0bb3c9cbbc5a828'
'51065e45d0060374346f3c756a6b1cd0d1fb1323'
'4ac33284c534b5117741b551cc531589cfa08d75'
......@@ -142,49 +142,49 @@ build() {
package() {
cd "$srcdir/$pkgname-$pkgver"
install -D out/Release/chrome ${pkgdir}/extra/usr/lib/chromium/chromium
install -D out/Release/chrome ${pkgdir}/usr/lib/chromium/chromium
install -Dm4755 -o root -g root out/Release/chrome_sandbox \
"$pkgdir/extra/usr/lib/chromium/chrome-sandbox"
"$pkgdir/usr/lib/chromium/chrome-sandbox"
cp out/Release/{*.pak,libffmpegsumo.so,nacl_helper{,_bootstrap}} \
out/Release/{libppGoogleNaClPluginChrome.so,nacl_irt_*.nexe} \
"$pkgdir/extra/usr/lib/chromium/"
"$pkgdir/usr/lib/chromium/"
# override command-line options
install -Dm644 "$srcdir/chromium.default" "$pkgdir/extra/etc/chromium/default"
install -Dm644 "$srcdir/chromium.default" "$pkgdir/etc/chromium/default"
cp -a out/Release/locales out/Release/resources "$pkgdir/extra/usr/lib/chromium/"
cp -a out/Release/locales out/Release/resources "$pkgdir/usr/lib/chromium/"
find "$pkgdir/extra/usr/lib/chromium/" -name '*.d' -type f -delete
find "$pkgdir/usr/lib/chromium/" -name '*.d' -type f -delete
install -Dm644 out/Release/chrome.1 "$pkgdir/extra/usr/share/man/man1/chromium.1"
install -Dm644 out/Release/chrome.1 "$pkgdir/usr/share/man/man1/chromium.1"
install -Dm644 "$srcdir/chromium.desktop" \
"$pkgdir/extra/usr/share/applications/chromium.desktop"
"$pkgdir/usr/share/applications/chromium.desktop"
for size in 22 24 48 64 128 256; do
install -Dm644 "chrome/app/theme/chromium/product_logo_$size.png" \
"$pkgdir/extra/usr/share/icons/hicolor/${size}x${size}/apps/chromium.png"
"$pkgdir/usr/share/icons/hicolor/${size}x${size}/apps/chromium.png"
done
for size in 16 32; do
install -Dm644 "chrome/app/theme/default_100_percent/chromium/product_logo_$size.png" \
"$pkgdir/extra/usr/share/icons/hicolor/${size}x${size}/apps/chromium.png"
"$pkgdir/usr/share/icons/hicolor/${size}x${size}/apps/chromium.png"
done
install -D "$srcdir/chromium.sh" "$pkgdir/extra/usr/bin/chromium"
install -D "$srcdir/chromium.sh" "$pkgdir/usr/bin/chromium"
install -Dm644 LICENSE "$pkgdir/extra/usr/share/licenses/chromium/LICENSE"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/chromium/LICENSE"
#### PepperFlash ####
cd "$srcdir"
install -d "$pkgdir/extra/usr/lib/PepperFlash"
install -m644 opt/google/chrome/PepperFlash/* "$pkgdir/extra/usr/lib/PepperFlash"
install -d "$pkgdir/usr/lib/PepperFlash"
install -m644 opt/google/chrome/PepperFlash/* "$pkgdir/usr/lib/PepperFlash"
sed -i "s/flashver=.*/flashver=$_pepperflashver/" "$startdir/chromium.install"
install -Dm644 "$srcdir/license.html" "$pkgdir/extra/usr/share/licenses/$pkgname/license.html"
install -Dm644 "$srcdir/license.html" "$pkgdir/usr/share/licenses/$pkgname/license.html"
#### libpdf ####
install -d "${pkgdir}/extra/usr/lib/chromium"
install -m644 opt/google/chrome/libpdf.so "${pkgdir}/extra/usr/lib/chromium"
install -d "${pkgdir}/usr/lib/chromium"
install -m644 opt/google/chrome/libpdf.so "${pkgdir}/usr/lib/chromium"
}
......@@ -2,4 +2,4 @@
# Options to pass to chromium
# flash-version updated dynamically with .install file
CHROMIUM_FLAGS="--ppapi-flash-path=/extra/usr/lib/PepperFlash/libpepflashplayer.so --ppapi-flash-version=1.2.3.4"
\ No newline at end of file
CHROMIUM_FLAGS="--ppapi-flash-path=/usr/lib/PepperFlash/libpepflashplayer.so --ppapi-flash-version=1.2.3.4"
\ No newline at end of file
......@@ -61,7 +61,7 @@ Comment[de]=Chromium web-browser bundel, mit pdf, flash und gtalk plugin
Comment[en_GB]=Chromium web-browser bundle, including pdf, pepper-flash and gtalk plugin
Exec=chromium %U
Terminal=false
Icon=chromium.png
Icon=chromium
Type=Application
Categories=Application;Network;WebBrowser;
MimeType=text/html;text/xml;application/xhtml_xml;
[ -f extra/etc/chromium-browser/default ] && _default='extra/etc/chromium-browser/default'
[ -f extra/etc/chromium/default ] && _default='extra/etc/chromium/default'
[ -f etc/chromium-browser/default ] && _default='etc/chromium-browser/default'
[ -f etc/chromium/default ] && _default='etc/chromium/default'
flashver=11.9.900.117
instructions() {
......@@ -29,7 +29,7 @@ post_upgrade() {
if [[ $(cat "$_default") == *ppapi* ]]; then
sed -i "s/ppapi-flash-version=.*[0-9]/ppapi-flash-version=$flashver/g" "$_default"
else
sed -i '/CHROMIUM_FLAGS/s|"$| --ppapi-flash-path=/extra/usr/lib/PepperFlash/libpepflashplayer.so --ppapi-flash-version='$flashver'"|' "$_default"
sed -i '/CHROMIUM_FLAGS/s|"$| --ppapi-flash-path=/usr/lib/PepperFlash/libpepflashplayer.so --ppapi-flash-version='$flashver'"|' "$_default"
fi
}
......
......@@ -2,8 +2,8 @@
# Override command-line options
# Based on Gentoo's chromium package (and by extension, Debian's)
if [[ -f /extra/etc/chromium/default ]]; then
. /extra/etc/chromium/default
if [[ -f /etc/chromium/default ]]; then
. /etc/chromium/default
fi
# Prefer user defined CHROMIUM_USER_FLAGS (from env) over system
......@@ -14,5 +14,5 @@ CHROMIUM_FLAGS=${CHROMIUM_USER_FLAGS:-$CHROMIUM_FLAGS}
export CHROME_WRAPPER=$(readlink -f "$0")
export CHROME_DESKTOP=chromium.desktop
exec /extra/usr/lib/chromium/chromium $CHROMIUM_FLAGS "$@"
exec /usr/lib/chromium/chromium $CHROMIUM_FLAGS "$@"
pkgname=eclipse
pkgver=4.3.1
pkgrel=1
pkgrel=2
_date=201309111000
pkgdesc="An IDE for Java and other languages."
arch=('x86_64')
url="http://eclipse.org"
depends=('java-environment' 'gtk2' 'unzip' 'libwebkit-gtk2' 'libxtst' 'filesystem-extra')
depends=('java-environment' 'gtk2' 'unzip' 'libwebkit-gtk2' 'libxtst')
install=${pkgname}.install
makedepends=('zip')
license=("EPL/1.0")
......@@ -32,29 +32,30 @@ package() {
cd "${srcdir}/${pkgname}"
# install eclipse
install -d -m755 "${pkgdir}/extra/usr/share"
cp -ar "${srcdir}/eclipse" "${pkgdir}/extra/usr/share/"
install -d -m755 "${pkgdir}/usr/share"
cp -ar "${srcdir}/eclipse" "${pkgdir}/usr/share/"
# install misc
install -d "${pkgdir}/extra/usr/bin" \
"${pkgdir}/extra/usr/share/applications" \
"${pkgdir}/extra/usr/share/icons/hicolor"/{16x16,32x32,48x48,256x256}/apps
install -d "${pkgdir}/usr/bin" \
"${pkgdir}/usr/share/applications" \
"${pkgdir}/usr/share/icons/hicolor"/{16x16,32x32,48x48,256x256}/apps
# install bin symlink
ln -s "/extra/usr/share/eclipse/eclipse" "$pkgdir/extra/usr/bin/"
install -m644 "${srcdir}/eclipse.desktop" "${pkgdir}/extra/usr/share/applications/"
ln -s "/usr/share/eclipse/eclipse" "$pkgdir/usr/bin/"
install -m644 "${srcdir}/eclipse.desktop" "${pkgdir}/usr/share/applications/"
# install icon
ln -s "/extra/usr/share/eclipse/plugins/org.eclipse.sdk_${pkgver}.v${_date}/eclipse.png" "${pkgdir}/extra/usr/share/icons/hicolor/16x16/apps/eclipse.png"
ln -s "/extra/usr/share/eclipse/plugins/org.eclipse.sdk_${pkgver}.v${_date}/eclipse32.png" "${pkgdir}/extra/usr/share/icons/hicolor/32x32/apps/eclipse.png"
ln -s "/extra/usr/share/eclipse/plugins/org.eclipse.sdk_${pkgver}.v${_date}/eclipse48.png" "${pkgdir}/extra/usr/share/icons/hicolor/48x48/apps/eclipse.png"
ln -s "/extra/usr/share/eclipse/plugins/org.eclipse.sdk_${pkgver}.v${_date}/eclipse256.png" "${pkgdir}/extra/usr/share/icons/hicolor/256x256/apps/eclipse.png"
ln -s "/usr/share/eclipse/plugins/org.eclipse.sdk_${pkgver}.v${_date}/eclipse.png" "${pkgdir}/usr/share/icons/hicolor/16x16/apps/eclipse.png"
ln -s "/usr/share/eclipse/plugins/org.eclipse.sdk_${pkgver}.v${_date}/eclipse32.png" "${pkgdir}/usr/share/icons/hicolor/32x32/apps/eclipse.png"
ln -s "/usr/share/eclipse/plugins/org.eclipse.sdk_${pkgver}.v${_date}/eclipse48.png" "${pkgdir}/usr/share/icons/hicolor/48x48/apps/eclipse.png"
ln -s "/usr/share/eclipse/plugins/org.eclipse.sdk_${pkgver}.v${_date}/eclipse256.png" "${pkgdir}/usr/share/icons/hicolor/256x256/apps/eclipse.png"
install -D -m644 "${srcdir}/eclipse.png" \
"${pkgdir}/extra/usr/share/icons/hicolor/512x512/apps/eclipse.png"
"${pkgdir}/usr/share/icons/hicolor/512x512/apps/eclipse.png"
# license
install -d -m755 "${pkgdir}/usr/share/licenses/eclipse/"
mv $pkgdir/usr/share/eclipse/epl-v10.html "$pkgdir/usr/share/licenses/eclipse/epl-v10.html"
}
......
pkgname=emacs
pkgver=24.3
pkgrel=3
pkgrel=4
pkgdesc="The extensible, customizable, self-documenting real-time display editor"
arch=('x86_64')
url="http://www.gnu.org/software/emacs/emacs.html"
......@@ -13,7 +13,7 @@ md5sums=('ea9ed000ca165280265aabb55b9afbd7'
build() {
cd "$srcdir"/$pkgname-$pkgver
./configure --prefix=/extra/usr --sysconfdir=/extra/etc --libexecdir=/extra/usr/lib \
./configure --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib \
--localstatedir=/var --with-x-toolkit=gtk3 --with-xft
make
}
......@@ -23,13 +23,13 @@ package() {
make DESTDIR="$pkgdir" install
# remove conflict with ctags package
mv "$pkgdir"/extra/usr/bin/{ctags,ctags.emacs}
mv "$pkgdir"/extra/usr/share/man/man1/{ctags.1.gz,ctags.emacs.1}
mv "$pkgdir"/usr/bin/{ctags,ctags.emacs}
mv "$pkgdir"/usr/share/man/man1/{ctags.1.gz,ctags.emacs.1}
# remove conflict with texinfo
rm "$pkgdir"/extra/usr/share/info/info.info.gz
rm "$pkgdir"/usr/share/info/info.info.gz
# fix user/root permissions on usr/share files
find "$pkgdir"/extra/usr/share/emacs/$pkgver -exec chown root:root {} \;
find "$pkgdir"/usr/share/emacs/$pkgver -exec chown root:root {} \;
# fix perms on /var/games
chmod 775 "$pkgdir"/var/games
chmod 775 "$pkgdir"/var/games/emacs
......
post_install() {
if res="$(extra/usr/bin/gtk-query-immodules-2.0)"; then
echo "$res" > extra/etc/gtk-2.0/gtk.immodules
if res="$(usr/bin/gtk-query-immodules-2.0)"; then
echo "$res" > etc/gtk-2.0/gtk.immodules
fi
}
......
post_install() {
extra/usr/bin/gtk-query-immodules-3.0 --update-cache
usr/bin/gtk-query-immodules-3.0 --update-cache
}
post_upgrade() {
......
pkgname=filezilla
pkgver=3.7.3
pkgrel=1
pkgrel=2
pkgdesc="Fast and reliable FTP, FTPS and SFTP client"
arch=('x86_64')
url="http://filezilla-project.org/"
license=('GPL')
depends=('dbus-core' 'xdg-utils' 'wxgtk' 'libidn' 'libsm' 'libxxf86vm' 'hicolor-icon-theme' 'sqlite3' 'filesystem-extra')
depends=('dbus-core' 'xdg-utils' 'wxgtk' 'libidn' 'libsm' 'libxxf86vm' 'hicolor-icon-theme' 'sqlite3')
install=${pkgname}.install
changelog=${pkgname}.changelog
source=("http://downloads.sourceforge.net/project/filezilla/FileZilla_Client/${pkgver}/FileZilla_${pkgver}_src.tar.bz2"
......@@ -19,7 +19,7 @@ build() {
cd "${pkgname}-${pkgver}"
./autogen.sh
./configure \
--prefix=/extra/usr \
--prefix=/usr \
--disable-manualupdatecheck \
--disable-autoupdatecheck \
--disable-static \
......@@ -33,12 +33,12 @@ package() {
make DESTDIR="${pkgdir}" install
install -dm755 "${pkgdir}/extra/usr/share/filezilla/resources/oxygen"
cp -dpr --no-preserve=ownership "${srcdir}/oxygen" "${pkgdir}/extra/usr/share/filezilla/resources/"
install -dm755 "${pkgdir}/usr/share/filezilla/resources/oxygen"
cp -dpr --no-preserve=ownership "${srcdir}/oxygen" "${pkgdir}/usr/share/filezilla/resources/"
# Install changelog
install -Dm644 NEWS "${startdir}/${pkgname}.changelog"
install -dm755 "${pkgdir}/extra/usr/share/doc/${pkgname}"
install -Dm644 {AUTHORS,ChangeLog,README} "${pkgdir}/extra/usr/share/doc/${pkgname}/"
install -dm755 "${pkgdir}/usr/share/doc/${pkgname}"
install -Dm644 {AUTHORS,ChangeLog,README} "${pkgdir}/usr/share/doc/${pkgname}/"
}
pkgname=firefox-i18n
pkgver=25.0
pkgrel=1
pkgrel=2
pkgdesc="Language pack for Firefox"
arch=('any')
url="http://www.mozilla.com/"
license=('MPL' 'GPL')
depends=("firefox-kde>=$pkgver" 'filesystem-extra')
depends=("firefox-kde>=$pkgver")
_languages=(
'ach "Acoli"'
......@@ -115,7 +115,7 @@ package() {
for _lang in "${_languages[@]}"; do
_locale=${_lang%% *}
install -Dm644 firefox-i18n-$pkgver-${_locale}.xpi \
"$pkgdir/extra/usr/lib/firefox/browser/extensions/langpack-${_locale}@firefox.mozilla.org.xpi"
"$pkgdir/usr/lib/firefox/browser/extensions/langpack-${_locale}@firefox.mozilla.org.xpi"
done
}
......
......@@ -2,7 +2,7 @@
pkgname=firefox-kde
pkgver=25.0
pkgrel=1
pkgrel=2
pkgdesc="Standalone web browser from mozilla.org with OpenSUSE patch, integrate better with KDE"
_kmozillahelper_obsver=b88c72dfdc858f6209feb123227bd7df
_kmozillahelper_pkgname=kmozillahelper
......@@ -10,7 +10,7 @@ _kmozillahelper_pkgver=0.6.4
url='http://www.mozilla.org/projects/firefox'
arch=('x86_64')
license=('MPL' 'GPL' 'LGPL')
depends=('gtk2' 'startup-notification' 'libnotify' 'alsa-lib' 'gstreamer0.10' 'gstreamer0.10-base' 'libxt' 'dbus-glib' 'libevent' 'filesystem-extra' 'kdelibs')
depends=('gtk2' 'startup-notification' 'libnotify' 'alsa-lib' 'gstreamer0.10' 'gstreamer0.10-base' 'libxt' 'dbus-glib' 'libevent' 'kdelibs')
makedepends=('zip' 'pkg-config' 'diffutils' 'python2' 'wireless_tools' 'unzip' 'autoconf2.13' 'mesa' 'yasm' 'cmake' 'automoc4' 'libpulse')
optdepends=('networkmanager: Location detection via available WiFi networks'
'libpulse: PulseAudio audio driver')
......@@ -126,7 +126,7 @@ build_firefox() {
cd "mozilla-release"
export PATH="$srcdir/path:$PATH"
export LDFLAGS="$LDFLAGS -Wl,-rpath,/extra/usr/lib/firefox"
export LDFLAGS="$LDFLAGS -Wl,-rpath,/usr/lib/firefox"
export PYTHON="/usr/bin/python2"
make -j1 -f client.mk build MOZ_MAKE_FLAGS="${MAKEFLAGS}"
......@@ -143,28 +143,28 @@ package() {
install -Dm644 ../kde.js "obj-ff/dist/bin/defaults/pref/kde.js"
make -j1 -f client.mk MOZ_PKG_FATAL_WARNINGS=0 package
#make -j1 -f client.mk DESTDIR="$pkgdir" install
mkdir -p $pkgdir/extra/usr/lib/
tar -C $pkgdir/extra/usr/lib/ -xf obj-ff/dist/firefox-$pkgver.en-US.linux-${CARCH}.tar.bz2
mkdir -p $pkgdir/usr/lib/
tar -C $pkgdir/usr/lib/ -xf obj-ff/dist/firefox-$pkgver.en-US.linux-${CARCH}.tar.bz2
install -Dm644 ../vendor.js "$pkgdir/extra/usr/lib/firefox/defaults/preferences/vendor.js"
install -Dm644 ../kde.js "$pkgdir/extra/usr/lib/firefox/defaults/preferences/kde.js"
install -Dm644 ../duckduckgo.xml "$pkgdir/extra/usr/lib/firefox/searchplugins/duckduckgo.xml"
install -Dm644 ../vendor.js "$pkgdir/usr/lib/firefox/defaults/preferences/vendor.js"
install -Dm644 ../kde.js "$pkgdir/usr/lib/firefox/defaults/preferences/kde.js"
install -Dm644 ../duckduckgo.xml "$pkgdir/usr/lib/firefox/searchplugins/duckduckgo.xml"
for i in 16 22 24 32 48 256; do
install -Dm644 browser/branding/official/default$i.png \
"$pkgdir/extra/usr/share/icons/hicolor/${i}x${i}/apps/firefox.png"
"$pkgdir/usr/share/icons/hicolor/${i}x${i}/apps/firefox.png"
done
install -Dm644 ../firefox.desktop \
"$pkgdir/extra/usr/share/applications/firefox.desktop"
"$pkgdir/usr/share/applications/firefox.desktop"
mkdir -p $pkgdir/extra/usr/bin/
ln -sf /extra/usr/lib/firefox/firefox $pkgdir/extra/usr/bin/
mkdir -p $pkgdir/usr/bin/
ln -sf /usr/lib/firefox/firefox $pkgdir/usr/bin/
# Use system-provided dictionaries
rm -rf "$pkgdir"/extra/usr/lib/firefox/{dictionaries,hyphenation}
ln -s /usr/share/hunspell "$pkgdir/extra/usr/lib/firefox/dictionaries"
ln -s /usr/share/hyphen "$pkgdir/extra/usr/lib/firefox/hyphenation"
rm -rf "$pkgdir"/usr/lib/firefox/{dictionaries,hyphenation}
ln -s /usr/share/hunspell "$pkgdir/usr/lib/firefox/dictionaries"
ln -s /usr/share/hyphen "$pkgdir/usr/lib/firefox/hyphenation"
}
......
pkgname=flashplugin
_licensefile='PlatformClients_PC_WWEULA_Combined_20100108_1657.pdf'
pkgver=11.2.202.310
pkgrel=1
pkgrel=2
pkgdesc='Adobe Flash Player'
url='http://labs.adobe.com/technologies/flashplatformruntimes/flashplayer11/'
arch=('x86_64')
depends=('mozilla-common' 'libxt' 'libxpm' 'gtk2' 'nss' 'curl' 'filesystem-extra')
depends=('mozilla-common' 'libxt' 'libxpm' 'gtk2' 'nss' 'curl')
optdepends=('libvdpau: GPU acceleration on Nvidia card')
provides=('flashplayer')
license=('custom')
......@@ -17,20 +17,20 @@ source=("http://fpdownload.macromedia.com/get/flashplayer/pdc/$pkgver/install_fl
'mms.cfg')
md5sums=('34b436d5c9c4e681bd619a6efad84148'
'94ca2aecb409abfe36494d1a7ec7591d'
'31e165d90ffbfdd9d25291b74d68eded')
'f34aae6279b40e0bd2abfb0d9963d7b8')
package () {
cd ${srcdir}
# Plugin install in /extra
install -Dm755 libflashplayer.so "${pkgdir}/extra/usr/lib/mozilla/plugins/libflashplayer.so"
install -Dm644 "${_licensefile}" "${pkgdir}/extra/usr/share/licenses/${pkgname}/LICENSE.pdf"
install -Dm644 ${srcdir}/mms.cfg "${pkgdir}/extra/etc/adobe/mms.cfg"
install -Dm755 usr/bin/flash-player-properties "${pkgdir}/extra/usr/bin/flash-player-properties"
install -Dm644 usr/share/applications/flash-player-properties.desktop "${pkgdir}/extra/usr/share/applications/flash-player-properties.desktop"
install -Dm755 libflashplayer.so "${pkgdir}/usr/lib/mozilla/plugins/libflashplayer.so"
install -Dm644 "${_licensefile}" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.pdf"
install -Dm644 ${srcdir}/mms.cfg "${pkgdir}/etc/adobe/mms.cfg"
install -Dm755 usr/bin/flash-player-properties "${pkgdir}/usr/bin/flash-player-properties"
install -Dm644 usr/share/applications/flash-player-properties.desktop "${pkgdir}/usr/share/applications/flash-player-properties.desktop"
for i in 16x16 22x22 24x24 32x32 48x48; do
install -Dm644 usr/share/icons/hicolor/${i}/apps/flash-player-properties.png \
"${pkgdir}/extra/usr/share/icons/hicolor/${i}/apps/flash-player-properties.png"
"${pkgdir}/usr/share/icons/hicolor/${i}/apps/flash-player-properties.png"
done
......
#Hardware video decoding
EnableLinuxHWVideoDecode=0
#EnableLinuxHWVideoDecode=1
pkgname=('gcompris')
pkgver=13.11
pkgrel=1
pkgrel=2
pkgdesc="Educational software suite comprising of numerous activities for children aged 2 to 10"
arch=('x86_64')
url="http://gcompris.net/"
license=('GPL3')
depends=('pygtk' 'python-pyxml' 'librsvg' 'python-pysqlite'
'gstreamer0.10-base-plugins' 'filesystem-extra')
'gstreamer0.10-base-plugins')
makedepends=('texinfo' 'texi2html' 'intltool' 'gettext' 'gnuchess')
optdepends=('gnucap: for computer simulation within the electricity activity'
'tuxpaint: for the painting activity'
......@@ -17,7 +17,7 @@ md5sums=('7c3396c02e44bbf72424ca12bfff9cf3')
build() {
cd "$srcdir/$pkgname-$pkgver"
./configure --prefix=/extra/usr
./configure --prefix=/usr
make
}
......@@ -26,5 +26,5 @@ package() {
make DESTDIR="$pkgdir" install
# Fix path for editor
sed -i -e "~s~gcompris -a~gcompris -l /extra/usr/lib/gcompris/ -a~" ${pkgdir}/extra/usr/share/applications/gcompris-edit.desktop
sed -i -e "~s~gcompris -a~gcompris -l /usr/lib/gcompris/ -a~" ${pkgdir}/usr/share/applications/gcompris-edit.desktop
}
......@@ -2,7 +2,7 @@
pkgname=gegl
pkgver=0.2.0
pkgrel=4
pkgrel=5
pkgdesc="Graph based image processing framework."
arch=('x86_64')
url="http://www.gegl.org/"
......@@ -17,7 +17,7 @@ sha1sums=('764cc66cb3c7b261b8fc18a6268a0e264a91d573' 'c10fd988c634fcf0948cc91a51
build() {
cd $srcdir/$pkgname-$pkgver
patch -Np1 -i $srcdir/gentoo-gegl-0.2.0-ffmpeg-0.11.diff
./configure --prefix=/extra/usr --with-sdl --with-openexr --with-librsvg --with-libavformat --with-jasper --disable-docs || return 1
./configure --prefix=/usr --with-sdl --with-openexr --with-librsvg --with-libavformat --with-jasper --disable-docs || return 1
make
}
......
pkgname=gimp
pkgver=2.8.8
_pkgver=2.8
pkgrel=1
pkgrel=2
pkgdesc="GNU Image Manipulation Program (Development Version)"
arch=('x86_64')
url="http://www.gimp.org/"
license=('GPL3' 'LGPL3')
depends=('libpng' 'pygtk' 'lcms' 'libxpm' 'libwmf' 'librsvg' 'libmng' 'dbus-glib' 'filesystem-extra' \
depends=('libpng' 'pygtk' 'lcms' 'libxpm' 'libwmf' 'librsvg' 'libmng' 'dbus-glib' \
'jasper' 'libexif' 'gegl' 'desktop-file-utils' 'hicolor-icon-theme' 'babl')
makedepends=('intltool' 'libwebkit-gtk2' 'poppler-glib' 'alsa-lib' 'iso-codes' 'curl' 'ghostscript')
optdepends=('gutenprint: for sophisticated printing only as gimp has built-in cups print support'
......@@ -25,7 +25,7 @@ md5sums=('ef2547c3514a1096931637bd6250635a'
build() {
cd "${srcdir}/gimp-${pkgver}"
PYTHON=/usr/bin/python2 ./configure --prefix=/extra/usr --sysconfdir=/extra/etc \
PYTHON=/usr/bin/python2 ./configure --prefix=/usr --sysconfdir=/etc \
--enable-mp --enable-gimp-console --enable-python --with-libcurl \
--with-gif-compression=lzw --without-aa --without-hal --without-gvfs --without-gnomevfs
make
......@@ -34,11 +34,11 @@ build() {
package() {
cd "${srcdir}/gimp-${pkgver}"
make DESTDIR="${pkgdir}" install
sed -i 's|#![ ]*/usr/bin/env python|#!/usr/bin/env python2|' "${pkgdir}"/extra/usr/lib/gimp/2.0/plug-ins/*.py
install -D -m644 "${srcdir}/linux.gpl" "${pkgdir}/extra/usr/share/gimp/2.0/palettes/Linux.gpl"
sed -i 's|#![ ]*/usr/bin/env python|#!/usr/bin/env python2|' "${pkgdir}"/usr/lib/gimp/2.0/plug-ins/*.py
install -D -m644 "${srcdir}/linux.gpl" "${pkgdir}/usr/share/gimp/2.0/palettes/Linux.gpl"
ln -sf gimp-console-${pkgver}.1.gz "${pkgdir}/extra/usr/share/man/man1/gimp-console.1.gz"
ln -sf gimprc-${pkgver}.5.gz "${pkgdir}/extra/usr/share/man/man5/gimprc.5.gz"
ln -sf gimptool-2.0.1.gz "${pkgdir}/extra/usr/share/man/man1/gimptool.1.gz"
ln -s gimp-${pkgver}.1.gz "${pkgdir}/extra/usr/share/man/man1/gimp.1.gz"
ln -sf gimp-console-${pkgver}.1.gz "${pkgdir}/usr/share/man/man1/gimp-console.1.gz"
ln -sf gimprc-${pkgver}.5.gz "${pkgdir}/usr/share/man/man5/gimprc.5.gz"
ln -sf gimptool-2.0.1.gz "${pkgdir}/usr/share/man/man1/gimptool.1.gz"
ln -s gimp-${pkgver}.1.gz "${pkgdir}/usr/share/man/man1/gimp.1.gz"
}
pkgname=gnet
pkgver=2.0.8
pkgrel=2
pkgrel=3
pkgdesc="GNet is a simple network library. It is written in C, object-oriented, and built upon GLib."
arch=('x86_64')
url="https://live.gnome.org/GNetLibrary"
license=('LGPL')
depends=('glib2' 'filesystem-extra')
options=('!libtool')
depends=('glib2')
install=install
source=("http://ftp.gnome.org/pub/GNOME/sources/gnet/${pkgver%.*}/${pkgname}-${pkgver}.tar.bz2")
md5sums=('93327d2fca333d7e54ba2cf54e071165')
......@@ -15,7 +14,7 @@ sha1sums=('74a33dd25cc594b874e3a5171795efd99e567387')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
./configure --prefix=/extra/usr \
./configure --prefix=/usr \
--disable-gtk-doc \
CFLAGS="$(pkg-config --cflags glib-2.0)" \
LIBS="$(pkg-config --libs glib-2.0)" \
......
......@@ -6,7 +6,7 @@
pkgbase=gtk2
pkgname=('gtk2' 'gtk-update-icon-cache')
pkgver=2.24.17
pkgrel=1
pkgrel=2
arch=('x86_64')
url="http://www.gtk.org/"
makedepends=('atk' 'pango' 'libxcursor' 'libxinerama' 'libxrandr' 'libxi' 'libxcomposite' 'libxdamage'
......@@ -18,12 +18,19 @@ source=("http://ftp.gnome.org/pub/gnome/sources/gtk+/2.24/gtk+-$pkgver.tar.xz"
md5sums=('a10cc43fad8d64f8893d779b1f8322ff'
'22355df723f6ca358e30e6b8f0baace5')
prepare() {
cd "${srcdir}/gtk+-${pkgver}"
patch -Np1 -i "$srcdir/xid-collision-debug.patch"
}
build() {
cd "$srcdir/gtk+-$pkgver"
patch -Np1 -i "$srcdir/xid-collision-debug.patch"
CXX=/bin/false ./configure --prefix=/extra/usr \
--sysconfdir=/extra/etc \
autoreconf -vfi
CXX=/bin/false ./configure --prefix=/usr \
--sysconfdir=/etc \
--localstatedir=/var \
--with-xinput=yes
......@@ -42,10 +49,10 @@ package_gtk2() {
cd "$srcdir/gtk+-$pkgver"
make DESTDIR="$pkgdir" install
sed -i "s#env python#env python2#" $pkgdir/extra/usr/bin/gtk-builder-convert
echo 'gtk-fallback-icon-theme = "gnome"' > "$pkgdir/e