Commit 4fe09dc5 authored by Xuetian Weng's avatar Xuetian Weng

lib32-{systemd,util-linux}: update against their 64bit counterpart

parent 848d1a36
pkgname=lib32-systemd
_pkgbasename=systemd
pkgver=225
pkgver=227
pkgrel=1
pkgdesc="system and service manager (32-bit)"
arch=('x86_64')
url="http://www.freedesktop.org/wiki/Software/systemd"
license=('GPL2' 'LGPL2.1' 'MIT')
depends=('lib32-glib2' 'lib32-libgcrypt' 'lib32-xz' 'lib32-curl' 'lib32-libcap' 'lib32-bzip2' "$_pkgbasename=$pkgver")
makedepends=('lib32-gcc-libs' 'gcc-multilib' 'lib32-libidn' 'lib32-acl' 'intltool' 'gperf' 'docbook-xml' 'docbook-xsl')
source=("git://github.com/systemd/systemd.git#tag=v$pkgver"
)
depends=('lib32-libgcrypt' 'lib32-xz' 'lib32-libcap' 'lib32-acl' 'lib32-libidn' 'lib32-gcc-libs' "$_pkgbasename=$pkgver")
makedepends=('lib32-gcc-libs' 'gcc-multilib' 'lib32-libidn' 'lib32-glib2' 'intltool' 'gperf'
'lib32-curl' 'lib32-bzip2' 'git')
source=("git://github.com/systemd/systemd.git#tag=v$pkgver")
md5sums=('SKIP')
prepare() {
......@@ -25,8 +25,7 @@ build() {
cd "${_pkgbasename}"
# LTO currently breaks the build because of libtool failures
CFLAGS+=' -fno-lto'
local timeservers=({0..3}.chakra.pool.ntp.org)
./configure \
--libexecdir=/usr/lib32 \
......@@ -44,13 +43,15 @@ build() {
--disable-networkd \
--disable-blkid \
--disable-libiptc \
--disable-manpages \
--without-python \
--disable-libcryptsetup \
--disable-microhttpd \
--disable-qrencode \
--disable-xkbcommon \
--with-sysvinit-path= \
--with-sysvrcnd-path=
--with-sysvrcnd-path= \
--with-ntp-servers="${timeservers[*]}"
make
}
......
......@@ -4,7 +4,7 @@
_pkgbasename=util-linux
pkgname=lib32-$_pkgbasename
pkgver=2.26.2
pkgver=2.27
_pkgver=(${pkgver//./ })
_pkgver=${_pkgver[0]}.${_pkgver[1]}
pkgrel=1
......@@ -17,7 +17,7 @@ makedepends=('gcc-multilib')
license=('GPL2')
options=('!libtool' '!emptydirs')
source=("ftp://ftp.kernel.org/pub/linux/utils/util-linux/v${_pkgver}/util-linux-$pkgver.tar.xz")
md5sums=('9bdf368c395f1b70325d0eb22c7f48fb')
md5sums=('5b06bbda9309624ee7add15bc8d8ca22')
build() {
cd "$_pkgbasename-$pkgver"
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment