Commit fc9dfd54 authored by Chaoting Liu's avatar Chaoting Liu

lib32-libpulse: update to 6.0

parent d51c34a2
......@@ -3,24 +3,21 @@
_pkgbasename=pulseaudio
pkgname=lib32-libpulse
pkgdesc="A featureful, general-purpose sound server. (32-bit client libraries)"
pkgver=5.0
pkgver=6.0
pkgrel=1
arch=('x86_64')
url="http://pulseaudio.org/"
license=('GPL' 'LGPL')
depends=(lib32-{dbus-core,xcb-util,json-c,systemd}
lib32-lib{asyncns,cap,xtst,sm,sndfile,samplerate}
lib32-lib{asyncns,cap,xtst,sm,sndfile}
'webrtc-audio-processing' 'systemd'
"$_pkgbasename=${pkgver}")
makedepends=('pkgconfig' 'gcc-multilib' 'lib32-libtool' 'intltool'
'lib32-glib2' 'lib32-speex')
optdepends=('lib32-alsa-plugins: ALSA support')
provides=('lib32-pulseaudio')
conflicts=('lib32-pulseaudio')
replaces=('lib32-pulseaudio')
options=(!emptydirs !libtool)
source=("http://freedesktop.org/software/pulseaudio/releases/pulseaudio-${pkgver}.tar.xz")
sha256sums=('99c13a8b1249ddbd724f195579df79484e9af6418cecf6a15f003a7f36caf939')
sha256sums=('b50640e0b80b1607600accfad2e45aabb79d379bf6354c9671efa2065477f6f6')
_libs="libpulse.la libpulse-simple.la libpulse-mainloop-glib.la"
_pkglibs="libpulsecommon-${pkgver}.la libpulsedsp.la"
......@@ -40,6 +37,9 @@ build() {
--disable-hal \
--disable-tcpwrap \
--disable-rpath \
--disable-bluez5-ofono-headset \
--enable-bluez5-native-headset \
--disable-bluez4 \
--disable-default-build-tests
# fight unused direct deps
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment